Posts created by tinkz2007

 
 
I have the same issue as all the others listed on here. Very frustrating to get so far but not be able to finish the game.
 
 
 posted in Katy and Bob: Safari Cafe Collector's Edition on Sep 29, 17 6:07 AM
Played the trial with no problems, bought the game, played it with no problems, on going back into the game the following day, it won't go past the first two title pages (i.e. the big fish page and the logo page) I then get a blank screen. I have removed and re-installed the game but still have the same issue. I am playing this on PC
 
 
 posted in Elven Legend 3: The New Menace Collector's Edition on Jul 28, 16 6:47 AM
Oudespoor wrote:Level 37, I cannot pick up the Blacksmith's Hammer, either before or after fixing the hole that it sits over on the pathway. Anybody else have this problem. Have tried collecting it first before getting the ore pieces as well as replayed tried to get it last, both times it won't let me pick it up.

I also have this same problem on level 37 with the Blacksmith's Hammer, I have tried restarting the game too, but to no avail. Still cannot pick up the hammer - very frustrating.
 
 
 posted in Hidden Object: Home Makeover on Oct 15, 15 11:15 AM
I'm using windows 10 on PC and at level 19 the game freezes and I have to use task manager to get me out of the game - I have reinstalled the game and it still happens. Very frustrating and a waste of money if I cannot play this game. Not a happy customer at the moment
 
 
 posted in Malice: Two Sisters on May 6, 12 4:38 AM
Everytime I click on the Glass Shard it takes me out of the game - I cannot progress until I get this object!!!
 
 
I started playing this game with no problems at all, even got into the cemetary with no problems. I then had to come out of the game for a while, went to re start the game and it goes through the process of loading, then I get a blank screen with the loading sign in the middle - background music is playing. I then get the message that the game has stopped responding. Have tried to restart a few times since, and the same thing happens.
Its a shame really, as I was quite enjoying playing this demo and was considering purchasing it.
 
 
 posted in Victorian Mysteries: Woman in White on Sep 17, 10 12:21 AM
walcroft wrote:i have downloaded it but every time i go to play it shuts itself down HELP

Im having same problem
 
 
 posted in Mystic Gateways: The Celestial Quest on Sep 11, 10 5:27 AM
ive got the first screen asking to turn on a lamp, but the whole screen is black - cannot see a thing!!! Help
 
 
 posted in Finding Hope on Sep 11, 10 5:20 AM
I've just completed the game, during the 1 hour trial period. If that helps.

Very good game though, nice story
 
 
loved this game, cant wait for the regular version to come out - very rarely buy collectors edition.
Bit sad that the trial finished before the hour was up tho, still had 30 mins game time left!!
 
 
 posted in Nightmare Adventures: The Witch's Prison on Sep 5, 10 2:59 AM
Just played the trial version - love it, gonna use my game credit to buy it!!
 
 
 posted in Echoes of the Past: The Castle of Shadows on Aug 15, 10 3:17 AM
Dara6028 wrote:I just retrieved the Factory Guard's hat, but when I go into the factory I can't see anything other than the game icons in the upper left & right corners. Everything else is dark. If I try and return to the main menu, the game just hangs and then I have to "Ctl Alt Del" to get out of the game.....

This has happened to me too, I have reinstalled the game twice and it still comes back to this frozen screen.
 
 
I really enjoyed the trial of this game, was sad when the hour was up!!
I liked that you had to go from room to room using things that you found to progress.
As in previous posts though, I am also in two minds whether to purchase the collector's edition or just wait for the regular edition.
 
 
 posted in My Beautiful Vacation on May 10, 10 10:51 AM
Played half an hour of this game, then the game froze - had the music playing in background, but no cursor and could do absolutely nothing!!

Not going to bother trying to fix this issue, as the game wasnt that great. The graphics were just ok - nothing spectacular, the tasks were quiet pathetic and the hidden object scenes were really bad too.

This has to be one of the worst games that I have tried so far!!
 
 
 posted in Trial of the Gods: Ariadne's Journey on May 9, 10 3:40 AM
Have just finished the demo of this game, and although I usually play HOG games, I must admit, I did enjoy this match 3 - with a bit of HOG!
The music was ok, the placing of the awards was a good idea. Overall a very enjoyable hour! Probably wouldnt want to play longer than that though.
 
 
 posted in Fiction Fixers - Adventures in Wonderland on May 5, 10 10:59 AM
Ive just played the hour demo of this game, and got through to the 4th door. I really enjoyed playing this game, I thought the graphics were lovely and it really followed the story of Alice in Wonderland.
As in some of the other comments made, it would have been a lot easier if you could just click on the location on the map, however, this wasnt too much of a problem.
I think I will use my credit to purchase this game.
My 5 year old thought this game was very pretty, and was happy to help find the hidden objects - so a big thumbs up from him.
 
 
 posted in Dale Hardshovel and The Bloomstone Mystery on May 4, 10 3:16 AM
Have just played about 10 minutes of this game, and it is definately not for me. The puzzles are tedious and quite repetitive.
I suppose those that enjoy puzzle games, may like this game, but I didnt.
There is a help button, although you are limited to 3 tries (I think), the music is annoying, but I turned the sound off on my computer. The graphics are not brilliant, have definately seen better.
 
 
 posted in Lisa's Fleet Flight on May 3, 10 9:21 AM
Just played the hour trial of this game, and found it extremely tedious, the same thing on each level, even though I bought all the 'upgrades' there was no change to the game.
Definately will not buy this one.
As for the music, I turned the volume off on my computer.
 
 
 posted in Magic Encyclopedia: Illusions on May 2, 10 2:45 AM
Im 30 mins into the trial, and love it, altho the music is very annoying. So have just switched my volume off - problem solved!!
The idea of switching views, is a brilliant one. Very grateful for the hints, as at times, it can be a bit confusing as to what needs to be done.
I am currently at the airship, and need to enter a code, but not sure where to find the key to the code.
Any ideas/help?
 
 
 posted in Eternity on May 2, 10 2:09 AM
I enjoyed playing this game, once I found out which order the buttons had to be pressed in!!
The hidden objects were good - some were easy, some were quite difficult. I liked the way the rooms were crossed off when they were completed.
Im sure I've demo'd this game before, but am adding this to my buy list.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator