Posts created by themom101

 
 
All the "Dark Parables" are a must-have for me. I usually wait for the SE version tho. While playing the Demo of this one, there was one glitch that I found. Not a major bug, just frustrating. When you collect the Frozen Statue, you have to use it on the fire pit to be able to collect the Golden Raven and the Rune. You do NOT get the statue back. Then, you have to go to another area and place 5 statues on the corresponding place on the steps in order to get a part of the hunting horn. However, there are only 4 statues there, 5 spots to fill, and you lost your statue at the fire pit. You're able to collect the fragment of the hunting horn and play on, but that one spot remains empty.
Just to double check, I went thru the guide and it states to place the 5 statues on the steps. It doesn't show where to get the one back that you used and lost. And I couldn't find any mention of them anywhere else.
I also started over with a new profile and tried to pay very close attention to the statues and that one missing one. I didn't find it anywhere.
Like I said, it doesn't cause an issue with the game play that I found, but it is frustrating.
Otherwise, I had no issues with the game, install, playing, everything was great.
Thanks for another great Parable in the series.
 
 
 posted in The Big Secret of a Small Town on Mar 6, 15 9:28 AM
How do I find the things to finish the snowman?
 
 
 posted in Echoes of the Past: The Kingdom of Despair on Sep 11, 13 10:38 PM
I have most of the Echoes of the Past series and they all have been very good lengths. I enjoyed the demo on this one, but a key factor in tilting the scales toward buying a game is the length, hate buying one and then finding out that it only took 2-3hrs to finish after the demo. The reviews on the CE seemed to indicate that the main game was long but didn't see any real info on the SE.

Thanks for any info offered on this one!
 
 
 posted in Stray Souls: Stolen Memories on Aug 8, 13 2:37 PM
Sounds like a lot of us are in the same boat! I'm 51 and disabled. I'm at home 99% of the time and the games on BF and one other game site makes up a big part of my day! I look forward to the new releases and having been a member since 2009 I've purchased 93 games from BF. I prefer not to have to go to another site to try to find a walkthu. I would bet that there are a lot more of us that looks to BF as a bigger part of our lives than perhaps they realize!
 
 
 posted in European Mystery: Scent of Desire on Jul 11, 13 10:25 PM
Mine did the same thing when i got to Gaston's Basement. The locksmith gave me the key, and when I went in the room, it was like I was locked in. Couldn't back out, my map had no interaction whatsoever. I had to finish the tasks in the room: complete the HO scene to get a saw, make a lever for the pipe out of the broom, drain the pipe to get the key, and then once I used the key to get out, everything was back to normal.
 
 
 posted in Dark Parables: The Final Cinderella on Jul 9, 13 7:00 PM
Just checking back in to say Tech Team got me up and running! Very happy because I love this game!
 
 
 posted in Dark Parables: The Final Cinderella on Jul 9, 13 10:24 AM
I did update my video drivers this morning and got the same issues. Currently I'm downloading the CE version to see if I get the same thing with it. I have sent an email to the support team with a "Dr Felix" report attached. Will continue to try to find a solution because I really enjoyed the part of the game I got to play and had it on my "must have" list for a while!
Thanks so much for the reply! I did go to the page you suggested and went thru all the steps with the same result. Hoping the Tech Team will have an answer!
 
 
 posted in Dark Parables: The Final Cinderella on Jul 9, 13 8:53 AM
I was hoping a clean install would work but the same thing happened again. And, I posted the wrong chapter.....I think it is the 3rd not 2nd. It's the one with the pirate. Started over with a new character on the clean install and when I reached that point again the screen was solid black
 
 
 posted in Dark Parables: The Final Cinderella on Jul 8, 13 9:03 PM
Game was working fine until I got to the 2nd chapter. The pirate scene was fine but when I moved to the right toward where pinocchio ran off, the screen was black. I could move my curser and see bits of the picture but not the entire thing. Hoping it's just a glitch because I'm really enjoying the game!
 
 
 posted in Sacra Terra: Kiss of Death on Mar 16, 13 10:34 AM
I purchased the SE version because I loved the 1st Sacra Terra. But when I started playing this one, the "beyond" objects were missing. I read thru the Walkthru for the SE version and it shows them. My question is: are they only available in the CE version?
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Jan 5, 13 5:45 PM
This is one puzzle that can get frustrating fast. Makes you wish for a "skip" button within a few minutes! The only advice I can give you is to start at the bottom and work your way up as you get them fixed. Each row affects the one below it so when you get one fixed, skip up so you don't mess it up! Good luck!
 
 
 posted in Witch Hunters: Stolen Beauty on Dec 31, 12 6:03 PM
How long was the game and what level did you play? I only buy games that I love and then only after checking the length. If I love a game but it only lasts 4hrs, I'm going to skip it unless it comes up on a daily special. I read thru all the reviews and so many times gamers forget to post how long a game is.
 
 
 posted in Mystery Valley on Jan 4, 12 11:55 PM
After watching her for awhile, it seems as though she shows up near areas that need something done. Not really a hint but perhaps a reminder.
 
 
 posted in The Revenge on Jul 7, 11 7:46 PM
There have been several times that I couldn't pick up an item in a **** section but I found that if I exit the game and restart it, it works fine. You might try that .
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Jun 8, 11 12:23 AM
One other thing, after you get all the symbols in place, you have to click on the suitcase to get it to open.
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Jun 8, 11 12:22 AM
[b]I was having the same trouble with the suitcase. Didn't matter how closely I tried to draw them, I couldn't get it open. I finally went to the walk-through that shows the 6 actual places to get the codes.
1) On the cable car (if it isn't there anymore, click on the lever to bring it back
2)on the Right side of the tunnel, across from the machine that works the cable
car
3)At the bottom of the stairs from the same location as 1 & 2, it's on the rocks
4) On the rock where the scorpian was
5)by the hollow log where the salamander was
6) In the cyclops cave, across from the lantern, right above where the suitcase
sits. (This is the hardest one to see, but at least when you pull the suitcase
up, you can still see it.)

As I went to each place, I used my digital camera to take photos of the symbols.
When I pulled the suitcase back up, it was much easier to find the right symbols. Good Luck!
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 24, 09 8:43 AM
Thanks, Hollie! I totally missed the bottle. I got so frustrated with thinking I missed it in the Greenhouse, I lost focus!! Sure enough, it was in the bottle!!
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 24, 09 8:40 AM
Yes, about a dozen times! LOL I beat on everything in the Greenhouse... I think that is where the missing piece should be.... there should be 4 in there according to the walkthrough. The vases in there aren't breaking. Is there anyway to find them without starting the game over???
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 24, 09 6:26 AM
Okay, here I am in the Kitchen, Cellar, and Greenhouse. I have only found 9 out of 10 of the mirror pieces for the Cook. I've solved all the puzzles... watered the plants, killed the Fly Trap, Fed the Ghosts, etc. and still can't find the other mirror piece. I keep going back to the rooms and it's not there. I did the walk through and although it shows where all the pieces are, somehow, I only ended up with 9.
Anybody know what to do????
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator