Posts created by locoowl

 
 
 posted in Death and Betrayal in Romania: A Dana Knightstone Novel on Oct 22, 14 10:25 AM
Can you possibly tell me how to get past the hanging suits of armor. My hint keeps taking me back there but it won't do anything and the hint button says nothing else to do here.
Thanks
 
 
 posted in Mysterious Oasis on Mar 19, 14 8:41 AM
How do you move the boulder off the little tree at the end of the rail car line.
I have a ax, fishing pole, and a empty gas can.. Thanks
 
 
 posted in Legends of the East: The Cobra's Eye on Sep 19, 13 8:42 PM
I have reached the point in the game where Valerio has to battle Arthur. How the heck is this supposed to work? The instructions are entirely useless as to how I supposededly "choose" a weapon!

Anyone got any helpful hints?
 
 
 posted in Push The Box on Mar 21, 13 8:59 AM
THANK YOU LIZZIEK

Not only are the videos helpful but they are almost
as much fun to watch as playing the game.
 
 
 posted in Push The Box on Mar 15, 13 8:25 PM
scpotamus wrote:Game plays fine until level 63. At that point, you cannot rescue the pigs and your pig won't move any more when you try. Also, if you go back to level select it show that I only got 1 star on level 62 (the level before the one that messes up) but I got 3 stars. I even did level 62 over and got 3 stars again, and once again level 63 messes up when I try to rescue pigs...they don't go away and I can't move and the wolf gets me. This obviously is a game glitch. Any thoughts? Anyone else have this problem?


I just got this game two days ago (03/13/2013( and it is exhibiting similar behavior. This is on my Windows7 Home premium 64-bit desktop. My wife has been playing on her laptop with no problems. Quite a puzzle!
 
 
 posted in Mysteries of the Mind: Coma on Dec 7, 12 9:43 AM
cidingle wrote:Played the game until I travelled with the ship Victoria to the next level (forest etc.). Used the hint button and was transported back to the island with the lighthouse (to the portrait of grandmother minigame) with no axe to get the ship back into the water. Must be a glitch.


Go to the ship and then use the hint button again. It took me to the forest and I continued on from there.
 
 
 posted in Mayan Prophecies: Ship of Spirits on Nov 25, 12 5:50 PM
How did you get the wood to light on the candle. I am stuck at the same point!

Thanks!

 
 
 posted in Entwined: Strings of Deception on Mar 12, 12 2:38 PM
Suggestions where to look for the brown tile would be greatly appreciated.
 
 
 posted in Elementary My Dear Majesty on Feb 6, 12 4:31 PM
I don't know if this is really a technical issue or just a quirk in the game, but I have had several places where I get stuck and cannot go further. An example is hanging the pictures in the hold of the pirate ship. I hung them and selected the similar pictures and then the game just sat there and would not do anything else.

When I replayed the level things worked as they were supposed to.

I had the same issue with finding the sapphires on the volcano island. I found them all and freed them, but then they just disappeared and sparkles appeared where they had been. But when I replayed the level, once I found them all I got to place them in the chest lock so I could continue.

Has anyone else had this flaky behavior? Is this a known issue with the technical staff?

 
 
 posted in Elementary My Dear Majesty on Feb 6, 12 4:24 PM
Vickiec wrote:I found the magnet before noticed the crane it is in my invatory and now i cannot put it on the crane. Am i going to have to start over. Help !!


If you have found the magnet and it is in your inventory, you have to find the crane next. You can find it by clicking on the shield on the statue of the knight in the foreground. The shield will hinge open and you will see a red button. I think you can push the button and the crane will activate so you can put the magnet on it.

At least that is how I recall that working. My issue was finding the crane in the first place!
 
 
 posted in Elementary My Dear Majesty on Feb 6, 12 4:17 PM
You have to use the arrow controls down on the bottom right corner of your screen. If I recall, the bottom part of the snow woman is on the extreme right lower side. You actually find that the snowball is partially hidden by the arrow controls when you pick it up. But it is there and you can get to it.

 
 
 posted in Elementary My Dear Majesty on Feb 6, 12 4:15 PM
The sunglasses are very hard to find. I never really could see them, even when I used the hint button.

Sometimes all you can do is move your pointer all over an area and hope for the object to blink for you. I confess, I had to use a hint on the sunglasses. Unfortunately, I cannot remember precisely where they were. Maybe I will play it over and see sometime.
 
 
 posted in Elementary My Dear Majesty on Feb 6, 12 4:10 PM
locoowl wrote:I am having the same problem. I selected the five similar paintings. Now the task area shows that I need to hang them, but I cannot figure out how to go about that.

Help!


OK! I replayed the level because I was getting nowhere! The second time through, when I selected the five similar paintings, the paintings went away and the chest containing the star map appeared. There is a puzzle to solve to open the lock of the chest, but it is rather "elementary."

 
 
 posted in Elementary My Dear Majesty on Feb 5, 12 2:38 AM
I am having the same problem. I selected the five similar paintings. Now the task area shows that I need to hang them, but I cannot figure out how to go about that.

Help!
 
 
Have you tried using the map?

I confess this game does not give many hints or clues as to what to do next.

It does not take you to the next place automatically. You have to use the map feature to move to the next scene.
 
 
 posted in Margrave: The Curse of the Severed Heart on Apr 8, 11 5:58 AM
Thank you. I do wish there was a way to cross reference the titles.
GrannieKay
 
 
 posted in Margrave: The Curse of the Severed Heart on Apr 8, 11 5:41 AM
I have this one in the CE and also Margrave 2: Lost Ship. What was the name of the first game? Does anyone know?
Thanks
GrannieKay
 
 
Hi!
It is time for me to enter the graveyard, but I do not have the "Crown" key in my inventory. Where the heck is it? I have looked at the walktrough and can find no mention of where it might be located.

Help!!!

 
 
 posted in Dominic Crane 2: Dark Mystery Revealed on Sep 6, 10 12:00 PM
I tried it, I liked it and then realized I had missed getting the first one, so with the big Labor Day sale I got both of them. I hope we get punches for these.
As stated in other posts it's a good game and not so hard that you have to pull your hair out. Enjoy!
GrannieKay
 
 
 posted in Dream Chronicles: The Book of Air on Sep 5, 10 3:42 PM
ringette wrote:I am having a problem in the water hut. I have weighed and placed all but one of the objects and now the last one will not work. The symbol is a flattened X.


Ringette -
The symbol is a triangle with an "X" at the bottom. You form it by using the upward pointing arrowhead, the horizontal line (that creates the triangle) and the two slanting symbol pieces - that is four pieces in all.

Hope this helps!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator