Posts created by machamc

 posted in Crafting Story on Jan 5, 15 5:27 AM
This is not new - it showed up on the rival site in September! What gives - no new games available?
 posted in Relic Rescue on Aug 25, 14 3:51 PM
I have completed all 150 levels and decided to go back and try to get 3 stars on all levels. After I found the bonus levels locked, I was very upset but then found that if I played a level, whether I got 3 stars or not, I could play one bonus level. They then locked again until I finished another level.

So, just play a level, play the bonus round, play another level, and you have an unlocked bonus level again.

 posted in Wonderland Adventures: Planet of the Z-Bots on May 3, 14 7:42 AM
When I try to start this game, I am told I need a Windows feature called DirectPlay and am asked if I want to install it. Is this a Microsoft feature and why wasn't it part of the installation process?
 posted in Atlantis Adventure on Apr 30, 14 7:19 AM
I am using the latest version of Windows 8 and have made sure that Internet Explorer is updated and checked that the Flash Player is working and Active X Filtering is off as directed by Adobe but every time I try to start this game, I am told over and over to install the latest version of Flash Player. I can gono farther. I have been able to play the game in the online version! What is wrong with this game????????????
 posted in Rebuild the European Union on Feb 2, 14 12:41 PM
ActionWorksWhat are your computer's specs? CPU/RAM/VGA, operating system? Maybe a firewall or antivirus program is stealing your resources or an old driver is malfunctioning. If you are playing fullscreen, try to run the game in windowed mode (it's in the Options menu, what can be accessed from the Main Menu) or the other way around and check if the problem still persist. We never experienced such problems, so can't give you a solution right now, sorry.[/quote wrote:

Thank you for replying. I don't know much about specs but I have an older Dell Computer, Pentium 4 CPU 3.40 GHz, 2G Ram, Legacy Video Applied Device - sound, video, game controller. McAfee Antivirus. I have been running the game in windowed mode but just tried it full screen.. It slowed down much faster, wasn't even able to finish one level. Restarted and played in windows mode and was able to almost finish 3 levels before it slowed down. If I exit and restart the game, it is normal until it slows down again. If it were some other program slowing it down, I have no trouble running any of my other programs.
 posted in Rebuild the European Union on Feb 2, 14 8:16 AM
I do not understand what is going on with this game. I can only play a few levels before it starts to drag and barely allow me to switch items. It then takes a long time before I can switch another item. When I finish a level like this, it takes a long time for the end screen to come up and a longer time for it to allow a clikc on OK. I have even tried a clean reboot on my computer and playing it without any other programs open in background and it still happenes after a few levels.

It appears to be a memory hog that will not run smoothly. I have had no such problem with any other Match 3 game and I buy most of them.
 posted in Tales of Lagoona 2: Peril at Poseidon Park on Oct 23, 13 5:15 PM
I really love this game and am determined to play it. I have found that my game freezes every time the dialogue comes up. The first dialogue balloon works then it freezes as the second dialogue balloon starts to come up.

My solution (frustrating as it is to have to restart continually) is to hit the Windows button which brings up the desktop and start menu. I keep moving the mouse around until it finally appears in the taskbar at the bottom of the screen. I right click on the taskbar which brings up the menu and click on task manager. I tell it to "end not", the end now window comes up and I click on "end now". Then I wait a few minutes and the game ends. I start it again and it works until another dialogue starts, then freezes again and I start the end now procedure all over again.

When I have to put an item in something with the gears, I sometimes have to keep trying all around the part with the gears. It eventually goes in.

Hope the fix it and issue an update!!!!!
 posted in The Snow on Aug 29, 13 11:16 AM
I, too, cannot start this game, it freezes with the custom curser not movable and I have to use task manager to exit.

A competing gamesite has this as its new game today. I downloaded it and am able to play it with no problems so it would seem that it is a Big Fish problem!
 posted in Northern Tale on Oct 15, 12 12:54 PM
Thanks for your input but I think it had to be the game. I had just done a restart of my computer before opening the other programs, done a little work on Excel and then downloaded and played Northern Tale. I have done this numerous times with other games and never had a problem.

I cannot reopen the game and try again because the demo time ran out and I am not about to buy the game just to try it out. As I said, no other game (or any other program for that matter) has ever done this to me before and I just don't trust it.
 posted in Northern Tale on Oct 15, 12 11:54 AM
I played the demo and really enjoyed it and was going to buy it.

I usually have other programs open in the background so I can play a while and switch back to something else. On this occasion, I had Outlook Express, IE and an Excel spreadsheet that I was working on open. When the game shut down after the demo ended, it closed all those programs down. The frustrating thing was that the info I had entered on my spreadsheet was GONE.

I have never had anything like this happen before with ANY other game and I have been doing the same thing for years now. I will have to decide whether it is worth closing everything down to play this game for a while and then have to open them up again.

If you do the same thing I do, be careful not to lose your work when trying out this game.
 posted in A Gnome's Home: The Great Crystal Crusade on Jul 10, 12 10:34 AM
I have to chime in too. Love the game, love the music, but cannot work these old fingers and brain fast enough to complete the levels in time. Hope the developers are keeping tabs on the reviews and can give us the chance to continue working after gold, silver and bronze time runs out. I could care less about the rewards! Just would enjoy playing! Also, don't understand about the castle, did I miss something?

I just went to the developer's website and they don't even show this game - is it really Blam! Games? They produced the Fierce Tales - Dogs Heart and on that forum had a feedback section where they responded to customers comments.
 posted in Between the Worlds II: The Pyramid on Mar 3, 12 1:05 PM
I don't comment often but just couldn't stay quiet. I read most of the reviews and agree that one must have a lot of patience to complete the game. I enjoyed not having a walkthru and having to figure out the puzzles myself and was quite pleased when I managed it. I thought it was a very good game once you got past the frustrations in the beginning BUT:


I was extremely disappointed in the ending. When you reach the lengthy scroll that tells you that you are going to have to repair the box and restart the heart of the magical world, as soon as you have read it and clicked on it, the game is over. I had managed to solve all the puzzles with just a bit of help from the guy detective and was excited about continuing on and all of a sudden, the credits began. I was left feeling very frustrated that I couldn't continue on. I bought the first in this series in April of 2009 and can't remember a thing about it; I dearly hope we don't have to wait another 4 years for the sequel, as I may not be around to play and probably won't even rember it as I just turned 71 a week ago and have no idea what the future holds.

 posted in Youda Mystery: The Stanwick Legacy on Nov 15, 11 10:47 AM
I have never had a problem like this with a game before. When I try to start it, I get a 3/4 screen with the title across the top and a white screen. After waiting a bit, it flashes out even though the game stays in my task bar and my computer freezes for a couple of moments. When I use task manager to close the game, it says the program is not responding and closes it.

I uninstalled and reinstalled it with the same problem when I tried to start it. After closing the first time, I had 59 minutes remaining and after the second time, I had 58 minutes remaining even though it was supposedly not responding.
 posted in Sky Taxi 4: Top Secret on Nov 9, 11 3:21 PM
There is something terribly wrong starting around level 35 and continuing thru Level 40 where I got stuck because I could not get thru the sky obstacle course with the red thingys.

The levels start with the graphics all messed up. For instance, on level 40 which I keep getting thrown back to because of the obstacle course, you can start as a box, a bomb, a chuck of grass or one of the enemies but your id is all messed up - very large or very small. If you keep going, you revert to the mouse. If you hit escape to leave the level, the text boxes have the letters mixed up , i.e. EXIT is STIS or LEVELS is LSEVL. I was hoping the next levels would be okay, but I cannot get thru the obstacle course.

I have the previous Sky Taxi games and have had no problems with them although I purchased them from a competitor.
 posted in The Dark Hills of Cherai: The Regal Scepter on Oct 10, 11 4:58 PM
Loved this game. Replayed the first one and went directly to this one. It was challanging enough to last almost two days and I was very disappointed to see it end as each character's map showed many more levels but they were greyed out.

Does anyone have a clue as to when the sequel will be coming? If it takes two long, I may have to replay both of the first ones as I did with this one so I would have some continuity and understand what was going on. My memory is not that great anymore. BF released the first one in December of 2009 and this one in October of 2011, that is almost two years between the two! I hope the third one doesn't take that long, I am 70 and don't know if I will still be around two years from now?
 posted in Jewel Quest Mysteries: The Seventh Gate on Jul 14, 11 10:11 AM
I don't post very ofter but in this case, I felt it necessary to vent. I love the Jewel Quest series and have bought every one of them, even though there are a few I have been unable to complete. I feel completely ripped off as this game is so short I was able to complete it in 3-4 hours and it is not the type of game I would like to play over again as except for the few jewel boards, it would be completely boring and repetitive.

Developers, how could you do this to those of us who love this series?.
 posted in Foreign Dreams on Jul 8, 11 9:47 AM
Received Error: Access Violation after finding first of Victor's items and game quit. Restarted and got almost back to where it stopped, continued for a few minutes and got Error: Access Violation again when starting to go down the stairs and game quit again. Not going to waste any more time and uninstalled game.
 posted in DreamWoods2 on Apr 11, 11 2:53 PM
JessF wrote:Perhaps if we had played Dreamwoods 1 it would make more sense.
Anyone played it? Not in the list of BFG games.

i have DreamWoods 1 and have never finished it. I got stuck somewhere towards the end and just can't figure that level out. I purchased it from a rival gamesite -(removed by moderator).
 posted in Jewel Match 3 on Feb 15, 11 1:39 PM
First of all, I love the game and am so glad I tried the demo because I really didn't care for the Jewel Match games much but loved the original Babylonia and played it over and over.

The jewels, music and specialty items are the same as Babylonia and the game plays much more like Babylonia than Jewel Match. It seems like this should be named Babylonia 2 rather than Jewel Match 3. I wonder if the developers are the same for both games.
 posted in The Stroke of Midnight on Jan 22, 11 11:56 AM
When I start the game, a little box pops up and says "Library not Registered". Then I get about a 3/4 size white screen which has the name of the game at the top. I wait a few minutes thinking it might be loading but when nothing happens, I shut it down by clicking on the red x box on top right. That screen vanished but there is a full size black screen that blips in and disappears immediately..
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator