Posts created by peedeeleavitt

 
 
I'm back in the elevator room and have pulled the chain and gotten the ring and then I got stuck. The guide says to use the crowbar to pry open the elevator doors but I no longer have the crowbar. I used it once before and it disappeared. Have I missed something along the way?
 
 
 posted in Wild West Quest 2 on Apr 12, 12 2:17 AM
I'm having a problem with the hints in the dining room.with the location of all the silverware. I have reinstalled the level but the hints are no where to be found. I can't get out of this level and have no idea how to obtain more hints or what happened to the hints I had. If I have no way to gain additional hints and am stuck on the level for the game, then it's no fun and I would also request a refund for this game.
 
 
 posted in Wild West Quest 2 on Apr 12, 12 2:14 AM
DebL wrote:I am disappointed with this game and the hints not working!
I would like a game credit on this game or a version that works.
 
 
 posted in Nightmare on the Pacific on Feb 19, 11 9:26 PM
Well, I guess poor Jimmy just drowned! I tried everything thing possible as listed on the forum, to get the water valve closed. I couldn't find the red screw and nothing happened when I clicked on the right side of the vent. Other than that I enjoyed the game and wish I could have finished it.
 
 
 posted in Nightmare Adventures: The Witch's Prison on Oct 28, 10 7:01 PM
Where can I find the walkthrough? I read it's in a blog but how do I find the blog?
 
 
 posted in Column of the Maya on Oct 23, 10 1:52 PM
No, but I need one also. I can't get off the map in the office. All it keeps telling me is use the flashlite to find the office. I do that, clilck on the map and get told to use the flashlight etc. I'm going to delete the trial on this game. I don't like it at all.
 
 
 posted in Golden Trails: The New Western Rush on Aug 24, 10 8:30 PM
I cannot get out of this location. I am stuck in the boudoir location. I have tried everything but nothing helps. Please help. In one site it shows a barrel in the lower right corner but I do not have a barrel there.
 
 
 posted in Golden Trails: The New Western Rush on Aug 24, 10 5:11 PM
I can't seem to get out of the saloon. I keep getting sent back to the boudoir. I've tried everything. Can someone tell me what I'm doing wrong. Please!!!
 
 
 posted in Magic Encyclopedia: Moon Light on Sep 11, 09 8:14 PM
Hi, I left the minigame at the labyrinth and now I don't know how to get back in to find the rest of the "walking stick". The only item I show as not complete is the knitting needle. I'm so confused. I need some help please!!!!
 
 
 posted in Mystery Age: The Imperial Staff on Aug 28, 09 4:37 PM
Thanks for the info on the scisssors. I had looked for them for over 1/2 hour, but when I found the instructions and followed them I was fine. I've only had two "bad" patches in this game, the sick camel and the scissors. I think this game is one of the best I have ever played. Iam sure that it is the type that if I go back after a couple of months I can replay it and enjoy it just as much. Thanks for the help.
 
 
 posted in Mystery Age: The Imperial Staff on Aug 25, 09 5:21 PM
Well, I guess I'm in my second childhood because I think the game is great. As far as the hints are concerned, I must not be able to discern their meaning because I'm stuck on a sick camel and have been for 2 days. I think the game is better than most of the ones I play.
 
 
 posted in Mystery Age: The Imperial Staff on Aug 25, 09 5:19 PM
belamba wrote:I really disliked this game! Aimed at young children me thinks. Those annoying speech bubbles, stupid hints non-stop telling you what each object was for, and the game was finished within 2 hours gameplay! Didn't feel it was value for money, and certainly didn't exercise the grey matter!
Was very disappointed with this game. Don't know why anyone would need a walkthrough? Just click on 'hint' and any object and your probs are solved!
 
 
 posted in Mystery Age: The Imperial Staff on Aug 24, 09 8:03 PM
I'm with you. I've tried all the suggestions, but I can't open the coconut because I can't find the last piece of the handle for the device to break it open. I've tried to make the camel take the medicine by placing the items over the mouth area but nothing! I've clicked on the camel and clicked on the camel but nothing happens. I'm still trying to break open that darn coconut,, Can someone please help me. Other than that this is a great game.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator