Posts created by 1snooker1

 
 
 posted in Roads of Rome: New Generation 2 on Nov 2, 17 5:22 AM
I can't get past the intro - whole computer locks up and I have to turn it off and reboot. I've tried removing and re-installing the game and the same thing happens. Screen, mouse and keyboard freeze. Very frustrating. It's not my computer, not my updates, not my Windows - the game needs a fix.
 
 
 posted in Hotel Dracula on Jul 31, 17 12:24 PM
This is a fun, easy game - I give it 3 stars. You can only have 2 meals queued with the cook at a time, and "soft" mouse clicks don't respond.
 
 
 posted in Wedding Salon 2 on Feb 15, 17 10:45 PM
Game crashing - I got to India and next time I tried to play, am told to wait then get an error message. No problems until now. I won't waste time with the computer/system "fixes" after reading everyone else is having crashing problems. Please listen to the players, techies - it's not the computers, settings, etc. The game needs a fix.
 
 
 posted in Clutter IV: Minigame Madness Tour on Oct 14, 14 6:21 PM
Same issue - choose the first quest and game shuts down. Running Vista on 64 bit machine. Never had this problem before.
 
 
 posted in Rush Hour! Gas Station on Oct 3, 14 10:36 PM
Same problem on level 13 as everyone else - no cars, lot empty, but nothing happening. Can't finish level, can't move to next level.
 
 
 posted in Airline Baggage Mania on Feb 5, 13 6:02 AM
I rarely post but this game is so awful I had to agree with all the above. No real tutorial but finally fumbled into how to play; too fast to be fun, just manic clicking and wondering what I was doing. I never did figure out what the magnets are for, and never figured out how to actually score points. I was so excited to see a new TM game, and now I'm starting the day with a big disappointment. Big boos on this one.
 
 
 posted in Spooky Mall on Feb 29, 12 9:46 PM
Great game! Fun, not too hard, great graphics and smooth play. A couple of glitches, but I bought it anyway. Well worth the $$$ - hope they get the glitches fixed soon!
 
 
 posted in Spooky Mall on Feb 29, 12 9:38 PM
Having the same problem at level 11 in butcher shop - guy stands by the sodas with a question mark. Can't get it to clear. Also had a problem with a piece of the clown's trash - couldn't pick it up and it showed up in the same place at the beginning of the level. I tried to replay the level but the trash was still there. Finally got out of the game and restarted it. That got rid of the trash, but that's when I got the guy by the sodas I can't get rid of.
 
 
 posted in Island Tribe on Jan 29, 11 5:01 PM
I am having the same problem with level 10 - have started level over 3 times and each time it's a different building that locks up. The building gets damaged, and I get a green check but workers don't repair. When I click on the building again, there is a red "x" but no list of items needed to repair and it just stays damaged. I can repair other buildings, but not the one with the red "x". So now I can't go any further.
 
 
 posted in Island Tribe on Jan 29, 11 4:55 PM
Me too - same problem. First it was the grain, then the milk. The building needs repair, but can't get anything but the red "x" when I try to repair. Doesn't show what resources needed to fix. I have resources, nothing blocking the path - just can't repair. Have tried starting over several times - each time it's a different building that locks up.
 
 
 posted in Youda Farmer 2: Save the Village on Nov 7, 10 11:45 PM
Can't get past the Gripper Balloon tutorial - when I try to pick up the truck, the truck backs away but tutorial shows that I have it and to drop it on the tower. There's nothing to drop - balloon just goes up and down, or side to side, and no more trucks appear. Have tried exiting and rebuilding balloon - same thing every time. Now am stuck and can't play.
 
 
 posted in Fill Up 2 on Sep 4, 10 12:41 AM
B*O*R*I*N*G!!!! zzzzz......... I played 5 minutes then deleted game. Music is too frantic. Graphics are good, very responsive. But geez the game itself is a bust.
 
 
 posted in Fill Up! on Aug 26, 09 6:17 PM
I agree with previous posts - great potential, but a big flop. Game stutters, instructions not clear, not enough time to enjoy the game. Music is lousy too - doesn't fit with the game. Have to be in a frantic rush from the beginning - later levels must be a nightmare. I am a big fan of TM games, but this one needs LOTS of improvement to come close to being fun. A big PHOOEY; thumbs down.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator