Posts created by Lordshandmaiden

 
 
 posted in Living Legends: Uninvited Guests Collector's Edition on Jan 15, 18 6:39 AM
JulieJay wrote:Lots of flickering going on across the top of my screen. Had to stop playing after 5 minutes. I've just today finished playing one CE and have just demo'd another with no problems whatsoever.


I am having the same problem. Flickering at the top of the screen for the first 2-3 inches. I have tried all the solutions here, but nothing helps.
 
 
 posted in Halloween Stories: Invitation Collector's Edition on Oct 12, 17 5:17 AM
I had no problem downloading, or opening, but after I put my name in and then went to choose gameplay mode, my mouse won't go below a certain point. It stops about 3/4 of the way down the screen, so I can't click on "OK", so therefore can't play the game. I can click anywhere else on the screen and it works, just when I try to go below, the cursor stops. It is weird!
 
 
Does anyone happen to know what the song is in the intro? I love it.
 
 
Same issue since the "update". Didn't have a problem until I installed the update. I had played this game once before with no problem on any level.
 
 
 posted in Santa's Christmas Solitaire on Dec 9, 16 8:04 AM
I say hats off to this game. I am an "older" person who enjoys games like this. Sometimes I get so frustrated when the developers make a game so hard that you ride the hint button. Yes it is a simpler game, but it is a great game to relax with at this joyous season. I love the music, and the fact that there is so much variation of it. Some games give you one song for the whole game. Drives me nuts.
All in all, for the season, I give this game 10 thumbs up.
 
 
 posted in Elven Legend 3: The New Menace on Aug 24, 16 4:52 AM
I was just wondering if any of the moderators know if Elven Legend is coming to Android games anytime soon? I am looking forward to playing this new game, but I am having a hard time sitting up for long periods of time, so it is nice for me to play these games on Android, as I can lay down with my LG tablet. I am starting to like these types of time management games, especially the ones where you can play relaxed games as my eyes aren't so great either.
Thank you! Love Elven Legend games.
 
 
 posted in Button Tales on Aug 10, 16 11:34 AM
Same. Error access violation. Didn't look like a good game anyway according to some, so no loss for me.
 
 
 posted in Next Stop 2 on Jun 7, 16 6:23 PM
This game is entirely too short! I got so wrapped up in it, that I finished it in less time than I have with any other game. It could have gone on to 2 more towns. Great game. I loved it.
 
 
Okay, I am putting myself out there. I have played this series for awhile now, and I downloaded this one to see if I like it as well, and I just realized I have been pronouncing it wrong all this time! I was saying am-er-inthe. But now that I look at it closely, I can see there are more letters than I am pronouncing. How *do* you pronounce it? lol
 
 
 posted in The Chronicles of Noah's Ark on Mar 22, 16 8:16 AM
And once again they throw the "help articles". They DO NOT work for me! I see they still the same standard answer. I realize it may work for some new people who haven't tried those tips, but those of us who have over and over, it gets very tiring. I wish they could come up with new results.
I wonder if the problem is having to actually have a new game every day, making it hard to bug test their games. Maybe the workers are getting overworked to "get those games out"!
Okay...off my rant now.
 
 
 posted in The Chronicles of Noah's Ark on Mar 22, 16 6:37 AM
I agree! It is most refreshing, "religious" or not, to have a game now and then, where no fighting is necessary, or evil intent, or monsters, or blood. Maybe that is why most people won't like this game.
 
 
 posted in The Chronicles of Noah's Ark on Mar 22, 16 6:31 AM
Same as all above. This is the 4th game for me that this has happened. I always follow the given "advice" to fix these games, but it is always the same. And then I talk to CS and get thrown a coupon. This is getting very tiring.
 
 
Yeah, this and all the other tips and tricks didn't work for me. Guess I have to try to find another game.
 
 
Having same problem as everyone else, black box etc running on windows 10. No fix or update yet?
 
 
 posted in Queen's Garden Halloween on Oct 30, 15 1:55 PM
Got it. Just pure perseverance.
 
 
 posted in Queen's Garden Halloween on Oct 29, 15 11:42 AM
Has anyone finished Garden 1 level 119? I just can't seem to get past this level.
 
 
Same here, and still no hints either.
 
 
I am like many of you, and disappointed in this game. I was thoroughly enjoying it. I liked the humour, and I liked the puzzles. It just had a bit of a different feel to it. I don't usually buy CE's, but this one warranted it after I tried the trial. At least I had fun up to hallway through the game.
 
 
I am using Windows 8.1
I have played the game up to where Francis has to open the crate, with no hints available. I checked the game mode, and changed it so they load quickly, and that opened the "skip" but not the hints. I updated, checked that I actually had hints available, and tried to restart the game. Nothing. It didn't even take me to having no profile. It just continued where I left off. I uninstalled it and re-installed it, same thing. I also noticed that I have a scroll, and a scroll token, and when I check the strategy guide for Francis opening the crate, it says after I open the scroll, I get leather gloves. I can't open the scroll, because when I try to use the token on the scroll, it won't let me. I am stuck at this time, with no going forward.
 
 
 posted in Laruaville 2 on Mar 31, 15 8:45 AM
Just to make sure I am not missing anything, when you have finished building the town, there are just levels to do, right? There is really no point in collecting all the coins? Well, except to get to the next level, of course.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator