Posts created by mickisue

 
 
 posted in League of Light: Edge of Justice on Sep 22, 17 11:08 AM
This is a tech issue. I have the Mac version, playing on a MacBook Air. My pointer won't reach the edges of the screen, so can't, for example, reach the "skip" button for the intro after the first time I've seen it. And there are items that are there, so can't complete some of the HOGs.

Please check on this.
 
 
It's in the snow, toward the left side of the screen. There's a guide at the lower left hand corner that shows it to you, if you can't find it.
 
 
 posted in Risen Dragons on May 14, 15 9:27 PM
What is this island's purpose? Or the green one next to it? There was some verbiage about the mushrooms--which I've now forgotten--early in the game, but no more. The island next to it occasionally will have a big green exclamation point on it, that disappears if you click on it. But no explanation.

Does anyone have any idea at all? I've beaten all the islands, working my way through getting all the stars available, but cannot figure out what to do with those two islands--if anything.
 
 
 posted in Risen Dragons on May 14, 15 8:28 PM
I just got the game, as it was only released for Mac. After reading the other thread, I realized that the elemental portal was the way to do it, and it worked, first time.

I maxed out all skills for the tower (don't bother using the Sergeant upgrade, there are no other towers to help out, after all), and was delighted to watch the stinking garbage crabs blow up each time.

Yes, the Summoner takes a long time. It helps to use both bombs and rocks on it, but not much.

The rocks will help in a different way, though, by blowing up the burning rocks that the dragon can't reach. Getting rid of rocks seems not only to add to energy points, but also to lower the number of enemies in each wave.
 
 
 posted in Risen Dragons on May 14, 15 8:24 PM
I know I'm late to the thread, but I wonder if LAnderson had the simple misunderstanding that I had...not realizing that the dragon could sit on top of the various towers. Click on the tower, and see the symbol of the dragon's foot.) The more the dragon breathes fire at enemies (as opposed to burning up rocks), the higher its rating and the more it's able to damage enemies quickly.

Once I figured out that (by watching a walkthrough on http://myhomestock.net/walkthrough/tower-defense/9/Risen-Dragons, I was off and flying through that level; even got all three difficulty levels complete.
 
 
 posted in 12 Labours of Hercules III: Girl Power on Apr 6, 15 8:19 PM
Also helps to click the "run faster" bonus.
 
 
 posted in Green City: Go South on Sep 10, 14 3:56 PM
You want to make sure that the arcade in the center section touches both the mansion and the high-rise, in order to increase their populations. It works if you put them on one the right lower part of the middle, with the arcade above the cinema.

EDIT: The cinema goes on the bottom left, where the arcade is originally. Then stack the two arcades, and you'll have enough population.

You can even destroy the cinema at the end, because it won't have quite enough power, and still get three stars. But you need it for the faster income, at the beginning.
 
 
 posted in Green City: Go South on Sep 8, 14 5:41 PM
Haven't yet gotten gold, but getting faster at my layout.

Start by destroying the cottage. clean up top right, build a multi and a prom.

Fully upgrade the first multi and sell. Build a cinema, upgrade prestige before you upgrade the second multi. Then completely upgrade it, and sell. Upgrade power on cinema to have at least 28.

Build mansion, upgrade, and, at same time, buy, destroy house on upper left. Build pumps (four), as you can while continuing to upgrade mansion. Buy building next to pumps, destroy and build another cinema.

As soon as you have the 20K, buy building next to mansion. As soon as it's destroyed, build two v. proms and upgrade fully next to mansion. Build second mansion and upgrade. Make sure you have at least 20 power left over.

Fill in remaining flooded areas, buy water purification plant. Put park above it, and three v proms next to them. I'm about 1 and a half minute past gold, so need to speed up just a bit...
 
 
 posted in Green City: Go South on Sep 7, 14 2:49 PM
I might have an easier way.

At the end, from left-right, top-bottom:

Two fully upgraded pumps, one above the other, and an upgrade park.

Top middle: cinema

Top right: fully upgraded multi with promenade.

Bottom left: fully upgraded multi. Bottom right: fully upgraded multi with upgraded park below.

Two arcades, one above the other.

Mansion.

Build a second multi while upgrading and landscaping the existing one. Keep the landscaped one, sell the other. In top left of bottom right, build and fully upgrade multi. Build another below, destroy immediately.

Fill in flooded areas to lower right, while clearing middle top and building and fully upgrading cinema.

Clear upper right, and build two pumps. Wait to upgrade.

When possible, build mansion, upgrade, not yet upgrading power.

When possible, buy building in center of bottom right, and destroy. Start upgrading power on mansion and pumps, and build first arcade, upgrading. Watch total amt of power, no need to have more than 10 to spare before building second arcade.

Build and upgrade parks at upper left and below multi on lower right till meet goal.

I (barely) made gold the first time I did this. Probably you could save time and get even better time!
 
 
 posted in Mystika 2: The Sanctuary on Aug 29, 14 8:41 PM
Just put Mystika in the search field. Don't know about PC, but there is a first one (Mystika: Between Light and Shadow) for the Mac.
 
 
 posted in Mystika 2: The Sanctuary on Aug 29, 14 8:40 PM
Level 54, no problem. But there are 200 levels in the game, and for some of us, a bug causes the most ear-splitting sound to be made, along with a terrible slowing of the movement, when you get down to a "danger" level in the time left in a level. For me, it happened once in the 30's levels, and I thought it was an aberration. But as the levels get more challenging, and the amount of time used to play increases, it happens more frequently.

There are other bugs, too, that pop up randomly for others. A game can start out enjoyable, but bugs that remain unfixed can make that enjoyment turn to annoyance. It's not like being without food and water. But when you pay for a game, you DO expect it to work and to work all the way through the entire game.
 
 
 posted in Mystika 2: The Sanctuary on Aug 28, 14 3:58 PM
If there are any BF employees reading this thread: could you please find out from the developers if a fix for this bug is in the works for the near future.

I'm to the point where I just don't want to deal with it. It detracts too much from the fun, and without the fun, why have paid for a game?

If no fix, then could those of us who have the bug (mac users?) get a refund, and start over with a game that works, please.
 
 
 posted in Mystika 2: The Sanctuary on Aug 25, 14 11:51 AM
Same issue. So frustrating to have to close/re-open in order to continue.
 
 
 posted in Mystika 2: The Sanctuary on Aug 25, 14 8:16 AM
princess282828 wrote:I am having sound issues. When timer is letting you know your running out of time in your level, It make this ungodly noise.
I thought my sound card was going, Thank god not the problem.
But it carries right throw the next levels as well.
No other game have that problem. so I know it the game I am playing.
I have a mac osx Minny. Brand new.


Same issue on a 2012 MacBook Air. The action also slows down, and the ungodly sound (like a fire alarm at a grade school) keeps clanging, even after you finish the level and go back to the map.
 
 
 posted in Unfinished Tales: Illicit Love Collector's Edition on Sep 9, 13 12:31 PM
CinW wrote:Sad to see that yet another Elephant Game gives me a black screen during the opening cutscene, plus missing text/animations. I had this same problem with the latest Mystery Trackers game, and technical support informed me that the game doesn't support Intel HD 3000/4000 graphics card (standard in a MacBook Air).

Elephant has always been one of my favorite game developers, and until recently I had no problems playing their games on my laptop. I hope they address this oversight before releasing another game that is supposedly ready to play on a Mac system!


I have the standard edition (just bought along with the CE of "Wild Ride"), and have the same issue. I I re-downloaded both Flash and Shockwave, to no avail.

What can I do next?
 
 
 posted in Virtual Villagers: The Lost Children on Jan 23, 10 9:00 PM
Not sure that I have all their games, but the ones I have, I've enjoyed. One more question: if the gong being rung didn't cause the babies to be taken, what did? And what did ringing the gong the first time do? Nothing, because it was too newly put together? (I analyze this stuff WAY too much for my own good!)

I noticed that when I rang it today, it gave food.
 
 
 posted in Virtual Villagers: The Lost Children on Jan 23, 10 12:33 PM
Yeah, that would help! I think I'm done, then...the game lasts long enough to certainly be worth the $6.99, doesn't it?
 
 
 posted in Virtual Villagers: The Lost Children on Jan 22, 10 2:39 PM
I haven't seen this one addressed. I finished all the puzzles in my first village yesterday, and rang the gong. There was a message that said it would take time for all the magic to be restored; a full day (meaning *my* day, or 12 years for the game).

Today when I opened that village, a message said that someone had taken all the infants during the night, and the mothers were beside themselves. (Well DUH) Does anyone know if this is related to the ringing of the gong? The message on the vine wall sounds as tho the gong is somehow sinister....

 
 
 posted in Cassandra's Journey: The Legacy of Nostradamus on Nov 15, 09 12:53 PM
Does anyone know if the bugs in the Mac version have been fixed? Can't get past the very first level, because it won't "pick up" necessary objects. Very annoying!
 
 
 posted in Ancient Quest of Saqqarah on Nov 15, 09 12:50 PM
I know I'm coming late to the party, but I just used a credit for this game last week. FINALLY. At gamezebo, when it first came out a programmer for Codeminion commented on something that saved my life on the temple of Thot so many times, already. When the puzzles are "loaded" into the game, they are completed, and then the software scrambles a few of the jewels.

So, in the bronze temples, it is REALLY easy once you realize that. A block of red, for example, with a couple other colors thrown in, needs to be completely red.

As you move up, it gets more difficult. But realizing that one thing lets you save your skipped levels for when you need them.

I've just finished all the silver temples, and found (again with Thot!) that if I get as far as I can, and then restart, I'll usually see a solution I didn't see before. That revelation let me finish the entire temple, just using one skip. And I probably could have figured that one out, but it was the level 48, and the LAST one in all the silver for me, LOL.

A great game, challenging as all get out. If you haven't gotten to the silver or the gold levels yet, you'll appreciate that monkey, because he'll light up sections that are nearly impossible to light, d/t their being remote from the rest of the puzzle.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator