Posts created by Owlish

 
 
 posted in Puzzling Paws on Apr 6, 11 7:34 PM
In this game you can only push the peices and not jump over any to get to the other side, and how do you jump or do a flip or what ever???
 
 
 posted in Brixter on Sep 3, 10 8:51 AM
I have been really enjoying this game, even though it is hard to follow it is challenging. When a game is like this one, i have to keep trying to beat each level, this is such a welcoming change to HOGs amd TM's. Thanks Big Fish!
 
 
Bus
 posted in Skymist - The Lost Spirit Stones on Jul 22, 10 6:34 AM
I got the hammer, the nails out of tire, and the battery, went back to bus door to get the hand truck. And every time i click on it i go back to where i got the hammer, nails, and battery. There wasn't a list of items to be found, so i only knew about the hand truck, pile of boards,and pump from the walkthrough.
So how do i continue with the game when i can't complete the installation of the battery? Help Please! I uninstalled and reinstalled but nothing changed!
 
 
 posted in Deep Blue Sea 2 on Jun 10, 10 11:43 AM
After you have gotten extra oxigen tanks, how do you use them after the divers air is getting low?
I picked up the oxigen tank but everywhere i clicked on the board to use it nothing happened?
Any help would be appreciated Thank You! Owlish
 
 
 posted in Chicken Invaders 3: Revenge of the Yolk Easter Edition on Apr 4, 10 12:59 PM
Whats up with this game i like trying different types of games, but the 1st time i down loaded it everything was in a language i didn't understand, i only know English! So i trashed it and thought maybe it was a mistake some how, reloaded it again, and this time i saw it was spanish?? So how do i get to load it in my own language which is English, is this an April Fools joke, or Easter Joke?
If so guess what, i don't get the joke and i am not laughing, so if anyone else has had this problem? Please tell me what do i do just keep loading and then trash it if it's not still in English, till it finally hits the right language or what, very confused, can't buy something if you can't even read the directions on how to play huh??
 
 
 posted in Mahjong Mania on Mar 20, 10 11:16 AM
Where it says More Themes you click into it and it's rocketgames, but it's a blank page, except for GoDaddy and advertisments for getting your own domains?? So how do you download more Themes?
 
 
 posted in Conga Bugs on Oct 22, 09 1:02 PM
Does anyone know is their a walk through for Conga Bugs, or the puzzles?
 
 
 posted in Zulu's Zoo on Aug 8, 09 11:03 AM
I looked on the fourm, i couldn't find anyone else that was having this same problem, is it a glich in the game, i just bought it today? Plese do i need to uninstall and reinstall the game again? Owlish
 
 
 posted in Zulu's Zoo on Aug 8, 09 9:24 AM
Has anyone played this game, and had problems with dropping the sharp tools in the trash? If you did how did you fix it, the hand picks the sharp objects up, but won't drop them in the trash cans at the bottom? Please help if you can! Owlish
 
 
 posted in Haunted Hotel II: Believe the Lies on Feb 28, 09 2:26 AM
We, my hubby and I, throughly enjoyed this game together, we played at the same time! And if we couldn't find an object, we helped each other, Or got stuck in a puzzle we helped each other. Comicsellar gave it to us for Valentines Day, it was the best gift we ever got! For once we found a way to enjoy things totally together, hubby on his PC and Me on mine. Now we try all of our shared HO games together, and believe you me it was plenty long for that! We will look forward to more relaxed played Ho games, like this one!












 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Feb 24, 09 3:16 AM
Gamezebo usually has walk throughs try that!
 
 
 posted in Fishdom on Feb 11, 09 2:50 AM
Leonie i finished the game and all i found you could do was change the decore, fish, feed them etc in the 3 tanks. Maybe if they get a Fishdom 2 but i haven't found any other tanks you can get in this one. Maybe someone has found out something different and will let us both know? Good Luck, Take Care, Good Gaming!
 
 
 posted in Luxor: Quest for the Afterlife on Feb 7, 09 3:20 AM
This is what CheerfulDragon8 suggested on the games forum and it worked for me. By the way Thank You CheerfulDragon i forgot to do this because once i could play the game i forgot, Sorry! High/low Detail if game is slow or jerky, go to your options in the game and switch from High detail to low Detail. This will make little difference to the graphics, but this did improve my game. I hope this helps, and don't thank me Thank CheerfulDragon, i hope he is still around to see this?
 
 
 posted in Conga Bugs on Feb 6, 09 2:28 AM
I know this game isn't for everyone, but i have been waiting for a new marble popping game for a long time. And once you get into it you find it's not just for kids, and with my limited abilities, in hand and eye cordination. The 1st hour of the demo went well, i plan to get it when i get my game credit the 18th. So even if some thinks it doesn't stack up to other poppers, i enjoyed my time at playing it.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Feb 4, 09 8:13 AM
Try Gamezebo they have a walk through that's how i got through this game, its a big help! Take care good gaming!
 
 
 posted in 7 Wonders: Treasures of Seven on Feb 3, 09 5:20 PM
gigi my 5 more favorites are Alantis an older game, Bettle Bomp, much older game, Luxor Quest for the after Life, Wild West Quest, and Paranormal Agency. Take Care and Happy Gaming!
 
 
 posted in Mystery P.I.: The New York Fortune on Jan 31, 09 6:59 PM
Thank You lordkalvan, i will try both of the other games you have suggested in the series, i have tried the Amazing Aventure series and do like them.Thanks again!
 
 
 posted in Mystery P.I.: The New York Fortune on Jan 31, 09 6:46 PM
I have been playing this game every since my Hubby chose it with his game credit. I am in level 18 and i am really enjoying this game, haven't gotten the end yet but curious to see how it all ends. The puzzles have been easy and the Ho objects not too bad to see to find. Way to go BF i really like this one!
 
 
 posted in Rescue at Rajini Island on Jan 27, 09 10:48 AM
I agree with you rita9720, we do need some middle of the road HO's, and maybe more hidden objects instead of so many hard puzzles. Hidden objects you can see with poor eye sight, and less puzzles. I am not too brainy when it comes to puzzles. owlish
 
 
 posted in Wild West Quest 2 on Jan 24, 09 7:17 AM
With this game my hint's button worked till about the 36th chapter, now they either don't show up on relaxed mode. Or they show up and when you click them, the sound is there but nothing showing where the object is. I can't move on in the game because what looks like a silhouetted sombero, i can't find anywhere, i have clicked on the whole picture. When i uninstall and reinstall it says. Exe-application error, The instruction at 0x1010 referenced memory at "0x00000010 The memory could not be read click ok to terminate the program wild - west - quest - 2_S1_l1_gF2848T1l1_d416541038(1). exe-Application Error, rather i push the ok button or not the program still downloads, and i am still having the problem. If this continues with this game i don't want it and want my credit back, i can't play this game from what i have tried. I have never had this much trouble with a game before from BFG. Help me please owlish.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator