Posts created by heidid

 
 
 posted in Aveyond: Gates of Night on Aug 8, 09 7:33 PM
You can do it without the goodie caves, and also without the spider eggs. There are Weevil scrolls available in Ghed'ahre (or however that's spelled ) that have a similar effect. You'll need to buy a few of them, since it's possible for them to "misfire" and not infect Gyendal.

My favorite help in the final battle is actually a sword that's possible to get from battling Medusa.

(Highlight for spoilers)
You can freeze Stella with the Medusa sword, and she won't be able to heal Gyendal at all until the end of the battle. It makes things much quicker, and you can have Mel focus on tripping the bad guy.
 
 
 posted in Aveyond: Gates of Night on Aug 8, 09 7:26 PM
For the gold cave in Brightwood - look for 2 waterfalls close together on the road to Red Rock Pass. Search near them.

There is a 5th cave, actually - search the map of the town of Stormbend when you get there. It contains all the spells for Lydia.

Be careful using that one, though...there's no "partial" for it - it's all or nothing, and takes a bit of the fun out of things.
 
 
 posted in Aveyond: Gates of Night on Aug 8, 09 7:22 PM
As a general rule in the Aveyond games, it's usually not a bad choice to grab the *unique* item in a case like this, even if it looks useless. I have played all of them, and I can't think of an instance where any one-of-a-kind item ended up never being needed. Rule-of-thumb: if you can get an item another way (chests, or stores, for example) then choose the one you can ONLY get in that particular situation.

OK, that sounded rather convoluted - hope I didn't confuse anyone! Enjoy your game...
 
 
 posted in Aveyond: Gates of Night on Aug 8, 09 7:17 PM
It isn't a separate house...it is just a section of the castle, thus "northern wing." Note that it is a place you cannot get into unless you are engaged to Mel. Any other time, the maid near the door will tell you "only the king can grant access" or something similar. Have fun!
 
 
 posted in Aveyond: Gates of Night on Aug 8, 09 12:05 PM
You can't get the spider egg in GOT. It's only available as a side quest in the first chapter.

@Nestorfish: As for "bad selling practice" - there is a long explanation on this forum (can't remember which thread, sorry) regarding Amanda's rationale for splitting this game up into chapters.

Considering that I have purchased many games here that only take a few hours (2-4) to complete, I think that even chapter one, which I completed in just under 6 hours (the 3rd or 4th time through - first was about 8-9) was a pretty good bargain.

Personally, I'm happy to consider the first 2 Aveyond games as *extremely* good deals, instead of looking at these as bad deals, especially in comparison to how much other RPGs cost when they last 30-40 hours or more.

Also, I don't think it was only your grammar that was being objected to. Long strings of ????? or !!!!! make posts very difficult to read.

I'm sorry you did not like the game. Better luck elsewhere, i guess.
 
 
 posted in Winemaker Extraordinaire on May 4, 09 12:49 PM
To add to the strangeness, my husband is having this exact difficulty with his game, but I played the entire game through and never ran into this problem. We're using the same computer (separate log-ins), so it's not even a case of different systems reacting to an installed game differently. Very odd and inconsistent.
 
 
 posted in Youda Camper on Apr 1, 09 11:06 AM
Under the "Construction" tab, look at the 2nd over (I think) and it says "Reception"...there are only two options, and once you purchase them the advertising is no longer greyed out. (1st two available with Medium reception, other two with large).

the Ad campaigns fill up your park quickly, I discovered. They're pretty effective.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Mar 18, 09 2:19 PM
shyanne2000 wrote:i mean the 1 with the pop magic gloves!!!!!!!
the 1 where u need 2 get the 2 blue keys!!!!!!!!


OK, I am guessing this is the initial training on POP magic, right as the game is getting started.

This one took me a while, too. The key on the right side of the board is the trickiest one. The key to this part of the level (pun intended ) is to use the POP magic on two of the light blue sliders at once. They will bump into each other and stop in the middle. It may take a few tries to get it right, but keep at it.

The left side isn't as bad, though if you want the coins on the far side of the flame vents you have to be very quick!

If this doesn't help, post a more specific question. There are lots of tricky parts to these levels.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Mar 18, 09 1:56 PM
Could you be more specific? I'm not sure what you mean by a "walk bridge." I've finished this level, so I'll help if I can, but I don't exactly understand which part you are stuck on. This was a hard level - I was stuck on a couple of places for a while.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Mar 18, 09 1:47 PM
I know which gates you mean; I haven't found those keys either. I was assuming I needed the star key...but I also planned to try an "extra" key of another color, in case the rainbow means it works for anything. I'll post if I find the solution, though.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Mar 14, 09 8:30 PM
You need the red orbs after you finish the levels under the volcano, and once the mirror room in the temple is activated. You actually only need one...all others are optional.

I don't remember where the "deep dark crack" level is, but for many parts of the game it is possible to get all the way back to the "makeshift camp" location. You don't have to redo puzzles that originally blocked your way.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Mar 14, 09 8:27 PM
Icechip, that's a great suggestion. Actually, I spent ages trying to get those dratted turtles to go across the bridge. Every single time, the first did so and the second went north instead. I never thought of trying to pop across the water & keeping the bridge up instead of letting them swim.

Imagine my surprise when I left that until later, and discovered that, with careful usage of my teleports, I could finish the game without needing the turtles a second time. Give it a try... My way used 1 more "pop" than the one icechip suggested, but it's still possible to finish the level.

Good luck, whichever way you try it.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Mar 14, 09 8:14 PM
It's been a while, but I think it makes a difference, in what order you talk to the kabooms. You get the key for the temple after you have talked with the chief of the village, who sends you north to see the temple & talk to the professor. HE tells you to talk to the guy in the south part of the village who has a shop, and I think he sends you off to find another kaboom (south) who has the key. It's complicated, if I'm remembering it correctly.

The Tree of Life puzzle is north of the kaboom village, but I can't remember if it's next to the temple or on a different screen (I think it's the same screen, but southeast).

Good luck; hope this helps. My best guess is that you either haven't finished a puzzle that's needed, or there's someone else to talk to that you missed, though clearly I could be wrong.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Mar 14, 09 8:09 PM
In order to get the middle button, you have to follow the crab all the way to the edge of the water. If you stop and follow carefully, he will not go far enough. I don't think it works the same with the little blue guys, so make sure you use the crab for the middle. You also have to be sure to follow diagonally, so as to avoid the spring. Hope this helps - good luck!
 
 
 posted in Chocolatier: Decadence by Design on Mar 10, 09 10:38 PM
(Grin) Sorry for being picky! Thanks for trying...I've played both the previous Chocolatier games, and I love them - what could be better than sitting & dreaming about chocolate for an afternoon! So I'm having fun regardless.
 
 
 posted in Chocolatier: Decadence by Design on Mar 10, 09 10:28 PM
I gave truffles to everyone (if I had not, that would have showed up in my quest log, which is now empty).

And I think Alex is in Zurich...no Munich in this game to my knowledge. She spoke with me once, but I haven't been able to find her there again, and she didn't give me any quests to do.

No joy so far. It's a great game, though, and I don't mind replaying it.
 
 
 posted in Chocolatier: Decadence by Design on Mar 10, 09 9:26 PM
I'm a bit puzzled...I've received my endorsements from all board members, and NOTHING else happened.

1) I no longer have any quests to work on (though I did fulfill a special order from one of my shops)
2) I am still listed as "Interim CEO" even though according to the dialogue in the game, I should be confirmed by now.
3) I still have 4 "creation" slots to fill, and nothing is showing up to trigger their availability.
4) The only recipes I have left that have not been made are those which require the Honduran cacao, which I don't have yet.
5) I just finished methodically going through the entire map and clicking on every possible place to visit, with no new conversations.

Has anyone else had this problem? I have no idea what to do next - I've tried everything I can think of! I'm wondering if I somehow triggered a bug of some sort that sends me off into limbo-land. I've started a second game and will see if the same problem shows up, and I plan to pay VERY close attention to the dialogue that happens when I finish the requirements for the last endorsement.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Feb 27, 09 11:09 AM
I'm assuming you mean the early level that teaches you how to use the POP magic. I'm not sure which portion of it you're confused about, but most of it can be solved using trial and error. Experiment a bit and see how the different platforms & buttons react when you use the POP magic on them.

The most confusing portion of this level for me was on the right-hand side, where there are several sliding blue platforms to navigate. The key for me was discovering that I could make 2 platforms move at the same time, so they would bump into each other & one would stop. Hope this helps! If you are still stuck, ask a more specific question or you can also look on YouTube...this level is on there with a video solution.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Feb 27, 09 9:19 AM
It would help if you had a more specific question, but in general, you just need to run through the maze. I can tell you that it really helps to use your spyglass to look around before you start, because the ice trolls will freeze you if you pause in any open area. If you have a question about a particular area, post again and I'll try to help.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Feb 24, 09 12:20 PM
That was just the right tip - Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator