Posts created by babstoo

I'm having similar problems. The first few tries, I got "access violation, program terminated", then game played for five minutes and shut itself off. Now it won't play at all and goes the "time's running out" screen. Is there a problem with the game that could be resolved?
I am at the part where Emma & Norm get out of the fire through the brick wall in the basement and need to revive Norm. When I go into the HOS for that I can up the green liquid bottle and the cloth but there's no indication what to do with them. The hint just keeps showing that the bottle and something near the bottom middle go together but I don't know what. Hope I don't have to restart. I'm really enjoying the game except that the constant loading every time I change the scene is annoying.
 posted in Crossroad Mysteries: The Broken Deal on Oct 5, 17 6:13 AM
At some point, you'll find a bradawl to remove the conspicuous brick on the wall which I think is in the hall after the reception room. After you make the special drink the walled up patient wants he will give you a stone that you x-ray and then put the x-ray over the floor plan to find out which one is Anna's ward. I forget where and when I found these things but when I did had to skip the floor plan mini-game because I couldn't find the required landmarks on it. Also, eventually you will find a small white cross that goes on the small box inside the medical kit.
 posted in Nostradamus: The Four Horseman of the Apocalypse on Mar 28, 17 1:12 PM
If you have the mace in your inventory, just use it to hit the snakes.
 posted in Wave of Time on Mar 28, 17 8:29 AM
I'm trying to play the minigame where all the squares are different colours and there are four white squares and you can push the lines up/down or side to side but I don't know what to do or what the solution is.
 posted in Wave of Time on Mar 28, 17 8:25 AM
The map doesn't have the legend, so I don't know what marker indicates an area where something can be done.
 posted in Lifeline on Mar 19, 17 11:53 PM
I tried that, but couldn't find any place to change the mode.
 posted in Whispered Secrets: Song of Sorrow Collector's Edition on Feb 21, 17 8:14 PM
I resolved my own question. The achievement was accomplished by the end of the main game. I don't know where or when but it was just a one-time thing. I always worry when there are no morphing objects in the SG because sometimes they are in the HOP's and I don't know I should be looking for them there unless I checked the achievements before starting the game.
 posted in Whispered Secrets: Song of Sorrow Collector's Edition on Feb 21, 17 2:27 PM
I'm playing the CE and one of the achievements is for getting the first shapeshifter. So far I've played several scenes and haven't found any. Are they morphing objects? Are they found in the main part of the scenes or only in the HOP's?
I just went into achievements and chose "collectibles" and then picked the items I wanted from that inventory bar.
Check the replies above for info about weighing the dynamite.
I also chose life because I think the seeker told us to be kind. I don't think it would change the story line much but I would be interested to know if the other choice did.
The top row bells show you the sequence and then you repeat it on the bottom row bells.
I think the walnut is supposed to replace the missing "5" weight, I couldn't see any other purpose for it. Even so, I couldn't figure out how to weigh anything. I had already crushed all the ingredients before I had trouble with the weighing and when I consulted the SG it was confusing. So I just used the parts of the SG solution that referred to scoops only and had to add one extra scoop of coal and then the meter filled properly. When the meter disappeared that meant the horn was filled correctly. The scoop still hovered over the horn and it kept saying to add ingredients, but then I just continued adding the cork, using the awl and adding the fuse and it worked out.
 posted in Gummy Drop! on Feb 3, 17 6:05 PM
I'm playing Rome right now and have an offer to buy coins in which certain amounts of purchase offer infinite lives. Does anybody know if this means that lives would never run out ever of if the lives would be infinite for a certain period of time?
I replayed the whole game from the beginning. Note: make sure you use a new profile. You have to speak to the professor twice. I spoke to him one time then when finished the key wasn't offered. Then I did the things for the bag which is at his feet. Then I noticed there was an eye icon on the professor again and I spoke to him at the end of which he gave the key.
 posted in Antique Road Trip: American Dreamin' on Nov 22, 16 2:39 PM
Hi, I;m on level 46 and have a quest to play the slot machine, and also find two different plane parts. I found the plane part with the red stripes quite easily in the slot machine on the left side (actually I have three of these parts now, anybody need one?), but have played all the slots hundreds of times with no success of finding the plane part that looks like a mirror or lens. Does anybody know which slot machine has that part? Thank you.
 posted in Nevertales: Hidden Doorway on Oct 27, 16 10:52 AM
I thought this was an excellent game. Great music and artwork. The mini games were very ingenious and for myself it wasn't the usual run of the mill thing. The plot was easy to follow and everything ran smoothly. The speakers' lips were timed perfectly to the dialogue and I always like that. I purchased and played the SE and it had a really long playing time but was not boring. I liked the little robot and felt that it was real. Keep up the good work developers. The ending looked like there would be more coming so I'm looking forward to it.
 posted in Agency 33 on Oct 1, 16 7:56 PM
My game was fine until the last couple of days. The game won't open, I just get a message saying "Agency 33 has stopped working" and I have to close the program. I've uninstalled and reinstalled but still having the same trouble. Any ideas?
 posted in Myths of the World: Island of Forgotten Evil on Sep 18, 16 6:33 AM
I found it confusing too. The left pillar top should be blank and the middle showing two circles. The right pillar should be a single triangle at the top and a single circle in the middle. Hope this helps.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator