Posts created by mrsabba

 
 
 posted in Roads of Rome: New Generation 2 on Jan 2, 18 4:11 PM
How do you get to the island in level 21? I can't seem to find a way. Thanks.
 
 
 posted in Gummy Drop! on Nov 16, 17 3:35 AM
Thanks so much! I wouldn't have thought of that!
 
 
 posted in Gummy Drop! on Nov 15, 17 1:38 PM
I just downloaded the latest update (Nov 2017) and now I can't figure out how to exit the game when I'm done! Can anyone help please?
 
 
 posted in Gummy Drop! on Nov 15, 17 6:29 AM
I just updated Gummy Drop but can't seem to find a way to exit the game. Any tips appreciated!
 
 
 posted in 4 Aztec Skulls on Sep 21, 17 4:36 AM
I have completed this level many times, always getting the three caches. But when i go back to the list of levels, it shows I only collected two caches. What's up?
 
 
Thanks!
 
 
How do I get across the gorge to build the bee hives? I'm sure it's something simple and I'm just missing it, so any help will be grateful.
 
 
 posted in Royal Envoy 2 Collector's Edition on Oct 21, 14 11:04 AM
I have finished all levels in gold except level 48. When can we expect a fix for this level? Would love to be able to access the bonus levels! Thanks.
 
 
 posted in Sweet Kingdom: Enchanted Princess on Mar 8, 14 3:03 PM
Have the donkeys, have the wood, but still not able to upgrade any buildings. What now?
 
 
 posted in Monument Builders: Notre Dame on Jul 11, 13 5:38 AM
I'm on level 2-9, have everything done except the stain glass windows. I don't have enough iron to complete and can't seem to find a way to get any! Any help?
 
 
 posted in Moai: Build Your Dream on Jul 2, 13 8:18 AM
I have plenty of food, wood, stone and mana but can't seem to find a way to complete the 4th statue. What am I missing?
 
 
 posted in Shiver: Moonlit Grove Collector's Edition on May 13, 13 10:20 AM
I had to start over because of too many issues. The second time I followed the strategy guide step by step to get to where I left off the first time around. I just got the lamp off the side of the mill but now I can't find alcohol anywhere! Where is it?
So frustrating!

Oh never mind! I found it finally!
 
 
 posted in Hidden Mysteries®: Return to Titanic on Aug 20, 12 4:45 AM
In the HOS I have gotten all items except the scroll. When I click on it nothing happens. I changed the cursor and still nothing. Now I'm stuck at this point. Any ideas?
 
 
 posted in Entwined: Strings of Deception on Mar 11, 12 3:38 PM
I've made it to the music room but can't find the record anywhere! Without it I can't get into the room with the microscope. Has anyone found it yet?
 
 
 posted in Sea Legends: Phantasmal Light Collector's Edition on Feb 16, 12 6:29 AM
I have finished the game, but the extras box is still chained. What do I do?
 
 
 posted in The Revenge on Mar 27, 11 5:45 AM
I have completed all objectives, have the magic wand, the door is open but I can't get thru it. There are two sparkles on the table where the skeleton was but nothing happens when I click on them or in the area. Help!!
 
 
 posted in Echoes of Sorrow on Mar 18, 11 6:22 AM
I am having problems with the game freezing on me. When I tried to go upstairs it froze on a black screen. Anyone else having similar problems?
 
 
 posted in Virtual Villagers: The Lost Children on Nov 7, 10 6:19 AM
This is the fourth time I have played this game and the only time the cauldron has disappeared! I had my villager pick it up and head for the fire. By the time he got there, the cauldron had disappeared. Any other suggestions other than starting over? Thanks.
 
 
 posted in Echoes of the Past: The Castle of Shadows on Aug 20, 10 4:23 AM
I too am having the same problem. It's frustrating to say the least!
 
 
 posted in Dr. Lynch: Grave Secrets on Jul 6, 10 3:47 AM
Is there a walkthrough for Dr. Graves yet?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator