Posts created by puckizzy

 
 
 posted in Jump Birdy Jump on Jan 10, 14 6:55 PM
I've had this game for a long time & just recently got back into it. Been going along just fine for weeks, then today it seems to be glitchy. I'm lining up the bird as I've become accustomed to on all the levels I've been to, but now it either skips past a star I've obviously hit, or it even hits a black star & doesn't die. Also, it won't "catch" in some of the bubbles when I hit them.

Even when lining up to slingshot somewhere - as I've done hundreds of times before, I miss the mark. Something's off just a bit. I haven't made any changes to my computer, mouse, etc.

What could be the problem??? I even un-installed and re-installed the game.

Help??

Puck
 
 
 posted in Tennis in the Face on Dec 29, 13 8:02 PM
It's kinda like shooting pool....if you know how to line it up for the angle after the bounce...but if you don't get that with pool, you won't get it with the game.

To me, this is a huge stress reliever! Cracks me up, the sound it makes when you slap them in the face!! LOL. I'm about to search for similar games.
 
 
 posted in Shadow Wolf Mysteries: Cursed Wedding on Feb 26, 13 5:19 PM
I have the tweezers, the broken mirror and the bottle of "silver stuff", but I can't find the spring. I've gone thru the walkthrough and I guess I've missed it there. Seems I'm missing one of the planets for the box too...Can anyone help?

Thanks,
Puck
 
 
 posted in Fishdom - Spooky Splash on Jun 20, 12 6:32 PM
jodice wrote:I have one more peeve with all the Fishdom games...why do they only let you use the bottom 1/3 of the tank to decorate? Especially with Spooky Splash? With Spooky Splash you have to buy so much stuff to get all the cups, it ends up looking really crowded, and even if you buy 100 tanks, they are all going to end up looking the same since they have the same BG and so little room to actually put anything! Personally I would love to buy more fish and have less stuff in the tank! :-) That is just my opinion...Or give you alot more room to arrange things!


I agree. Different BG's and let us put decorations ALL OVER the BG - top to bottom. IMO, that would make designing your tanks a little more entertaining.

Puck
 
 
 posted in Fishdom - Spooky Splash on Jun 20, 12 3:36 PM
Hi all.

I've got two fish icons that keep popping up in my little fishy's idea balloon & I can not figure out what it is they want!

One of them looks like an angle fish with a first aid box (little blue cross) and the other one which I keep getting the most, is a picture of a light gray fish with stripes and it looks like he is eating something. He's scooping up little pellets in his mouth.

I've got their feeder and vitamins. I even thought it was the sand they wanted on the bottom of the tank to scoop up and eat or spit out. That wasn't it, as I just purchased the sand.

I want to keep all my fishies happy! Anybody know what these two idea balloons are?

Thanks,
Puck
 
 
 posted in Redemption Cemetery: Children's Plight on Jan 5, 12 1:51 PM
Trebuchet11 wrote:Blue flame on the torch? Mine does not have blue flame.


Yeah, I don't have a blue flame either.... Anybody figure it out yet?

Puck
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 1, 12 10:14 PM
Got it!!! I guess maybe I was clicking on the wrong door. I was trying the right door, but got to the left door quick enough and got the code entered. I'm stuck elsewhere now, but thanks anyway!
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 1, 12 9:27 PM
Hello Severine! You seem to be the one with all the answers for this game! That's awesome! So hopefully, you can give me a tip on how to quickly get this "second code".

I looked at the WT, and I see that I have to "run" down the ladder & back over to the doors, or my code will change. Here's the problem: I can't RUN that fast!! LOL!

I've even written down my own clues like...go up rope, click down twice, turn right.... Not getting there in time.

Is it really a matter of going between the scenes really fast?!? If so, the game may just have to end for me here. Ugh.

Any tips??
Puck
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 1, 12 7:40 PM
Hey Dash, I suppose you're right! Although I don't know what directions you're referring to...I went back and forth so many times on that one. I was frustrated for sure!

Now I'm back to the forums to find out what to do next. I did all the nasty stuff with Mamma and only have one more chamber to open, but lots of inventory and other things to do.

I have to admit, the game has lightened up for a minute - as far as difficulty for me is concerned - not the content, by any means! (Gross!!!)

Where are you stuck at?
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 1, 12 2:00 PM
Big sigh...Figured it out. I went back and gave it one more chance. Trick is, you wait and click the wires at the SAME TIME that the eyes are open. When eyes are red, click red wire and so on.
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 1, 12 1:48 PM
I am so close to deleting this game. This is ridiculous!!! It's not fun, it's not challenging....it's annoying as heck! I am clipping the wires in the order that the eyes show, but the baby blows up every time. I tried the trick of clicking to the left of the blue wire - that is IF I can get to it before baby explodes! Green is first. I click on it & it doesn't work. If I click on if fast and move to red & cut it...it explodes. I've tried every which way.

It's bad enough that this game is entirely too difficult, but if I have to wrestle with pin point accuracy for my mouse to hit the mark - on top of all this..... Geeze.

Very aggrivated and disapointed in my favorite game series. What am I to do if I can't get cut these wires? I'm stuck here, with a credit wasted.
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Dec 27, 11 2:02 AM
I'm a huge MCF fan & I am not digging this game too much. Morphing is ok now and then, but I don't like it for every hidden object scene. And I don't mind the creepiness of this game, (I'm stuck with the pregnant, screaming lady)---but this isn't so much creepy as just kind of sick. But, I'm not even complaining about that - they warned us, so I knew it would be over the top-weird.

It's just that it's so dang hard! I like my H*0G scenes to be tuff, but I have to refer to the forums and the WT with almost every step of the game! Even if I had the CE where I wouldn't have to leave the game to get my clues/answers, I'd still get ticked off that I'd need to get this much help every step of the way. It takes the fun out of it.

And that the diary dosen't keep track of any numbers or clues you get along the way, is a pain too. You have to have a pen & paper handy for everything! My notes may as well be in sanscrit! I can't even decipher what I've jotted down!!! I don't know how people are expected to figure most of this out!!

There's challenging and then there's near impossible. I think the dev's missed the mark with this one. They've taken a SUPER cool series and taken it in a really weird direction. The only thing similar to the previous games, is the graphics/artwork.. I'm really bummed about it.
 
 
 posted in Supercow on Dec 8, 11 7:27 AM
cindyk35 wrote:[I THINK BFG NEEDS TO COME UP EITH SUPERCOW 2 !!!!!!
ANYONE ELSE AGREE??????????????????


I completely agree!!!
 
 
 posted in Alex Gordon on Dec 8, 11 7:14 AM
sirhc56 wrote:I downloaded and kept this game on my desk top for several weeks, playing one or two levels a day. I'm still a fan of the old Mario and Donkey Kong Country games and this reminded me a little of them. Plus, it was fun to collect coins to upgrade my Island! Is there any other games out there like this?


Try Super Cow. Awesome graphics. Type platform game to look for more games like this. That's what I'm about to do. Another good one is Ozzy Bubbles. I think that's the name. Type Ozzy in a search. There's a 1 & 2. The second one is much better & faster playing than the first one. It's got nice graphics too.

Puck
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 28, 11 4:47 PM
Got a tip from another post... If anyone else has this problem, you only need the one brooch to start the game. Complete one side of the puzzle & you'll get the other brooch. You'll have to complete the other side of the mini-game. From there, you'll end up with everything you need to finish the game.

(Except I did miss one rose. Went back to the begining and still missed it...Dang!)
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 28, 11 11:02 AM
Hi All,

Ok, I'm at the end of chapter ten and partly into 11. I've passed the cemetery gate, given the girl her bear & the soldier his sword...played HOS, got brush, got ONE brooch. Can't find where to get the other one, to finish the mini-game.

The WT (to me) reads as tho I should already have two in my inventory - although the screen shot only shows one. I'm missing something around this area apparently.

(possible spoiler alert??)

I've moved forward, got my coal, paper, manhole cover, etc. Need hacksaw to get to manhole under little bridge. Stuck here & still missing one letter for the crypt plate.

So, with ALL that said.....
Basically, I need a second brooch, a hacksaw & my final letter for plate.

If someone could point me in the right direction to finding one of these items, I think the rest of it would probably fall into place. But for now, I'm stuck and waiting for replies. Thanks,
Puck
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 28, 11 10:38 AM
I'm in the same boat.
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 27, 11 8:39 PM
Figured out that I wasn't placing my cursor in the right area while inside the crypt. Duh. If I held it right above my inventory, I could click it and go straight down to the basement. Before, I was hovering over the hole in the floor to the basement or hanging around the angel statue.

Got what I needed, now I'm stuck elsewhere. Dang! Thanks for your help MEnr56 - you got me going in the right direction.

Puck
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 27, 11 7:42 AM
Hi All,
I posted a few weeks ago & I'm still stuck. I've moved on to other games while I wait for assistance in the fourms. I just got a good tip about a missing step I've yet to complete, but I don't know how to do it!! AARRGGHH!!

I need to get the wrench in that vase that is in the crypt with the caskets, along with a few other steps I can't complete at this time.

I've been in the crypt with the big square hole in the floor - several times, but aparently you are supposed to be able to go UNDERNEATH that crypt, to a room with broken caskets on the floor. I think it's there that I get a locket and possibly the hook that is needed to get inside that vase for the wrench.

Hopefully, someone that has played, remembers and can get me in that lower crypt!!

Thanks,
Puck
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 27, 11 7:29 AM
Hi
MEnr56 -

You are right, I haven't gone below to the underground area & I don't know how. Thanks for letting me know there is a step I've missed somehow. I've looked at the WT twice and I didn't get the impression I was to go BELOW the crypt. Gotta figure out how to do that. I'll make another post or search for one referring to that.

And I will make my color darker and larger in the future.

Thank you!
Puck
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator