Posts created by ParadeGirl

 
 
I'm stupid! I had the hammer in my "Inventory" all along. I just didn't see it because it was at the very beginning.
 
 
 posted in PuppetShow: Mystery of Joyville ™ on Sep 19, 10 5:15 PM
I just updated my Mac to 10.6.4 and the game is choppy to me. The game itself works fine but, it looks like a TV set that needs the tracking fixed. Can I fix this somehow?
 
 
 posted in Wedding Dash 4-Ever on Sep 18, 10 10:28 AM
I just started this game and already I have a problem. In the tutorial I can't see the guests and Flo is moving slowly.
 
 
 posted in Drawn: Dark Flight ® Collector's Edition on Sep 2, 10 8:04 PM
I'm so disappointed that it's only for OS 10.5. I was really looking forward to playing this game because I loved the first one.
 
 
 posted in Hotel on Jun 20, 10 6:00 PM
I've got the computer on the hotspot but, it's not doing anything. When I click on it, it just talks about the computer and how it's somehow broken. I'm so sick of having to restart the game over this.
 
 
 posted in Green Moon on Apr 24, 10 1:39 PM
It won't let me change the water to start over.
 
 
 posted in Green Moon on Apr 16, 10 9:21 AM
I started to make the wrong potion/spell. How do I start over?
 
 
 posted in Diner Dash on Feb 11, 10 12:34 PM
I just can't seem to make the business gals happy. I've tried different seating options but, I just can't do it. Help!
 
 
 posted in My Kingdom for the Princess on Jan 26, 10 3:22 PM
I feel stupid because all I'm supposed to do is collect gold but, I just can't pass this level. Does anyone have any tips or tricks that I could use? Thank you in advance for your help!
 
 
 posted in Cake Shop on Jan 19, 10 3:52 PM
I can right click other places but, not during this game. This is annoying!
 
 
 posted in Empire Builder - Ancient Egypt on Jan 17, 10 4:07 PM
reeny08 wrote:
margeryk wrote:OK, I just finished all the levels with three stars and I must say I am a bit disappointed. The game ended far too quickly, and the challenges seemed to get easier as it went along. I opted for the trial version before I actually bought the game and I was excited by the prospects. The graphics are very nice, and there is some new and interesting game play (like the mini games, but even they got boring). I also liked the historical context. But overall, I did not find it challenging in the least. I guess I will have to wait for BAL 5 or Be Richer-er...

mk

im stuck on mission 26 memphis. can u pls tell me where 2 put the mastabas and the houses so i get the happiness required. thnx


Ditto. I can't figure out how to get the $20,000 income.
 
 
 posted in World of Zellians: Kingdom Builder ™ on Dec 19, 09 12:46 PM
I loved this game. I was addicted to it from the geckgo. I can't wait for the next chapter of the game. If there going to be another game? From the ending with Zorm it sounded like there is going to be.
 
 
I'm so glad that I'm not alone in not seeing any similar features in the pipes.
 
 
 posted in Valerie Porter and the Scarlet Scandal on Nov 9, 09 12:56 PM
I finished this game yesterday and I loved it! I hope that Valerie gets to solve more cases.
 
 
 posted in Escape From Paradise 2: A Kingdom's Quest on Oct 30, 09 11:42 AM
I'm also missing one jewel. I've played the games and finished everything but, I just can't find it. I went to the walkthrough and I've got all of the jewels in the pictures. I can't figure it out.
 
 
 posted in Escape From Paradise 2: A Kingdom's Quest on Oct 22, 09 10:08 AM
You have to drag Taz there to play the mini-game.
 
 
 posted in Escape From Paradise 2: A Kingdom's Quest on Oct 20, 09 1:39 PM
Give the cards to the tiki guy who asked for your help in finding them. After you do that it will create the mini-game Tripeaks. Taz has the net and will bring it out when you drag him to a bird or fish.
 
 
 posted in Princess Isabella: A Witch's Curse on Sep 12, 09 11:51 AM
I finished the game yesterday. I liked this game a lot. I hope that there's more like it in the future.
 
 
 posted in Princess Isabella: A Witch's Curse on Sep 10, 09 9:41 AM
veronique875 wrote:You have to use the blue one before you can find the red one.


Where do you use the blue key. I tried to use it in the puzzle but, it wouldn't let me.
 
 
 posted in Princess Isabella: A Witch's Curse on Sep 9, 09 11:54 AM
I'm stuck on the stupid "rock" walkway in the garden and it's so annoying.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator