Posts created by amminnc

 
 
Does anyone know how many "hidden" puzzle pieces there are? Is there one in every level? If so, they are pretty well hidden...

This is getting more and more common; puzzle pieces in all the TM "Hercules" games as well as others, but I think this is the first time we have puzzle pieces in a New Yankee game.

Thanks!!
 
 
 posted in New Yankee in King Arthur's Court 4 on Feb 16, 18 10:06 AM
What is the purpose of building the Druid Temple? Does it do anything?
 
 
 posted in Roads of Rome: New Generation 2 on Nov 27, 17 2:28 PM
Has anyone achieved gold on this bonus level? If so, please offer advice! I've found all the caches but need another 15 seconds to complete the level in gold time.
Thanks!!
 
 
 posted in Roads of Rome: New Generation 2 on Nov 24, 17 9:10 AM
Okay, now I've got the gold -- finally! After building the sawmill and food market, get over to the left side asap. Get the gold mine going as well as quarry. Build up everything to the max. Will need to build a 2nd quarry across the bridges.
 
 
 posted in Roads of Rome: New Generation 2 on Nov 23, 17 1:36 PM
I'm right there with you, Fatandfrumpy. I have gold on every level except this one. Found all the caches, just can't finish in time. I need 10 more seconds. HELP!!
 
 
 posted in Moai V: New Generation Collector's Edition on Aug 30, 17 9:22 AM
No, you are definitely not stupid! Doesn't work for me either. There are several things in this game that I don't think were well tested before release. Sometimes I need to click on something 2-3 times before it does anything. The runes and spells are very confusing indeed!
 
 
 posted in Fables of the Kingdom II on Jun 1, 17 12:03 PM
See the Fables II Collectors Edition forum for a bit more discussion.

I'm looking for help on level 39 and 40 -- any suggestions?
 
 
 posted in Fables of the Kingdom II Collector's Edition on Jun 1, 17 12:01 PM
I'm also looking for help on level 39. Has anyone achieved gold on this level? All suggestions are welcome!
 
 
 posted in 4 Aztec Skulls on May 9, 17 9:42 AM
I can't get it either. HELP!
 
 
 posted in 4 Aztec Skulls on May 8, 17 3:38 PM
Finally got it! I didn't bother building the cobbler, and those few seconds made all the difference. Also tried to be efficient when sending workers from the original work hut and the warehouse. And made sure I eliminated both rows of blockages at the same time. I think in other attempts I waited too long to build the bomb hut.

I upgraded the upper level silver mine to two stars, but not the lower one and that worked just fine. (I did, however, chop up all the silver that was laying around. Same thing with the stone.) Once you've built the stone market, be proactive and keep ahead of the need.

Just try to be as efficient and smooth as possible. I probably tried 20 times before I got the gold.
 
 
 posted in 4 Aztec Skulls on May 8, 17 7:10 AM
Finally! Just got gold on this level. Built sawmill; then added a worker; then food market. Made my way over toward the quarry and built that. Then kept chopping/collecting wood until I had enough for the bridge. Before doing anything else, got enough stone to upgrade sawmill. Next was the storehouse, eventually upgrading it. Then got my 3rd worker. Then upgraded quarry.

The trick is to keep going to the food market as you'll run out of food quickly. Also to work on both sides of the stone blockages.
 
 
 posted in 4 Aztec Skulls on May 8, 17 6:54 AM
Me too -- can't quite make it.

Can anyone offer some help?
 
 
 posted in 4 Aztec Skulls on May 7, 17 10:21 AM
Any hints on how you got gold on this level?
 
 
 posted in 4 Aztec Skulls on May 4, 17 4:30 AM
Also look behind trees; several levels have baskets hidden behind trees.
Move your cursor around on sandy patches or little bumps. If there's a hidden treasure, you'll see "?" prompting you to dig there.
 
 
 posted in Gnomes Garden: New home on Mar 24, 17 2:16 PM
Has anyone reached gold for levels 46, 47, 48 or 49? These are doozies! Any suggestions?
Thanks a bunch!
 
 
 posted in The Voice from Heaven on Feb 20, 17 6:55 PM
I did the upgrade today (have been out of town) but now the game doesn't work at all. Most of the tiles won't move at all; and when I can move a tile to make a match, the match doesn't happen. Is this a problem with the upgrade? HELP!
 
 
Level 1.6 doesn't let you play because the "run faster" button is covering an essential lever that lets you cross the river.
 
 
 posted in Gnomes Garden 3 on Jul 6, 16 9:44 AM
TMFanatic is absolutely correct! The only way to get gold on this level is to let the thieves "steal" the crystals and then use your fireman to catch them. That way you get TWO crystals for every one they steal. To do this, wait half a second to let the thief grab the crystal and take a step back; then click on the thief. Otherwise, I don't think there's any way to get enough crystals to achieve gold. Thanks TMFanatic!
 
 
I have gold on every level except 25a. Any suggestions? I can't find a walkthrough anywhere. As extra tools I'm using the tower staff, rake and bag. Have tried mixing it up but nothing seems to work any better. I can't get to the last two lairs in time.

All ideas are welcome -- Thanks!
 
 
Isn't the advantage that you don't have to deal with the trolls; they just float by. You don't have to collect gems, fire up the altar, and zap them. They just float away.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator