Posts created by Roseyjane

 
 
After playing the demo of the latest MCF game, I was more than a bit disappointed with it.. The graphics are gorgeous, the storyline is good... but the replacement of hidden objects by "morphing" was more than I could take. My eyes were tearing up and popping out their sockets after spending 40 minutes of the demo looking for "morphed" items. The reason I buy hidden object/adventure games is for enjoyment and relaxation. If the "morph" replacement of HOG's trend continues, guess I won't be buying many games in the future. It's too bad..I was looking forward to the the latest MCF game but it won't be a buy for me this time.
 
 
I was not able to finish the game because of the miner's rings. Even though the game allows you to give more rings than called for to the skeletons, it will not allow you to move on. I replayed the entire game and was careful to give only the rings called for to each skeleton and I was able to finish it.
The game is entertaining but I am very disappointed with it's technical quality especially since I paid the CE price. The entire game is very jerky..by that I mean that the screens do not run smoothly and with ease. I also ran into a problem with the game freezing up and crashing at the scene with the hex wrench. Both times I played the game, I was forced to manually shut my computer down because everything froze up. There is also no consistency with inventory items, either. If it calls for 3 inventory items...sometimes it would let you use them without having all 3 and sometimes it wouldn't. I am disappointed that BF offered it as a CE with the existing technical problems. I took a chance and bought it with the CE price but am very sorry I did.
 
 
I am in the same situation. I had 4 rings and put them on the skeletons. I then went back, found the other ring and put it on the skeleton. But, I still have a one skeleton that needs a ring. This appears to be a glitch and I'm not happy about it. I'll give it one more try by replaying the game. If it doesn't work the 2nd time, I'll be contacting the Help Desk.
Jayne
 
 
I collected the 5 rings and gave them to the skeletons. But, now, the game is telling me that I don't have enough rings and need one more to proceed. Please advise on how to go about fixing this. I retraced my steps through the entire game looking for more rings but there are no more rings.
Thank You,
Jayne
 
 
Though I think this would probably be a good game for a child, it is a bit too juvenile for an old lady like me. If I had a small granddaughter, I would definitely buy it for her. But, unfortunately, I do not have a granddaughter so I will not be purchasing this game.
Since this game is a little more lighthearted than the usual dark and gloomy games of late, I was hoping that it was a good pair for me. I am growing very tired of the spooky, dark games of late and would like to see developers concentrate more on the adult, lighter side.
 
 
 posted in Gravely Silent: House of Deadlock on May 20, 11 7:08 PM
I was not able to download the trial CE version of this game so I have been waiting for this version to finally come out. I did want to purchase this with a credit but after playing the trial I changed my mind...simply because the **** items are waayyy too tiny for my old eyes. I found myself coming on with a headache from squinting at the screen trying to see the objects. It looks like an entertaining game but I just can't go through an entire game with not being able to see the items. It's too bad because I had every intention of purchasing the game...but, it's not for me.
 
 
 posted in Fallen Shadows on Apr 23, 11 1:24 PM
After trying twice, I am not able to get past the screen following the first introduction screen. My computer froze up. I had to hit my power button and turn the entire computer off to get out of the game. After reading the messages under technical issues, I found that others are having the same problem.
Big Fish: Is there a "fix" to this problem?
Obviously, I won't be buying or even trying this game until someone comes up with a solution.
Someone posted to change the pixels to 1600 and 900. My pixels only go to 1440 so I can't use that solution.
 
 
There were a few things about this game that I enjoyed..one of them being the talking characters. It was nice for a change to hear the characters speak. The graphics were gorgeous.
But, I have to say, that the Swamp Cannon game was ridiculously tedious and gave me a huge headache! I can't imagine anyone thinking that searching for almost indistinguishable marks on the map would be fun and relaxing! I buy these games for relaxation and just a little escape from the daily tedium and craziness. But, the swamp cannon search was more than I could bear and all it did was give me a pounding headache while tediously staring at the screen looking for tiny, tiny marks on the map.I did make it through the game but won't be attempting the Swamp Cannon game again which means that I won't be playing this game again. I don't want to go blind searching for meaningless tiny marks just to finish a game. The Strategy Guide was worthless. In order to find some meaning to the next steps...it was necessary to get out of the game and consult the Walkthrough. I though the extra money we spend for the Collector's Editions was to include some specific instructions such as a walkthrough within the game.
I am sorely disappointed and won't be spending the extra money by purchasing Collector's Editions again. Sorry!
 
 
 posted in Echoes of the Past: Royal House of Stone on Dec 13, 09 6:18 PM
I have the bag of seeds and tried to sprinkle them in the garden. The seeds won't sprinkle. I don't know what I'm doing wrong because it worked the last time I played this game. I went back to make sure that I did everything right before I got to the garden..everything looked ok. I placed the red bag over the garden beside the gardener but nothing happened..and I did it numerous times trying to get the seeds to work..but, no go. Does anyone have a suggestion for me?
Thanks.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator