Posts created by tarbarme

 
 
 posted in Natural Threat: Ominous Shores on Feb 26, 12 12:27 PM
This game wasn't billed or called a CE game. Why should you get your money back for a regular game?
 
 
 posted in Natural Threat: Ominous Shores on Feb 26, 12 11:01 AM
I didn't get the bonus round too. Its hard to tell what the button really is. I wonder if this game was going to be a CE but the devs changed their mind. Or maybe we are to collect something. Like morphing objects in other games.
 
 
The Devs of the game are already working on the fixes for the game.
 
 
The missing fuse is a glitch in the game. One of the devs who made the game message me here and told me so. They are trying to fix that glitch.
 
 
If we are really really lucky it might be sometime next week. BFG offices are closed for the entire week and might reopen on monday Jan 2. I don't think they view us as valuable members if BFG closes their offices for a full week and just say its a holiday.
 
 
I rather wait for a fix than to start all over again.
 
 
I still think I shouldn't have put the zodiac pieces in the puzzle at the planetarium or put the tnt in the crack in the wall. These 2 things could have caused the glitch to happen.
 
 
I already did the gas handle and got into the snow queen's ice chamber. I'm way past that. I got the tnt and put it in the wall but no fuse.
 
 
well I did all that. Still no fuse or HIdden Object scene! I still think I shouldn't have put the zodiac pieces in the planetarium puzzle. I'm not going to do over with a new profile since this game isn't that good to do so.
 
 
When I go back to the fridge the HIdden object scene doesn't show up!
 
 
You need to put the net that has the snake in the bath tub. The snake not the water is to go through the drain.
 
 
I'm towards the end of the main game and now missing the fuse. I have only the lighter left in my inventory. I put the zodiac signs in the planetarium (the ones I had.) Maybe I shouldn't have done that? I wonder if its a glitch in the game?
 
 
cardano wrote:Any chance the music volume has been set to low? The cutscene voiceover may be treated as music rather than sound on the option panel.


You are right. I had the music down very low. When I turned it up the voices for the cut scenes could be heard. Thanks.
 
 
Sorries did the bad beta. Its a remake of Return of Ravenhearst. With bad morphing stuff.
 
 
So many bugs in the bonus game that I can't even start to play it. 1st time the loading screen froze. 2nd time got to the 1st scene and tried to use the magnifying glass at the stair and it froze just with the glass. Managed to get the guide up but that froze open. I was able to exit the game with going for the alt-ctrl-delete. Looks like BFG is rushing the CE games now.
 
 
 posted in Awakening: The Goblin Kingdom Collector's Edition on Aug 25, 11 6:03 AM
I'm using the scraper to get the tree bark off and nothing is happening. None of the tree bark looks like its coming off. What am I doing wrong?
 
 
 posted in Written Legends: Nightmare at Sea on Aug 6, 11 6:07 AM
I can't get the seam ripper since there is now a mouse guarding it. The guide tells you to get it but I can't now.
 
 
 posted in The Lost City: Chapter One on Jul 27, 11 4:04 AM
Isn't this game was one of Mudrock's likes? (Its on his thread from July 11th.)

(((This is what he said about the game.)))
The Lost City: Chapter One is a very entertaining Hidden Object Puzzle Adventure game. Lots of spooky scenes with some really entertaining puzzles. If you've been looking for a new HOPA, this one should be right up your alley.

I really don't think he plays these game and is only told what to say.
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 17, 11 7:28 AM
well I found the ruler and it was behind the chest after the lid is closed. Also don't click on the big monkey robot at the end. It was destorying the crystal and I click on it again. All of a sudden I had 2 robot monkeys. One was the old one, before giving it an object and the new one still at the crystal. I got the thing I needed before the 2nd monkey showed up.
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 17, 11 5:35 AM
I'm at the hog scene just after I put in the grasshopper puzzle. The items list says I need to find a ruler and the hint button keeps circling an empty step right below the doll. I wonder if anyone else got this glich.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator