Posts created by hangel1

 
 
Is anyone able to access the hop scene in the forge and if so how did you do it? Or is this another Epix glitch?
 
 
I am having the same problem with the ho puzzle. There is no list of objects to collect. So am unable to get mold. I am using windows 7. Is this yet another Epix game I cannot play?
 
 
 posted in Rescue Team 7 Collector's Edition on Jun 16, 17 9:31 AM
After several tries, I figured it out. Remove the snakes on the left side then the right. Good luck!
 
 
 posted in Rescue Team 7 Collector's Edition on Jun 14, 17 9:59 AM
I don't have enough bones to search the ruins and you can't build a pet store to get them. The bulldozer has collected all bones and I have scared all the snakes away. Anybody have a solution for this one? Would appreciate any help. Thanks.
 
 
 posted in Set Sail - Caribbean on Apr 12, 17 11:43 AM
Thank you!
 
 
 posted in Set Sail - Caribbean on Apr 9, 17 11:36 AM
Is there a strategy guide anywhere for this game?

Thanks
Hangel
 
 
I am trying to get the hammer to make the rose branch but when I click the hammer to hammer is won't work. Am I doing something wrong?
 
 
 posted in Rescue Team 6 Collector's Edition on Nov 10, 16 9:14 PM
I can;t seem to get enough people rescued before timer runs out. Any help with this?
 
 
 posted in Weather Lord: Royal Holidays Collector's Edition on Oct 17, 16 11:05 AM
Thank you, that solved it!
 
 
 posted in Weather Lord: Royal Holidays Collector's Edition on Oct 16, 16 9:49 AM
Unable to build fairy house. The game points to the girl on the left of site and she want a light bulb which you can't create because you have no crystals. Each time I have clicked on the fairy house site it won't let me build it. Has anyone else had this problem? And if so, could you tell me how to build it?
 
 
 posted in World Keepers: Last Resort on Apr 20, 16 3:31 PM
How do you get into the pyramid? I clicked on the runes indicated by the clue but it won't open, Hope you can help. Thanks.
 
 
I have tried and tried to figure this thing out but to no avail. I pull the lines down 3 over 3, then try to get it up 2 and over then up to far left. It doesn't work. Anybody know how to make this work? Any help would be appreciated.
 
 
 posted in Gnomes Garden 2 on Jan 1, 16 2:25 PM
Is there a way to make the cable car go ANY faster? Is there a way to beat this level?
 
 
 posted in Building the Great Wall of China 2 on Dec 4, 15 8:15 AM
Can't get enough wood. Removed wood at wall with gold, Still short on wood to build sawmill. Anyone have this issue and hopefully a solution?
 
 
 posted in European Mystery: Flowers of Death Collector's Edition on Nov 16, 15 2:30 PM
I have all ingredients for bomb and am using florist kit. I place the ingredients in the vessels and mix and it won't create it. One vessel in wish I have vinegar says it should be cinnebar. The strategy guide says no its vinegar. What am I doing wrong?
 
 
Thank you so much! It worked and I was able to complete the game. You've been a great help.
Hangel
 
 
Sorry, the puzzle is inside monastery where there are 3 glyphs below the 4 balls. You are trying to get the piece of the moon that is in one of the balls. Thanks.
 
 
I don't understand this puzzle. How do you solve?
 
 
Thank you for your reply. However I don't have one of those. Guess I'll uninstall and reinstall. Maybe that will work.
Hangel
 
 
Where is the skip button? Can't seem to find it!
Appreciate any help,
Hangel
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator