Posts created by bimsquid

 
 
 posted in Awakening: The Golden Age on Jan 20, 16 2:12 AM
A hoopooe is the bird silhouette in the bottom right corner. Use it for a hint. (I think it is a crane bird).
 
 
 posted in Awakening: The Golden Age on Jan 20, 16 2:09 AM
I have all of the other games in the Awakening series and enjoyed this latest game. However, I found it to be dissapointing short. I got SE rather than CE, does anyone else think the SE is short?
 
 
 posted in Jewel Match 3 on Mar 23, 11 1:05 PM
If you have a level that says you have completed each room, but can't advance, try the following. Click the Menu button, then click the Main Menu button. When you get to the Start Menu, then click Play. You should return to the same game and will get the Time
Window. Click OK and the game should say You Win! Hope this works for any with stuck levels. I think this is a great game and play it heaps.
 
 
 posted in Dark Tales: ™ Edgar Allan Poe's The Black Cat on Jan 14, 11 12:07 PM
Thanks DragonLady, shame I can't access them, but enjoyed the game.
I thought it was great. Am getting into HOGs like this more and more.
 
 
 posted in Dark Tales: ™ Edgar Allan Poe's The Black Cat on Jan 12, 11 9:00 PM
This question might have been asked (and answered before) but
how do you get to play the extras??? I have finished the game(PHEW)
but can't seem to access the extras. Do I have to do something else???

Thanks Fishies.
 
 
 posted in Awakening: Moonfell Wood on Jan 10, 11 12:14 PM
The log is on the woodworking bench before you go into the secret passage.
Just click on it to pick it up. You should have already picked up a bust that
is on the table. Hope this helps.
 
 
 posted in Awakening: Moonfell Wood on Jan 6, 11 1:36 PM
Has anyone else finished all the Tripeaks Bonus Games? Wow, this whole
game has been fantastic!! 10 levels of Tripeaks, with 5 sub-levels! Each level
gets progresively harder, but all are do-able. All in all, I think that the Awakening
Moonfell game has been well worth the cost. Thanks Big Fish!!!! More like this
please!!
 
 
 posted in Awakening: Moonfell Wood on Jan 4, 11 3:41 PM
Hi there, have you tried picking up the bow and arrow with the cursor
and then making sure that the cursor is in the very centre of the target.
Click there and it has worked each time I have done it. Hope that helps.
 
 
 posted in Awakening: Moonfell Wood on Jan 1, 11 8:49 PM
On a small shelf that's about halfway up the screen on the left. It will highlight when you get near it.
 
 
 posted in Awakening: Moonfell Wood on Dec 30, 10 10:43 PM
I LOVED this game as much as Awakening the Dreamless Castle. I found that it froze
up briefly, but got around this by hitting the Windows key and then minimizing the Big
Fish Game Manager.Then click the game from the taskbar. If you do this as soon as the game has finished loading (be paitient and don't hit any keys until then). This seemed to fix the problem easily. I am now playing Tripeaks, which looks like it will be quite a long bonus game. Yessssss. What a change to have a bonus game that goes beyond a few rounds.
 
 
 posted in EcoRescue: Project Rainforest on Jun 10, 10 11:08 PM
If the pieces are really tiny then they might be the tigers paws. These pieces go at the very bottom and are hard to spot unless you look closely.
 
 
 posted in Hidden Wonders of the Depths 3: Atlantis Adventures on Apr 29, 10 10:56 PM
Love the Crab!!! He and his mate are really funny. Have
completed both Timed and Relaxed and loved every level.
HWD2 is a great game as well. I haven't had any problems
(apart from not wanting to stop) with either game. Don't
know what some people have against the Crabs.
Group tiles are my all time favourite as well.
 
 
 posted in Lost in Reefs on Mar 17, 10 1:28 AM
Thanks for the reply. Yes I had a great time playing it too, never mind about
the funny ending. Am still playing and enjoying. Thats the main thing!!!!
Very little fishy I am but learning to swim!!!
 
 
 posted in Lost in Reefs on Mar 15, 10 11:15 PM
I have finished this game, got 300 000 points, opened the secret door
but can't figure out what to do when the door opens. Does anything
happen? Can you get untimed mode?
Is it just me being dopey?????
 
 
 posted in The Sultan's Labyrinth: A Royal Sacrifice on Jan 27, 10 6:37 PM
Had the same thing happen to me, got very frustrated with the whole game.
Started from the beginning again, same thing. Grrrrrr. Got the last piece (top
left) to place. Just kept clicking it on the right place and PRESTO!!! it went in.
Might work for you.
 
 
 posted in Atlantis on Oct 30, 09 1:22 PM
If only the Extra Life bonus is lit up, have a look at the bottom of the screen as you play. You might have selected another bonus and not used it. If you use the active bonus, then you will be able to purchase others. Hope that helps. I have found that the bigger your screen, the easier (!) it is to play this game. PS try Atlantis Sky Patrol, it's a great game.
 
 
 posted in Hidden Expedition: Everest ™ on Oct 2, 09 5:58 PM
The Bonnet is on the top of the steps in the centre of the picture, just to the right of the ice skate.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator