Posts created by bajacalla

 posted in Grim Facade: Broken Sacrament Collector's Edition on Apr 12, 18 11:43 AM
interesting error. downloaded the game, tried to open it and was told it wasn't optimized for my Mac. impossible for me to have downloaded the PC version. so, I tried to delete it, and was told that it was running so couldn't be deleted it. right clicked on the icon and hit "quit," but it doesn't quit and will not delete, cannot play. what's up with that?
I have downloaded, uninstalled both game and Game Manager 3 times on my Mac, re-downloaded, opened, started, and each time the game locks up my computer at the player creation screen. I've been forced to hard reboot my computer each time, and this isn't worth it to me.

unplayable game; no sale.
bfgBeruna wrote:Hello GreyGhost,

I'm sorry that turning off the customer cursor impacts the ability to see the magnifying glass clue. I definitely understand wanting the issue to be fixed, so I'll absolutely pass this information along so the matter can be investigated. Thank you so much for your patience.

Sometimes, reinstalling Adobe Flash and Shockwave can fix the issues that prevent a cursor from working. The help page below will walk you through that process, if there's any interest:

<a href="">Reinstall Adobe Flash & Shockwave (Computer)</a>

If you would prefer to replace the game, I recommend contacting our <a href="">Technical Support Team</a>. They're be equipped to handle this exchange. Please PM me or another moderator if there are further questions. We'll be happy to provide whatever answers we can.


yeah, that link gets:


You're not authorized to access this page

Take me back to the home page

now what?
 posted in Lost Lands: Ice Spell Collector's Edition on Sep 12, 17 1:42 PM
on a Mac. did NOT receive the recipe after completing the tapestry. game is now unplayable.
Vintage paints: once I complete the red jewel and receive the red paint, part of the red jewel returns to the ornate box, and I cannot choose any other color piece. "Reset" does not work, "Skip" does not work. I have quit out and restarted, but that does not resolve the problem.

This make the second game in a row I've purchased where a glitch makes the game unplayable.
 posted in Moai V: New Generation Collector's Edition on Aug 29, 17 6:56 PM
three times now, with only a few tasks to go, the game crashes on me, with a message to "contact the administrator."

has anyone else had this happen? it's really frustrating!
 posted in Vermillion Watch: Order Zero Collector's Edition on Aug 7, 17 4:10 PM
thank you both so much!!!
 posted in Vermillion Watch: Order Zero Collector's Edition on Aug 6, 17 1:13 PM
this is not the first game I've purchased that indicates it has "souvenirs" in it to collect, but I've yet to find any. none of the guide's locations actually show anything that's collectible - I have no trouble with morphing objects or "collectibles," it's just the "souvenirs." what am I missing?
I'm flummoxed as well.
 posted in Ominous Objects: The Cursed Guards Collector's Edition on Apr 27, 17 7:31 PM
same here - slash through shield, but NO LIGHT. *nothing* points to *anything.* I'm on a Mac and an experienced gamer, not just HOGs. I'm not "overlooking" anything - there is *no light.* waste of a hint button.
I am in the *exact* situation. of course, it's after I purchased the game!
I've looked and looked, finished the level in gold, and still have not been able to find the puzzle piece. the guide doesn't mention it.
I've looked and looked, finished the level in gold, and still have not been able to find the puzzle piece. the guide doesn't mention it.
 posted in Epistory: Typing Chronicles on Oct 12, 16 7:05 PM
this has to now be one of my favorite games. I love the typing aspect of it, especially for battles, because I can type MUCH faster than I can aim and shoot. I love the origami-style of landscaping, which adds to the whimsical look of the game. for some reason, I never got two upgrades, and I didn't get all the picture segments, but I finished the game after several days, and was very charmed by the ending. I also like the "you cannot die, so try again" aspect, and that alone was enough for me to recommend it for my preteen grandkids. plus, they'll learn to touch type!
 posted in Epistory: Typing Chronicles on Oct 12, 16 10:25 AM
 posted in Phantasmat: Reign of Shadows Collector's Edition on Oct 8, 16 7:14 PM
I'm having the same problem. I'm scraping and scraping and scraping AND SCRAPING, but nothing happens. I can't drop the ice scraper, and I cannot open the handle to the door.
 posted in Moai IV: Terra Incognita Collector's Edition on Jul 7, 16 3:17 PM
I was able to build the Moai statue to gain mana, but before I could build the altar, my villagers dropped to two. I can't figure out how to either gain another or maintain at 3!
 posted in Spirit of Revenge: Florry's Well Collector's Edition on Jun 25, 16 1:50 PM
1. crashed right at intro
2. restarted, then froze upon entry into Bolton's office.
3. restarted. there is no map in Bolton's office, no second ghost, have collected 2 "morphing objects" hints, but cannot use them (unresponsive)
4. I'd say this game is far too buggy to warranted anything but a pass.
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 13, 15 6:33 PM
Mac, El Capitan. game has crashed now three times, "error activation" showing up on Game Manager, makes it not just unplayable, but undesirable.

 posted in Dark Romance: Vampire in Love Collector's Edition on Nov 2, 15 11:20 AM
all of the other threads are locked, and this was a bargain offering today, but this is horrible - the hint button doesn't work, not all the items are actually available, and there is virtually nothing to like about this game.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator