Posts created by Celestien

 
 
 posted in Dark Parables: The Thief and the Tinderbox on Oct 22, 16 6:19 AM
As far as I understand from the walkthrough, there should be a red marble in the puzzle on the palace door.... but there isn't. So the only thing I could do was skip this puzzle. Developers mistake?
 
 
 posted in Grim Tales: Crimson Hollow Collector's Edition on Oct 5, 16 6:42 AM
I can't find it either, and the hint is not helping me.... Anyone?
 
 
 posted in Grim Facade: The Artist and the Pretender on Nov 9, 14 2:55 AM
I can't put the last piece of the diving suit anywhere on the suit.
I mean the little sack. According to the drawing, it should be put aside the other that's already hanging there, bu wherever I click with it, it won't fit.

What am I doing wrong?
 
 
 posted in Beyond the Unknown: A Matter of Time on Aug 10, 14 12:48 PM
Celestien wrote:
ozgenie wrote:The HOG where the two angels are..... you can't pick up the plate to complete this HOG. Tried it on two different installs but no go. This is a glitch


I have this same problem. The hint tells me I should click there.... and nothing happens. I cannot finish this HOS!


> oh, I just managed to get it. The spot on which you can pick this plate up must be VERY small. Still a glitch then ;-)
 
 
 posted in Beyond the Unknown: A Matter of Time on Aug 10, 14 12:46 PM
ozgenie wrote:The HOG where the two angels are..... you can't pick up the plate to complete this HOG. Tried it on two different installs but no go. This is a glitch


I have this same problem. The hint tells me I should click there.... and nothing happens. I cannot finish this HOS!
 
 
 posted in The Theatre of Shadows: As You Wish on Sep 9, 12 5:28 AM
I found it. Youcan only use ths hand with the spray. The button in the middle of the arrows is meant to suck op paint or to spray it. The arrows do not work in a logical way; I had to click once up and then a lot of times 'right' to get the spray at different spots.
We'll probably need the arm with the brush for something else later.
 
 
 posted in The Theatre of Shadows: As You Wish on Sep 9, 12 5:22 AM
I'm having the same problem. restarted the whole computer and still nothing...
 
 
 posted in Oddly Enough: Pied Piper on Oct 24, 11 6:53 AM
Thank you so much, nabsuc!! I was getting really annoyed.

Now I'll tell support that the problem is solved. I already forwarded this issue to them...
 
 
 posted in Oddly Enough: Pied Piper on Oct 8, 11 11:37 PM
Yep, I'm having the same problem now. I'll report it at Customer Support. To be continued...
 
 
 posted in Unsolved Mystery Club ®: Ancient Astronauts ® on Oct 1, 11 10:59 PM
I drained the fountain first (did not take the copper tube out before that because I didn't notice it) but now I really can't find the copper tube anymore.
I do not see it lying around or something. Help??
 
 
 posted in Grim Tales: The Bride on Sep 29, 11 9:39 AM
Pheew. Thanks so much for the explanation! I would not have thought of that...
 
 
 posted in Dream Chronicles: The Book of Water on Jun 2, 11 5:39 AM
I encountered the same problem and yes, I have all the parts of the hammer )two of them, and it says ´100%´. I tried the Wield spell, it flashed all right, but the hammer is still in two pieces.... and when I want to use the spell again, the game says ´ther´s no reason for using this spell now´ of it says ´I´ve already used this spell here´.

????
 
 
 posted in Hallowed Legends: Samhain on May 29, 11 9:44 AM
I'm trying to solve the puzzle where you have to`have to drag the orange barriers into the correct spots so the emblem on the left will fall above their matching tiles. The tiles are all animals, starting with the snake, then the eagle, and so on.

Even when I put the orange barriers exactly on the right spots, following the Walkthrough, something strange happens in the third column. When I have put the barrier in the third row correctly (i.e. sending the tile down in the 3rd block) it DOES go down there but... turns back to the left ON ITSELF towards the wolf, without any barrier standig there! When I try to work around that, another tile will miraculously turn around in the third column somewhere!
Is this an bug? And if so, is there an updat for the game to fix this?? I can't go on with this game now!

 
 
 posted in Doors of the Mind: Inner Mysteries on Apr 10, 10 8:07 AM
Just finished the game. I liked the story and the game. Perhaps it was a little bit too easy sometimes. And I was a bit disappointed to find out that after the demo, having bought the game, I finished it in - I think/guess - half an hour or so.
 
 
 posted in The Mysterious City: Golden Prague on Mar 19, 10 1:43 PM
I agree with happylabs. And it is booooooring. Not a real story, just a hasty little story and then you'll just have to find thins and spot differences and so on... for what exactly?
No, surely a no-buy. I played for about 10 minutes and then deleted the demo.

Sorry, before this I finished games like 3 Cards to midnight, and such games are soooo much better.
 
 
 posted in Azada ™: Ancient Magic on Mar 10, 10 3:25 AM
mcmena wrote:yea! just finished azada 2 so my timing is perfect! 2 questions for other azada lovers: what other games have you played in this vein that you liked? i love these kind of adventure/logic games. anything from cheesy ones like the dream chronicles series to escape games that are in the style of the orginal myst (though nothing ever compares to that). big fish is great b/c of allowing free trial but they stink at categorizing and describing their games. constantly have to download to really see what it is. i like a hidden object element but only when it fits into the story. can't stand the ones that are just a bunch of random crap spread around - you'd think they would at least use period appropriate objects for the specific era games. any input would be appreciated. i have a mac btw
also - on the first azada - i had to stop playing b/c i can't get past the first matchstick puzzle - it says you must move at least 4 sticks to make the fish face the otherway but it only allows me to move certain sticks. i can't get more than 2 sticks to move. don't know if it's a glitch - i do find that azada and especially az 2 quit for no reason sometimes and had a few other glitches in az 2. help? hate to use an orb for that especially b/c i need them for things like the robot game b/c i suck horribly at quick clicking


Yes, I also just finished Azada Ancient Magic and am happy to learn that the next one is coming THIS MONTH.

To Mcmena: there are a lot of games which you'll like, I think. I'll just list some:
- Green moon
- Mystery Case Files: return to Ravenhearst
- Mystery Case Files: Dire Grove
- Drawn: the painted tower
- all the Natalie Brooks games
- Nightfall mysteries: Curse of the opera

Hope you haven't played them all already...
 
 
 posted in Azada ™: Ancient Magic on Mar 8, 10 7:27 AM
Phew, I finally finished this book, also with help from this forum.

The thing is to get the mirror frame (you can just pick it up at Vulcan, page 3) and the portrait of the Baron (which is in the treasure chest on page 1- get the hearing aid-thing from the moon man to open the chest). Then combine the portrait and the mirror frame and give this to Vulcan while snatching away his mirror. He'll turn into rage and not pay attention, so you can also get the card.

Then do the thing with the mirror and the laser machine. You can find how to do this eslewhere ont his forum.
 
 
 posted in Azada ™: Ancient Magic on Mar 7, 10 7:16 AM
Oh.... silly me. I can just close the note and pick up everything in the office.

Shebadog, for the note you need to pick up a Runes book, a Latin book (both on the shelves on the right behind the professor), a looking glass and you need to solve the minerals puzzle (also on the bookshelves) first to get an cryptex from the professor. Then you will have to put these four objects in the right order on the note. Just try, and then it will be decrypted.
 
 
 posted in Azada ™: Ancient Magic on Mar 6, 10 3:05 PM
Well, I wouldn't call myself an amateur at puzzles but... I did not get all the things at the professor's office and now I'm stuck at the runes puzzle. But I cannot go back to the professor's office!

So now what..???
 
 
 posted in Nancy Drew: Warnings at Waverly Academy on Mar 2, 10 7:12 AM
I'm having the same problem here. Cannot get it right. So HELP???
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator