Posts created by camgold

 
 
 posted in Cubis Kingdoms Collector's Edition on Feb 14, 18 12:05 PM
I am stuck on Level 115 anybody know how to win that one you only have 6 tries?
 
 
 posted in The Far Kingdoms on Nov 19, 13 8:34 AM
The settings do not work, could not turn the music down and there was no voice at all.
Also would not save and had to start over. Will delete the trial.
 
 
 posted in The Snow on Aug 29, 13 8:55 AM
Love the game, after playing demo bought it. Only thing I don't like is the part where you have to grow the tree, I played for over 4 hours trying to just finish that one and still didn't finish, had to stop for dinner and when you stop (quit) you have to start that one all over again, there should be a resume as it takes for ever to grow that tree, first you have the vines (or limbs), then you have three stages of flowers and it takes for ever to fill the bar at the top just to get one limb or one flower. Now I have to start this stage all over again, I don't know when I will have another 4 hours of even 5 to do this. Ugh
 
 
 posted in Grimm Reaper: Hidden Tales on May 21, 13 12:22 PM
Same problem as others, after about 20 minutes it keeps kicking me out and back to desktop. I liked the game but don't have the patience to keep getting back into it so I deleted it.
 
 
 posted in Royal Detective: The Lord of Statues on Jul 14, 12 9:21 AM
Very slow. When I went to just try the game it said my trial was over?? so I purchased the game which was a mistake, I like the game but the play is so slow I can take a nap between each scene and watching things move into inventory. I wished I had read the technical issues first.
 
 
 posted in Jewel Quest Mysteries: The Oracle of Ur on May 24, 12 1:54 PM
I like the jewel quest games but this one seemed very short, I did have to skip a few of the puzzles where you had to rotate items, you could click on them forever and they wouldn't rotate. The jewel quest boards were not hard but still haven't figured out where the timer is, maybe I am just not looking cause I am trying to turn everything to gold (lol). I am now going through it a second time.
 
 
 posted in Jewel Quest Mysteries: The Oracle of Ur on May 24, 12 1:47 PM
Had no problem with boards but did with the rotation of letter pieces, etc. I clicked and clicked and sometimes they would rotate and sometimes they wouldn't. Had no problems with the sun room.
 
 
 posted in Echoes of the Past: The Citadels of Time on Oct 28, 11 1:59 PM
Having same problems won't save and freezes if I go to options and then try to get back. I was really liking this game but I can't play this in all at one time. If I had known I was going to have these problem's I would not have bought it.
 
 
 posted in Slot Quest: Alice in Wonderland on Apr 21, 11 5:48 PM
I got past the Queen of Hearts but am stuck with The Witch on second book Fairy Tales, if I had known it wasn't going to let you get past some of these spots I never would have bought it. I have tried about 7 times and still not even close, she slows down your play about every couple of spins and then the bonus's are so slow you don't have a chance. Yuck!!!
 
 
 posted in PuppetShow: Lost Town on Apr 15, 11 12:31 PM
Installed new version working fine except there are a few things missing in ****, hint shows where it should be and the walkthrough shows it but it is not there and I can not continue. There is suppose to be a lever in a chair next to an umbrella - not there!! Help!
 
 
 posted in PuppetShow: Lost Town on Apr 14, 11 7:58 AM
Having same problem with trial version, running snail slow, even had a hard time getting to the menu to get out. I love the PuppetShow series and was so looking forward to this one. At this time will not buy until fixed.
 
 
 posted in PuppetShow: Lost Town on Apr 14, 11 7:53 AM
I have downloaded the trial version and am having trouble with it, it runs so slow it is aggravating. I love the puppet show series but am now leery to buy this one, anyone else having a problem with it being slow (snail slow)?
 
 
 posted in Death at Fairing Point: A Dana Knightstone Novel on Feb 8, 11 4:51 PM
I loved this game, it was long enough so you didn't feel jipped, puzzles were just right for me and didn't have to skip only one (frustration set in). Story line and graphics were very good. It was refreshing to play a good one for a change and I spread it out over a few days, most of them are really short and only take an hour or two to finish. I will play this game several times and enjoy it each time and work at accomplishing all the puzzles. Thanks BFG.
 
 
 posted in Behind the Reflection on Feb 4, 11 4:09 PM
I am having the same problem, if you try and put one in the wrong place more then once they disappear, same thing when you get to the bones, this has to be a software error.
 
 
 posted in Kingdom of Seven Seals on Jan 26, 11 1:51 PM
Get the gold in the casino's, look at map find $ signs go there and play.
 
 
 posted in Kingdom of Seven Seals on Jan 26, 11 1:49 PM
There is no guard by the Dwarf's house???
 
 
 posted in Crossworlds: The Flying City on Jan 9, 11 9:24 AM
YES!!
 
 
 posted in Art of Murder: Cards of Destiny on Jan 3, 11 8:32 AM
Finally got it, I found you have to examine everything she picks up by right clicking on it and she makes her comments, finally got the oil and poured it on the lock, after finally finding the lock, it was not very obvious and didn't look much like a padlock, inserted the key and low and behold I got the grate open, only took me two days and lots of hours of frustration. Not fond of this game and wish I hadn't purchased it.
 
 
 posted in Art of Murder: Cards of Destiny on Jan 2, 11 8:25 AM
I totally agree. I have deleted the game from my computer and then reloaded it (which takes a long time as it is a huge file) and it still didn't make any difference. I have got over a hundred games from BF and this is the first one that I have ever had a problem with.
 
 
 posted in Art of Murder: Cards of Destiny on Jan 1, 11 3:25 PM
I have tried everything, I can't get her to say it's rusty, I don't even see a real padlock on the bars, everytime I click on the right side where there's an area that is thicker I just get answers like: Yeah right, nothing doing or these items don't match.
I'm really hating this game, I have followed the walkthrough exactly, etc. The help button is worthless. Anyone one got an other suggestions? Help!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator