Posts created by robin2u

 
 
 posted in Elven Legend on Mar 9, 15 11:30 PM
When each level begins (before you click to start) there is a screen that tells you what the goals are for that level. At the bottom of that goal list are some icons. If you set your mouse over the icons it will explain what each icon represents, for example speed, extra worker, one extra resource and so on. I hope this answers your question. Good luck!
 
 
 posted in My Kingdom for the Princess IV on Feb 9, 14 3:04 PM
I got this code several times at different levels too. I also just restarted and all was well. Now if only I could get gold on level 4.9; then I'd be happy <smile>.
 
 
 posted in Adelantado Trilogy: Book Three on Jan 14, 14 9:05 PM
You can install a corrected version now at BF. You won't lose your profiles. Yippee!
 
 
 posted in Build-a-Lot: Mysteries on Aug 3, 13 3:16 PM
ianw12 , I also tried for this award. I built and appraised 75 plus cabins on one level. It just doesn't work! Kind of a BUMMER to get top scores on all levels and get all other achievements and be denied this one. I KNOW it is only a game, but you'd think the developers would fix this. It isn't 'only a game' to them, it is a livelihood, right?
 
 
 posted in Build-a-Lot: Mysteries on Aug 2, 13 8:42 PM
Thank you sipason!
 
 
 posted in Weather Lord: Hidden Realm on May 29, 13 12:52 PM
I didn't get gold on this level yet, but to help the mole you have to build the bridge, then send a fighter there to rescue him. After that, the artifact shows up by his foot.
 
 
 posted in Sweet Kingdom: Enchanted Princess on Feb 19, 13 6:12 PM
You can delete all of the buildings except the sawmill (you'll need that). Then build a market (close to the stronghold) by clicking on the square in the lower right of the screen. Then build 3 each of dairy and curd farms and go as fast as you can to make the wood, sell the curd and build the towers. Last, bribe the troll and get the artifact. Hope this works for you!
 
 
 posted in The Golden Years: Way Out West on Feb 14, 12 10:54 PM
I had the same ending, but I just replayed the game and there was more after that. I don't know if you want to know (spoiler) or if you'll just replay the game. The actual ending was cute, and worth the replay IMO.
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 31, 11 11:36 AM
I loved both games, and finally got 100% achievements. The only hope I have for RE3 would be a tally in the achievement area for count items, so I can know which enhancements I need to get up to total, or how many lanterns left to light.
GREAT GAMES developers!
p.s. I rather suspect that the developers had tongue in cheek when they decided that we had to replay certain levels as many as 30 times in order to gain all of the achievements. I would have liked some less boring way to end the game with 100%. Still, the game is addictive and enjoyable in many ways! Thank you!
 
 
 posted in Royal Envoy 2 Collector's Edition on Dec 29, 11 9:14 AM
I got the 1000 on level 41 Expert, but I haven't gotten the 100 yet. Good luck!
 
 
 posted in Pioneer Lands on Aug 16, 11 1:45 PM
Hi! I'm having a time with that level too! It is the only one I didn't get the "award" on. I think I'm at level 60+ by now (I just play a half dozen levels or so each day). Bummer, huh?
 
 
 posted in Gourmania 2: Great Expectations on Mar 30, 11 5:47 PM
Thank you for answering AnnBy. This final restaurant has no bar, but I do know which one you are thinking of. I tried sponge, brush and even a lot of broom. I scrubbed that "Grand" sign with all available, and went inside and did more. Windows have never been cleaner than those in this place LOL. All I know for sure was that this game, though doable, was very frustrating in that it lacked a clear path to success, if obtaining all the stars was your goal. sigh....
 
 
 posted in Gourmania 2: Great Expectations on Mar 29, 11 8:57 PM
I am very frustrated, for sure. I have cleaned more than I ever wanted to clean anything and still I can't get that last star at the Grand. It is so disappointing to get this far and not be able to complete the game with all six star restaurants because of CLEANING! Sheesh!
 
 
 posted in Island Tribe on Jan 30, 11 10:48 AM
Me too!
 
 
 posted in King's Smith 2 on Nov 25, 10 8:24 AM
Oh well, I thought I'd spend a little down time trying this game, but no cursor. Really! I was able to switch to windowed mode because the GAME recognizes where the cursor should be showing, but it is ot visible to me. I'll uninstall and try again when the bugs are fixed, I guess.
 
 
 posted in Drawn: Dark Flight ® Collector's Edition on Oct 2, 10 4:48 PM
I am having the exact problem. I restarted the game, then a second time I restarted my computer, and now I am on the third attempt, I am trying to open the book on the pedastal (in the library, in front of the statue). Now I am stumped. Anyone find an answer to this problem yet? I did buy this CE from Big Fish, btw.

moonsong42 wrote:I've been really enjoying the game, played through and bought the full version with no problems...until I tried to open the 2nd book in the library. The game minimizes, trying to open it again does nothing, and if I use the Task Manager to check on current processes...the application shuts down. However, the BFG Game Manager doesn't show the game as having been quit until I kill the two (?) Drawn II processes running.

Is this something that can be easily fixed?
 
 
 posted in Miriel's Enchanted Mystery on Jun 28, 10 5:31 PM
Okay, I looked again and found what I needed to start as a different player, or to start a new game. I am abashed. Can fishies blush? LOL
 
 
 posted in Miriel's Enchanted Mystery on Jun 27, 10 3:03 PM
Has anyone tried to start a new game (after getting past the screen where they ask if you want to retire or continue)? I didn't retire, I continued, just to buy the rest of the objects from the merchant, and now I can't begin a new game. There seems to be no place to entera "new player". I tried uninstalling and reinstalling, but I just continue on after level 41 is over in my reinstall. I have never had this experience with a game before. Is this game a "one play through only" game?
 
 
 posted in The Otherside: Realm of Eons on Dec 8, 09 10:12 PM
Hey, I'm having the same problem, and my hint button doesn't work, either. I checked screenshots from the walkthrough here AND on gamezebo, and there are no missing hieroglyphs for me to find! Dang.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator