Posts created by STL531

 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Jul 13, 09 5:42 PM
Do you just have to drack a stick to Jep for him to chew on it?

Because I have tried doing that (as well as using the axe an dthe knife) on the bamboo stick, on twigs, on a wooden pole, and on the large branch, and none of that is making a pointed stick...
 
 
 posted in Aveyond: Lord of Twilight on Jun 16, 09 6:02 PM
If you've seen the reporter in Thais after seeing the sleeping princess, she prints it up as a story and you'll see newspapers in all of the towns about it.

The blind guy is sort of SE in the Sinoa Plains.
 
 
 posted in Aveyond: Lord of Twilight on Jun 16, 09 6:00 PM
Have you taken the merchant road thing yet?
 
 
 posted in Aveyond: Lord of Twilight on Jun 14, 09 9:45 PM
paulfinnell wrote:I just finished this game. I did enjoy it but I think $10.00 is a bit much since it has three more chapters. I bought this game off of amaranth. Really if there is going to be chapters most computer games cost only 20.00. So, please do sell for a better price, probably 5.00 instead of 10.00. Over the course of 4 chapters it will 40.00 for the full game when I only paid 20.00 for Aveyond 1 and 2. I think the next chapter should be free for me or anyone else since we did pay 10.00 for only a part of the game. I agree it is a rip off. If I have to continue to pay 10.00 I probably will not buy again until it is finished. I will have still had to wait a year.


Well I would suggest joining the Big Fish Game Club, which recently lowered its prices so all games for members are just $6.99 (and I'm pretty sure there are no longer any minimum buying commitments--you get one credit a month and can buy extras for $6.99 or cancel at any time).

Buying both chapters (apparently there are only two, not four?) would then be $13.98, which I think is very reasonable.

Plus Aveyond 1 and 2 are also on Big Fish (for $6.99 each for members), which is particularly awesome for people who are just discovering the games.
 
 
 posted in Aveyond: Lord of Twilight on Jun 12, 09 7:01 AM
I'd just like to say that I've noticed that Big Fish has altered the game description page to include that it is the "first chapter of the Orbs of Magic series," which I very much appreciate.

Like many of the rest of you, that was really my biggest issue... I'll gladly pay for the next one and understand the financial need of Amaranth Games to introduce the games this way, but it just needed to be clear to purchasers that this was going to be the case and that it was not a self-contained game.

Kudos to Big Fish/Amaranth Games for fixing the description!
 
 
 posted in Aveyond: Lord of Twilight on Jun 9, 09 8:55 AM
When I double checked to see if they had both saved using the above method to find the file, both of my saved games appeared (and it just automatically did it that way in the game). I don't know if there's some problem that is preventing other people from saving in multiple slots at the end of the game, but mine worked fine without having to "manually" edit the file names. Thanks for the tip, though, Amanda.
 
 
 posted in Aveyond: Lord of Twilight on Jun 8, 09 8:11 PM
I did the same (did a second round with goodie caves), and it seemed that I was able to save in a second slot--it definitely showed up as two different saves on that end screen. So hopefully they will both show up when I download the next one.
 
 
 posted in Aveyond: Lord of Twilight on Jun 7, 09 6:06 PM
While I understand where Amanda is coming from, I think both the game developers and Big Fish needed to be clearer on the game's download page that this was the case. I have played Aveyond 1 and 2 and enjoyed them both, and was expecting a game similar in length. I think price-wise I wouldn't have felt ripped off so long as I had known in advance that I was signing up for just part one.

And apart from the whole issue of whether or not that is "fair" to the players... as I was not expecting the end of the game to come when I got the first quarter key, I still hadn't completed some of the other smaller tasks. Looking at some of the other questions on the forum regarding those tasks (finding a shovel, getting rid of pirates), it seems that those things can't be done until the next chapter. How is a person supposed to know this in the game? I was frikkin' wandering around the mines trying to pick up all the random shovels lying around and it was even more futile than I initially thought...
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 4, 09 4:51 PM
Yes, there are TWO doors that will have footprints to them. The first one you want to go into (the office) is sort of near the top right of the screen. The other door (which is in the middle on the left side of the screen) is the theater and you go there only AFTER getting the key that is in the drawer in the office.
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 3, 09 11:43 PM
Hi all,

Since I often like to see what other people thought of a game before I buy it and there isn't a thread on this forum yet regarding that, I thought I'd go ahead and post first.

I just finished the game and I'd give it a 3/5.

Here's the good:
-the story line is intriguing... lots of plot twists and surprises
-the voice acting is pretty good
-I enjoyed the end of day quiz things (they sum up evidence well)
-I felt like time-wise it was worth the $6.99 (it took me at least 4 hours, maybe more)

Here's what I didn't like:
-I felt it was too dialogue-centric--not nearly as many puzzles or other activities as, say, the Nancy Drew games, so while I was clicking a lot I wasn't actually making a lot of decisions/choices
-of the puzzles that did exist, I felt they were mostly underdeveloped (I didn't really get the logic of some of them)
-there are a lot of frustrating little things you have to find or do (as evidenced by the many threads of finding the white cloth, finsihing day one, getting past the dogs, etc.)

Also, I was put off by the fact that there are many rooms that have been reused from another Sherlock Holmes game (The Mystery of the Persian Carpet). The stairway area in the Bromsby home, one of the rooms in the Fairfax Theater, several rooms in the Aston theater, Hunter's home (both bedroom and garden area), Bromsby's office, and the sitting room were all pretty much identical to rooms in that other game. And while there was different stuff to do in the rooms for the different games, I still felt like that was pretty lazy of the game developers.

So anyway, ultimately I would say it wasn't the best game I've ever played, but it was entertaining enough, especially given the price. But if you don't have the patience to deal with the little frustrating things or to try some parts of the game repeatedly (hint: SAVE OFTEN), this one isn't for you.
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 3, 09 11:26 PM
I had to try several times (it was especially difficult because I couldn't get my screen bright enough to make everything out), but what worked for me was going along the right side of that middle wall thing until I was right below the cart thing (not the wagon, the thing close to the wall). Then right as the dog passed the lamp in front of the doors (which are sort of "northeast" of the cart) I double clicked on the footprints in front of the door to run there. I didn't have any trouble using the key... I can't remember if there is more than one key in the inventory at that point, so my suggestion would be to make sure you're using the correct one. Also make sure to use it where there is a hand icon (don't just click anywhere on the door).
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 3, 09 11:17 PM
To find the white cloth, go to the part of the ballroom in front of the door that leads to the room with the suit of armor. On the left side of one the chairs that is right in front of the door about halfway down the back of the chair you can find the white cloth.
 
 
 posted in Echo: Secret of the Lost Cavern on Apr 12, 09 10:31 PM
talonso wrote:I felt that the game was way too short. Enjoyed it. If it was longer I would compare it to Syberia.


I agree that the game seemed pretty short compared to other LFGs. Also, I thought the story was kind of silly and didn't feel like anything had really been resolved at the end (compared to, for example, games where there is a whodunnit aspect). So while the graphics were nice and I had fun (for a few hours), this would probably rate as one of my least favorite of the dozen or so LFGs I've purchased on .
 
 
 posted in Dracula 3: The Path of the Dragon on Mar 22, 09 12:50 PM
In the blood sweat and tears game, Arno has to taste all of them to figure out what they are since they all look the same. When he tastes the blood, he even says something about how it is indescribable (indescribably good, that is).

And he does desire Maria... I think the dreams that he has of her are supposed to indicate that.
 
 
 posted in Dracula 3: The Path of the Dragon on Mar 20, 09 10:58 PM
Note the small holes in the paper and the letters they correspond to. Where else in the room do you see these letters? Make sure you write down all of the letters that have holes, then find a way to make a chemical solution that will use all of the "letters."

Once you've figured out this step, you simply remove the microfilm with the tweezers.
 
 
 posted in Dracula 3: The Path of the Dragon on Mar 20, 09 10:48 PM
It shouldn't stop you if everything else is correct... I was able to pass even though it said unknown symbol. I think the reason it says it is unknown is because of the time period of the game... the priest wouldn't have known the significance of the symbol yet, so to him it is unknown.
 
 
 posted in Dracula 3: The Path of the Dragon on Mar 20, 09 10:44 PM
The priest doesn't lie to Dracula in the end... in fact, if he lies, he dies. The "correct" answers are still the truth, but they are worded such that Dracula doesn't realize the truth means the priest wants to kill him. For example, with question one, the priest did what he did in order to get to Dracula ("I had no choice: it was the only way to come to you"), but while Dracula interprets that as the priest wanting to meet him to become an immortal, it really means the priest wanted to get to Dracula to vanquish him.

But also... you were okay with everything before this (having the priest drink blood, burn a bible and a crucifix, draw flaming swastikas and pentagrams, etc.), but you can't make him lie because it feels like sacrilege? Seems a little late for that...
 
 
 posted in Lost in the City on Mar 16, 09 8:31 PM
pfalcioni wrote:
Gentlsong wrote:I know I am not the only one around here who has had to upgrade their actual video CARD (not just the drivers) recently to avoid game difficulties. It is simply the nature of technological advances.


Yes, I understand that some games will be more video-intensive, and may lag on slower machines, but they should still be playable.

There is no reason why a game with very basic graphics, like Lost in the City, should require anything big and new to play correctly. Don't get me wrong, I love the look and feel of Lost in the City - but the graphics are simple, and there's not much going on in each scene that should require big memory or a big vid card.


I agree with this response, and I am more convinced that it is not a problem with my video card because I have no problem playing the large file games on Big Fish (Nancy Drew, Dracula, the Jules Verne ones, etc.). If my video card can support these games, which I would assume all have more advanced graphics, why would it crash on "Lost in the City"?

And also I must point out that the system requirements listed for the "Lost in the City" game say DirectX 7.0, not 9.0c, and that is lower than many of the large file games which list DirectX 9.0 as their minimum requirement.
 
 
 posted in Lost in the City on Mar 16, 09 7:35 AM
In response to okletmewin12,

I did contact customer service again and told them that I had the most updated driver available and asked for other suggestions, but based on the info they got from my computer (PS that new Dr. Felix diagnostic thing is pretty cool), they couldn't offer any other solutions.

I have always found Big Fish Customer Service to be really helpful in the rare instances where I have a problem with a game, and while I am disappointed that the game just won't work for me (I had really gotten into it and was on about Level 25 when it got too bad to continue), they of course gave me a new game credit when the problem wasn't solved.
 
 
 posted in Lost in the City on Mar 15, 09 2:55 PM
I have heard back from support... I was told to update my video driver, but according to my computer manufacturer's website (Dell) I do have the most updated version. The one suggested by BF support is not compatable with my computer. I still tried to reinstall the most recent one and reinstall the game, but had the same problem... bummer.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator