Posts created by NancyLou9

 
 
 posted in Dark Manor: A Hidden Object Mystery on Dec 25, 13 6:23 AM
I follow the developers of this game on Facebook and for most holidays, they give energy gifts to players. It seems to be hit or miss that you can actually GET the energy gifts, with some people saying they got it, others saying they didn't.

On the FB page, some people said to do a manual update on the game but when I tried that, it didn't work. I was just told, "No updates found".

How would one go about actually receiving the energy gifts from the developers?
 
 
 posted in Hero of the Kingdom on Jul 24, 13 10:26 PM
Do I get these as a result of a quest or do I have to find them somewhere?
 
 
 posted in Castle: Never Judge a Book by Its Cover on May 12, 13 10:37 AM
I have the phone number needed to dial it but it's not working.

I watched the video of the puzzle and the solution makes so sense to me? Why am I only dialing three numbers if the phone number is a ten-digit number?
 
 
 posted in Snark Busters: Welcome to the Club on Apr 20, 13 8:42 PM
Are you seriously suggesting we start the game all over again, after making it all the way to chapter 5? Really?
 
 
 posted in Snark Busters: Welcome to the Club on Apr 20, 13 8:37 PM
Seems a number of us are in the same boat and BigFish has a give a crap attitude about it.

I guess getting our money is far more important than giving us a game we can actually play.

Pity, that. This was once a great place for games. Now it's just a financial drain. I haven't gotten a free game credit each month for a long, long time, which was once part of the membership I've had with them for, literally, years.

But, again, they couldn't care less about their customers, any longer. They're all about the Benjamins.
 
 
 posted in Snark Busters: Welcome to the Club on Apr 20, 13 8:35 PM
I saw this question asked back in Nov. 2010 and then again June 2011 and neither of them ever got an answer. I'm starting to notice a pattern in here and it doesn't give me a warm fuzzy with regard to Big Fish and their games - seems they tend to ignore a high number of problematic posts where the game simply stops working...

I am in chapter 5 and need the last piece of the books. The hint keeps directing me to the periscope and then tells me to use the "Left" arrow, however, the image doesn't change and I can't find the last piece to the books that go on top of the cabinet.

Please advise? I'd like to move forward in the game and am unable to do so.
 
 
 posted in Snark Busters: Welcome to the Club on Apr 20, 13 8:32 PM
I have the same problem, too. Did you ever get an answer to this or did you have to abandon the game?
 
 
 posted in Westward III: Gold Rush on Dec 5, 09 1:57 PM
memawclay2 wrote:That is a pure shame you couldn't get any satisfaction from . But SLG does stand by their games and at least now you can play.


Yep, I can finally play a game I bought a year ago, but I had to buy it twice...
 
 
 posted in Westward III: Gold Rush on Dec 5, 09 1:56 PM
bfgErie wrote:Hi NancyLou9,

I am very sorry that you had a bad experience with our customer support. I have checked into this issue and I am happy to help. This appears to be the case of emails not reaching their intended recipients. I'm sending you a private message right now with more information.

bfgErie


Yeah, I haven't heard this about four times already. Sorry, you lost me as a member due to your apathy. It won't work any longer, the sucking me back in with the false promises of "e-mail us and we'll fix it." Nope, done...
 
 
 posted in Westward III: Gold Rush on Dec 2, 09 4:19 PM
I finally wen to Sandlot and bought Westward III again as well as IV. They both work fine. I had a question for support and sent it to them while I created a login. Before I was done, I had heard back from support there. What a concept, taking care of their customers. In looking through the site, I'm starting to think it's time to ditch BFG for good, once my last credits are used.

Having been a member for so many years here, it's disappointing that I needed support for the first time and I got nothing from them but total silence.
 
 
 posted in Westward III: Gold Rush on Dec 2, 09 6:38 AM
I sent it during the week on November 10th. Also, I check my junk mail folder daily, nothing there.

This is apathy on the part of BFG and nothing more. I do everything they ask and I hear nothing back. This is the second time I've done the "Dr. Felix" and this time I sent screen shots of the error I get.

BFG apathy...
 
 
 posted in Westward III: Gold Rush on Nov 16, 09 7:14 AM
My guess is it won't work either, much like the other ones. I did manage to get WW I and II to work but have never been able to get III to load on my machine. Here I am over a year since I paid for it and still have never played it.

Just to maintain my level of gullibility, I'll probably buy WWIV as well, knowing it won't load on my machine.
 
 
 posted in Westward III: Gold Rush on Nov 16, 09 7:12 AM
In response to my posting here at the lack of contact from support, I was e-mailed by someone who seemed interested in helping me with my problems related to Westward III and the fact it won't load.

I did what they asked of me, again. I ran the Dr. Felix program, again. I even got screenshots of the errors I get when the game tries to load (but this was a new attachment). I sent the Dr. Felix file and the Word document with the screenshots and I have heard nothing, again.

I guess they got me, again. I suppose I'll never be able to play Westward III, again.
 
 
 posted in Westward III: Gold Rush on Nov 10, 09 10:22 AM
I've sent NUMEROUS messages related to this game not loading and crashing on the load... Still no contact to fix a broken game... Makes me wonder why I stay here if my money is going to be taken for a game with known issues and doesn't work.

At this point, I'd accept, "Wow, we suck and we're sorry but we have no idea how to fix this so, LOL, your money's lost!" Something - anything - just don't ignore me!
 
 
 posted in Westward III: Gold Rush on Nov 10, 09 10:16 AM
I'm interested in seeing if anything is being done about this as well. I paid for the game, played it a couple times, had to do a reload when I got a new laptop and now I can't play it. Seems more than a little unfair to me that BFG takes our money and then puts out an inferior product, knows it's inferior and then does nothing to fix it.
 
 
 posted in Ghost Town Mysteries: Bodie on Oct 29, 09 11:32 AM
The walk through says I should be looking for spades and the game has me looking for clubs. I can't find them anywhere at all. Since the walk through doesn't match the game, I'm wondering if anyone here has come across having clubs on the tombstone for Thomas Galor?
 
 
 posted in Ghost Town Mysteries: Bodie on Oct 29, 09 11:30 AM
Wow, Margie - didn't mean to hit a nerve there with ya... Didn't even know it was you. However, in finding the fourth shovel, where a shovel isn't mentioned in the walk through, they are in the same place as the item you DO have listed (which I can't recall what it is, just that it's not shovels)

Now I am on the Tombstone for Thomas Galor and it has me looking for clubs while clubs are not mentioned in the walk through at all. I can't find the first club. I tried my trick of looking for the clubs where the walk through says the spades should be located and that didn't work.

If anyone knows where the clubs are located, it would be appreciated to know where they are. I've been looking at this same tombstone for over an hour now.

Also, possibly the walk through could be updated when people spot the differences? As I had said with the shovels, they were found in the same place as the item that WAS shown, which I "think" was dynamite.
 
 
 posted in Hidden Expedition ® - Devil's Triangle on Oct 28, 09 12:07 PM
I also thought the ending was pretty abrupt and short... With all the work we had to do to get to the end, it really rather came out of no where, BAM, we're done!
 
 
 posted in Ghost Town Mysteries: Bodie on Oct 25, 09 4:47 PM
I'm having the same problem. Looks to me as though Big Fish games rushed things a little bit in posting a walk through.

I can't find the last shovel and the walk through says nothing about shovels in the slightest.
 
 
 posted in Empire Builder - Ancient Egypt on Oct 1, 09 12:14 PM
I found the ending to be rather anti-climactic after all the frenzy of building to obtain three stars on each level... I was looking for a bit more hoopla, I suppose.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator