Posts created by Westel

 
 
 posted in Mystery Case Files: The Black Veil on May 13, 17 5:14 PM
I guess I'm just stupid, but I'm finding the instructions for the mini-games extremely difficult to understand. Programmers are notorious for skipping steps when writing how-to instructions. I don't need someone to hold my hand, but there's nothing in the instructions to spark my intuition! Tired of having to exit full screen and looking up the walkthrough.
 
 
 posted in Secrets of Great Queens: Old Tower on Dec 17, 16 6:07 PM
I'm having trouble getting Louis to do things for me. I'm trying to get in the boat and it says to pull the lever, but when I put my cursor on the lever and the "Louis tool" appears, nothing happens. What am I missing here?
 
 
 posted in 9: The Dark Side on Dec 15, 16 11:30 AM
I just installed Windows 10 and my older games freeze. The screen goes blank, though the music continues to play. The only way I can exit is if I turn off my computer. New games play just fine.
 
 
Stanj1 wrote:Downloaded the update, everything worked fine. Didn't realize how close I was to the finish. Sad that it took so long, but very happy to finally get to the end!


HOW did you download the update? I see nothing on my Game Manager about an update. I've just deleted my download and am re-downloading the game. Will the patch be in place then?

Why are the Forum Mods so silent on this issue? I'm like many others - I don't like spending my money on games that have major - and I mean MAJOR - glitches!!!!
 
 
I played the HOP game in the chapel by switching to the puzzle, but now it keeps going back to the HOP and I can't find what's supposed to go into the solution. I've lit the bunson burner, but don't know what else I can do now! HELP!!!!
 
 
 posted in Hidden Object Crosswords 2 on Feb 2, 16 1:35 PM
I love word games, and this one is no exception. One small criticism, however: the clues don't always fit the object/word. Example one of the hints for 'ribbon' was a 'piece of jewelry'.

The match-3 mini-game hangs up sometimes, too, but that's a tech problem.

Overall, I like the combination of HO and word puzzles. I give it a 3 out of 5.
 
 
 posted in Mortimer Beckett and the Time Paradox on Jul 30, 15 7:08 AM
Oh, this is embarrassing - I needed to give the bones to the island witch. I had them, but they were so faint in the cache I didn't see them. Once I gave her the bones, she gave me the code for the puzzle on the pirate ship, and there I got the last piece of the spyglass.

Live and learn!
 
 
 posted in Mortimer Beckett and the Time Paradox on Jul 30, 15 6:59 AM
I cannot for the life of me find the rest of the telescope to give to the Leviathon. Can anyone help?
 
 
OK, for any of you (none of you?) who had issues with this, pull up the mirror, then click on each of the three arrows on the three separate dials. Exit the mirror, then go to the safe and your dial can be added to the other two dials. On each dial, click the green button, moving the dial in a clockwise fashion, until the dial turns green. Do this for each dial and the safe will open.

Guess I'm too visual for my own good. Hope this helps anyone like me.

Or not.
 
 
I've tried clicking on the small arrows, after seeing their locations in the mirror. However, nothing happens and my dial is kicked back to the inventory. Could someone please help my idiocy and tell me, step-by-step, how I'm supposed to get this to work?
 
 
 posted in Bluebeard's Castle on Jan 10, 15 5:43 PM
I see all the previous discussions are locked, so I can't determine whether any fixes were issued for the obvious bugs in this game. After playing a few minutes, the cursor starts to drag and weird things like lightning bugs turning into minute strings of data. I've had to reboot the game several times, yet the dragging continues.

Is there a link where I could refer my question to the technical folks?
 
 
 posted in Haunted Hotel: Lonely Dream on May 31, 14 2:33 PM
Try putting the oil lamp back in your inventory, then click on Hint, then retry putting the lamp on the winch. Make sure you've already fueled the engine.
 
 
 posted in Haunted Hotel: Lonely Dream on May 31, 14 2:30 PM
Add the oil from the OIL LAMP to the engine as well. (5).


Sorry, but you have to put the OIL LAMP on the WINCH, not the ENGINE. Took me several painstaking RESTARTS to figure this out.
 
 
 posted in Haunted Hotel: Lonely Dream on May 31, 14 2:28 PM
I addressed this same question, but somewhere else. I finally found that you DON'T put the oil lamp on the ENGINE, but on the WINCH - Duh!!

The instructions say to put the lamp on the ENGINE - NOT the WINCH. In desperation, after having quit the game at this spot several times and starting all over again, I just started trying to put that stupid lamp everywhere in the room, finally, when I moused over the winch, voila - SPARKLES! Dropped that lamp on the winch and all was well.

Not a great game anyway.
 
 
 posted in Haunted Hotel: Lonely Dream on May 12, 14 12:49 PM
Westel wrote:I played the game once and had no issues. This time, however, when I try to use the oil from the oil lamp on the engine (the one that activates the winch to break through a wall in the basement), it says I'm making a wrong move. I have uninstalled and reinstalled the game, but it hasn't fixed the problem. Is there something I'm missing?


Here I am trying to play this game AGAIN (after re-installing it once more from BFG site) and I'm stuck in the exact same place! It simply will NOT let me use the oil lamp to lubricate the engine. I'm deleting this game - waste of money.
 
 
I have reached the point where I need to install the elevator to proceed to the next level. I collected all the parts for the elevator, but it disappeared from my inventory. Now I'm stuck on this level, and it looks like I'm going to have to start all over to try to get past this point.

I'm also finding it hard to find exactly where to place my cursor before finding the green arrow leading to another area. Distracting and frustrating.

Not gonna happen any time soon! Very disappointed.
 
 
I assembled all the parts for the elevator, but it has disappeared and now I can't move forward.
 
 
 posted in Enlightenus II: The Timeless Tower on Mar 30, 14 8:20 PM
I've gone back through the walkthrough just to be sure I've solved all the sections for Floor Three. I just didn't get the piece. Nothing for it but to start all over again.

Anyone else have this problem?
 
 
 posted in Dreamscapes: The Sandman on Mar 22, 14 12:02 PM
There are only 6 colored wires: (1) orange; (2) light blue or aqua; (3) yellow; (4) pink; (5) green; and (6) dark blue. What's the seventh color? How can you randomly give green the number 7? If so, what colors are 1, 3, and 5? Clues should at least make sense.
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Mar 15, 14 2:17 PM
There is no organ piece outside the gate - they're all inside. The really hard one to find is on the right, hidden behind one of the balcony poles, near the floor. Just move your cursor slowly and wait for the "pipe" message to pop up.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator