Posts created by aoakley455

 
 
 posted in Heroes of Hellas 4: Birth of Legend on Apr 11, 18 3:41 AM
I've had the game freeze several times while playing it. ( Usually at least once a day) Have to go to task manager and of course it says the game is not responding. Have to close out and start over. Haven't had this many problems with a game in awhile.
 
 
 posted in Imperial Island 3 on Jun 9, 16 3:17 AM
Reached level 300 something. Windows 7. My screen is totally black as well except for the menu, play, timed and inventory buttons. Nothing happens when I hit the play button. Tried several times to restart the game and even uninstalled and installed it to no avail. Guess I was luckier than some, getting to play that many levels. But if there are more levels, should be able to play them all, after all, I did pay for a complete game. Big fish always seems to think it's everyone's computers and not at their end. Time to fix it at your end Big Fish.
 
 
 posted in Awakening Kingdoms on May 14, 15 5:15 AM
My game frequently shows I'm not connected to the internet, which is not true. Got reset back to day 1 also once. Other little miscues happening. I reiterate, I'm glad I never spent a cent on this game with all the problems it had been exhibiting!!
 
 
 posted in Awakening Kingdoms on Apr 23, 15 4:50 AM
Logged in today and only had 190 energy points after not being on for 24 hours. (should have 360 per 24 hours.) Also shrine still has 34 hours to charge. For some reason I lost about 10 hours in energy and time. Also didn't get my reward today. First time this has happened. Just glad I never spent a cent on this game. Soon time to call it quits anyway, has gotten way too boring anymore with no quests!!
 
 
 posted in Royal Flush Solitaire on Jan 21, 15 4:19 AM
This game is a mess. Downloaded OK, at the end I had to download something else for it to play, which I did. First time I tried to play it kept asking for my name, after typing it in 4 different times and hitting the check mark after each time, I exited the game. Second time I tried to play, I hit the play button and it just exited itself, tried this 3 times and it did it each time. It is now uninstalled never to be tried again!! It also deactivated my fairway solitaire game each time, go figure!
 
 
 posted in The Far Kingdoms on May 1, 14 6:01 AM
Gave the fate card to the guard who was supposed to give me a token for the grey house??? Did not receive one. Uninstalled and reinstalled game to no avail. Guess I'm at the end of the game. What a waste of money on this one!!
 
 
 posted in Zodiac Prophecies: The Serpent Bearer on Nov 16, 13 9:36 AM
I also have Avast and am getting the same suspicious message after I purchased the game and tried to install it. Had no trouble installing the trial version. Does anyone know if it is safe to install? Thanks!
 
 
 posted in Heroes of Hellas 3: Athens on Oct 26, 11 9:54 AM
Downloaded this game at another site, very quickly with no problems what so ever! What does this tell you BF?? Must be something screwed up with your download. And look at the numbers having problems downloading, too many for it to be all our computers! Game is fun, guess I'll have to soon look at another gaming site if this one keeps giving me problems.
 
 
 posted in Heroes of Hellas 3: Athens on Oct 26, 11 4:43 AM
I've gotten to 44% every time I tried to download. It just stops dead. I've NEVER had this happen before with my computer, so I'm sure it is on their side and not mine. After reading all of these you'd hope they'd take the hint and check it out and fix it. Love these games so looking forward to playing it, someday.
 
 
 posted in Caveman Physics on Sep 21, 11 12:49 PM
My 10 year old grandson got this puzzle on his first try. Don't ask me what he did however, lol!!
 
 
 posted in Gunslinger Solitaire on Jun 20, 11 12:03 PM
Objectives very easy to meet making this an extremely short game! Even at the DD price it wasn't worth the money.
 
 
 posted in PuppetShow: Lost Town on Apr 14, 11 9:12 AM
barbiedoll25 took the words right out of my mouth!! Same exact problem as this with custom cursor also turned off. A shame, looks like a great game. It's a "fix or no buy" for me.
 
 
 posted in Robin's Island Adventure on Apr 5, 11 6:06 AM
It's an OK game, might have used a credit if I could turn off the custom cursor. Not a fan of custom cursors so it's a no buy for me.
 
 
 posted in Atlantic Quest on Mar 9, 11 11:22 AM
Was on the fence about this one for 20 minutes. I enjoy match 3 games and am in need of a new one. Would have gladly used a credit but after 20 minutes of playing with that huge cursor, it was a no go for me. A shame, I think it would have satisfied my match 3 craving at this point!!
 
 
 posted in Cate West: The Velvet Keys on May 8, 10 4:33 PM
Yeah, it finally worked after purchasing another game!
 
 
 posted in Cate West: The Velvet Keys on May 8, 10 4:28 PM
I tried that but I get this message--

The code you have entered is not valid for a discount on any of the products in your cart.

So I guess I'm out of luck. Thanks for your help.
 
 
 posted in Cate West: The Velvet Keys on May 8, 10 4:21 PM
Anyone else with this problem? When I click on "buy this game" it is automatically deducting my game club credit!! I DID NOT click on use credit, which I certainly wouldn't waste on a DD. It is doing this for any game I try to buy. I don't want to use a credit but it keeps using it. I didn't click on the OK button, so I didn't lose it, but I also can't by the DD. Thanks for any feedback.
 
 
 posted in Dominic Crane's Dreamscape Mystery on Apr 9, 10 11:37 AM
I found 3 keys during my hour trial. If there are only 6 keys, this seems like it would not be worth buying for me. Excellent game, loved everything about it and sooner or later I figured out the mini puzzles. Just wish it would have been longer, since it's not, it's a no buy for me.
 
 
 posted in Alice in Wonderland on Mar 24, 10 6:17 PM
I agree with these reviews. I only played 5 minutes and couldn't stand the constant flashing lights. If this was added to make the game spooky, it failed miserably. All it did was cause me to quit the game!
 
 
I downloaded the game on my new laptop with Windows 7. Game won't open. Upon checking the collector's edition forum, I found a thread with many others having the same problem. Several had contacted customer support and tried their suggestions to no avail. You would think they would have tried to fix this before launching the regular game, but I guess not. Doesn't pay to have the newest equipment in cases like these I guess.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator