Posts created by pphrn

 
 
Can't get the piano music notes to move. Hint says I need another statue. Strategy guide doesn't mention or show one.
 
 
How long is this game? I was wondering since, I only see 2 chapters on the demo.
I finished the demo in about 30 minutes.
How many chapters?
 
 
 posted in The Treasures of Mystery Island: The Ghost Ship on May 5, 11 10:02 AM
Yes, I enjoyed this game!!! This is one of the better games I have played in a while.
I did reinstall the game as instructed. I did loose the clock hands in doing so. I also lost one other piece for the bus. (my second time through)
The third time through it worked perfectly!
The game was not boring!!! It switched you back and forth and added in extra puzzles that were not impossible.
The map was significant in helping you find those places where you needed to do something!!!
I definately recommend this NON-collectors edition game!!!!!!
 
 
 posted in Stray Souls: Dollhouse Story on Mar 17, 11 10:40 AM
I enjoyed the game but, about half way through it became annoying.
You had to constantly find one item to continue. Ex. find one key, then find another key, then find another key, etc. The screens did tell you there was nothing to do in this area....**** O.K. some objects hidden in dark places, which the hint button helped with. Lots of great graphics, ghosts....
I had to stop playing because of the repeating of finding one key to continue, just got too annoying.
 
 
 posted in Epic Adventures: Cursed Onboard on Mar 11, 11 2:15 PM
I also downloaded the game....The screen was black and I could only hear the audio portion. I had to shut down the computer to get out of it.
 
 
O. K . I figured it out. I missed the safe. Once I opened the safe, I had the keys.
 
 
I can't open the front door either!
I only have a safe key.l Where/how do you get the keys?
(have a hammer, been out to the barn, ETC.
 
 
 posted in Echoes of the Past: Royal House of Stone on Dec 3, 09 3:59 PM
the barrel moves with rapid clicking mid barrel/when it finishes moving the oil pours out/
leave it and move out kitchen door
 
 
 posted in Echoes of the Past: Royal House of Stone on Dec 2, 09 8:34 AM
I tried all maners of clicking. finally the third time though/rapid clicking mid barrel did it!
This worked for me on the third game I played.
 
 
 posted in Echoes of the Past: Royal House of Stone on Dec 2, 09 8:32 AM
It won't let you put out the fire until you pick up the gem/
this is true for each test/you must pick up the gem each time
 
 
 posted in Echoes of the Past: Royal House of Stone on Dec 1, 09 10:27 AM
The barrel in the kitchen is too hard to move!
Playing two games at the same time, I've only gotten it to move in one game.
I keep clicking and moving the curser to the left but, it only rolls back.
I've also tried holding the curser and not holding the curser as I move over the barrel, still no luck!
This is very frustrating!

O.K. The 3rd time through...I did rapid clicking on the barrel (mid-barrel). The barrel moved out of the way. I was amazed, what a challenge! (just to move the barrel.)
 
 
 posted in Ghost Town Mysteries: Bodie on Oct 27, 09 9:52 AM
I wanted to try it because I have been to Bodie.
I have tried to play it twice. I regret buying it.
Some of the hidden objects are too hard to see.
I was not able to find the last shovel on the one tombstone.
The photos were also very difficult even when looking at the walkthrough.
I could not complete the boy/dog photo.
No pass or hints on these areas.
How do I get a credit back?
 
 
 posted in Ghost Town Mysteries: Bodie on Oct 27, 09 9:38 AM
I agree! The differences are too hard/some impossible to spot
The last shovel on the one tombstone is also inpossible to spot
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator