Posts created by Tvini

 
 
 posted in Virtual Villagers: A New Home on Oct 23, 12 6:22 PM
Today, the morning after I upgraded to Mac OS Mountain Lion 10.8.2, I attempt to launch the game from the Game Manager and am immediately sent to the "thank you for playing" screen - without having actually played. I am also experiencing issues with other Virtual Villagers games. I wonder if this is an issue of the games being incompatible with the most recent Mac OS.

Any word on a planned update?
 
 
 posted in My Tribe on Oct 23, 12 6:18 PM
This happened to me today also - the morning after I upgraded to Mountain Lion 10.8.2. "Application Not Responding." Also with Virtual Villagers: A New Home, and I suspect with others that I haven't tried to open yet. I wonder if this is an issue of the games being incompatible with the most recent Mac OS.

Any word on a planned update?
 
 
 posted in Awakening: The Goblin Kingdom on Oct 8, 11 3:48 PM
Susan8906 wrote:In the mines, the pocket dragon will not light three of the torches It lighted one, but will no do the other three. Has anyone solved this problem? The walkthrough says to use the pocket dragon to light the torches!


Susan8906, I initially thought I had this problem, but I was just imprecise in my clicks. Or rather, I hadn't clicked on the one tiny spot it thought was the torch. I had to click like a madwoman but finally found the "sweet spot" which the game recognized. I don't know if that's your issue, but it seems similar.
 
 
Agreed. Even before I encountered what I believe is a technical issue preventing me from completing the game, I was already feeling rather let down. I feel I'm being led around rather than having the opportunity to solve things on my own. There are a few too many instances of "I need to find the X to save the Y!" And there's the X in plain view. Click. Solved. Cue swelling music and celebratory sparkles. How about we save the rewards for puzzles requiring actual brainpower?
 
 
I am also having this problem. I used the hammer to break one barrel, which revealed a key and caused the hammer to disappear. I used the key to unlock the house on the right, which I believe is the postmaster's office? However, now I have no key and cannot open the house center left, which I'm assuming is where the paint is. I need to be able to get into that art shop in order to complete my fishing pole. No hammer, no key, no means of entry. Anyone have a suggestion?
 
 
 posted in Gemini Lost on Oct 28, 09 12:46 PM
Is this available for Mac as well as PC? I purchased and downloaded the Mac version of the game on the 25th, well after the new build, yet I still have the "can't get Libra" glitch. How should I proceed?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator