Posts created by Baywolfe

 
 
A follow up on my post. Apparently, if you make it far enough into the game the Menu button starts working. I my case, it didn't work as far as the Underworld but works now that I am at the Colossus.
 
 
I just purchased the game on August 19 and have started playing it. I see you STILL HAVE NOT FIXED THE MENU BUTTON ISSUE. Everything else on the game works fine and I have not had any trouble with actual game play but not being able to use the menu button is beyond ridiculous.

Alienware M15X Laptop
Windows 10 Build 15063.540
8 GB RAM
Intel Core i7 CPU
64 Bit Operating System

Viewsonic 1080p Monitor
Microsoft Optical Mouse
 
 
 posted in Who Am I on Jan 18, 14 12:00 PM
The Hint Button is the big green button on your left.
 
 
 posted in Paranormal State: Poison Spring on Nov 2, 13 6:56 PM
I'm am also getting the error. Game crashed when I came back with the meter from the car. Uninstalled, confirmed that the folder was completely deleted, and reinstalled. Same issue.

Alienware M15X Game Laptop
Windows 7 Home Premium
Intel Core i7 CPU
8.00 GB RAM
64 Bit Operating System
238 GB Hard Drive / 212 GB Free
 
 
 posted in Motor Town: Soul of the Machine on Feb 18, 13 10:18 AM
I think this has already been pointed out but, in case it has not been specifically stated.

Bug: If you select the funnel you do not have a chance to select the candle. It zooms out and the area is no longer available for inspection.
 
 
 posted in Mystery Case Files®: Shadow Lake Collector's Edition on Nov 22, 12 10:02 PM
Very disappointed, it feels like you've lost your way. This game has little of the heart of the older MCF games. In its place, we now have live action. The story wasn't bad, except for being too short, but it now feels like the game is all about the performances not the game play.

For me it felt like it all started to go wrong with 13th Skull. I actually had to turn off the sound due to the banality of the voice acting. Not their fault really, just having them say the same lines got annoying. But at least 13th Skull was an interesting play. Shadow Lake was just getting led around by the nose by Lea Thompson and solving different varieties of the same stupid puzzle over and over..

There are so many other game companies doing their type of MCF games so much better than you now. Maybe you were their inspiration, and it's time the torch was passed, I don't know. I do know I will never buy another MCF sight unseen and I wonder if I'll ever buy another one, period.
 
 
 posted in Big City Adventure: London Story on Jan 29, 12 3:13 PM
Love the game. I've only played 15 minutes but I can see it's a keeper. But, please put some kind of option in your game to shut off these annoying "helps and hints".

Nothing is more annoying that going to do something and be told with TWO hints what I'm supposed to do. You actually start to think after about the 70th message (exaggeration) that "Oh my God, they're never going to stop, are they?"
 
 
 posted in Azada® : In Libro Collector's Edition on Nov 18, 11 8:28 PM
Take a left at the Centaur.
 
 
 posted in Azada® : In Libro Collector's Edition on Nov 18, 11 8:22 PM
It's outside the house and you'll also need something else to get it.
 
 
 posted in Azada® : In Libro Collector's Edition on Nov 18, 11 8:21 PM
I don't think a lot of CE's equal twice what their "regular" version has. You can wait it out, practically every CE game is later sold as a non-CE.

It would be nice if there were some standards set by BFG regarding CEs. e.g. Must have a certain length of game play vs the non-CE game, must come with a Strategy Guild, no "trial and error" puzzles, that kind of stuff.

Back in ye olden days of PC Adventure games, you expected to get 1 hour of game play per dollar.
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 25, 11 4:23 PM
SexiePrincess wrote:
mindles wrote:
pepopsmama wrote:Can't seem to click on the piece of the tree trunk in the cave to patch it into the root...have looked at the hint to make sure I am attempting it correctly...still won't let me click on the piece I am supposed to. Please help


I have the identical problem. I've patched two spots successfully, but no third patch has become clickable. :-(


I am having the same issue and I hope they update it very fast!


Ditto. The game runs absolutely fine, but I can't click on the split and I do not get a magnifying glass anywhere on the screen. I can't patch any of the root.
 
 
 posted in Twisted Lands: Insomniac on Sep 16, 11 5:50 PM
I don't have any problem with them trying to come up with a new twist like switching you back and forth. I do think there are WAY too many cut scenes. I've played 40 minutes of the demo and there has to be close to a dozen.

I guess my only other complaint is that it's really kind of easy. And this is without using the walk-through and on Expert mode.
 
 
In the boiler room, I clicked the button to solve the coal puzzle. but I'm still at the furnace except now I don't have any coal, and I can't escape from the puzzle.
 
 
 posted in Spirit Seasons: Little Ghost Story on Jan 26, 11 4:47 PM
This is a terrific game. I only played it long enough to do one thing, but that was enough to hook me.

The graphics are very smooth and they didn't waste any money with voice dialog.

I'm always impressed with this development company's products!
 
 
Misty36 wrote:
Baywolfe wrote:I also am having the issue where you start the Salt puzzle, leave, and the game won't let you back in the puzzle.


Me too, and I even uninstalled and reinstalled, and it was still stuck. I am NOT starting this game over, and it probably is at the end. I, like everyone else, would love to know if the bug has a fix.

Misty


I hope so too. Because I am done until then. I guess I could delete it and wait a year when I don't remember anything about the game.
 
 
I also am having the issue where you start the Salt puzzle, leave, and the game won't let you back in the puzzle.
 
 
Here's what I liked.
1) Large sprawling southern mansion with surrounding grounds and town made for tons of areas to explore.
2) Interesting puzzles and "games". Very few that I've seen before.
3) No indication as to what sex "Master Detective" is, they never speak aloud.
4) Favor/task based advancement was different, although possibly a little "corny".
5) The Captain's door puzzle. That was greatness.
6) The whole Dead Piratey theme. Ghosts, skulls, pirate ships!
7) The "in" jokes.

Here's what I didn't like.
1) Real life actors. I could not suspend disbelief and it kept taking me out to the game. They were fine actors, I just didn't care for the switch, and the end game, with the same cliched threats over and over and over, were just silly. I like when the game doesn't intrude in what's going on in your head while you're playing it.
2) Any puzzle that you had to guess at the solution and could not be solved by either a) Intellect or b) a discovered answer
3) Wouldn't a member of an organization as badass as MCF carry a gun the size of Hellboy's at all times? And why would they chase a murderous family completely unarmed?
4) As stated above, not sure some of the tasks were exactly what you picture a Master Detective accomplishing, but not complaining too much.
 
 
I can do completely without the real life actors. I enjoy when the game is as much in my head as it is on the screen. I don't need real people talking to me, especially when they're threatening me with the same 12 cliches over, and over, and over.

I thought the MCF Games were all about solving mysteries in relative solitude. Please, please go back to 100% animation and limit the "Master Detective's" exposure to anyone no already dead.
 
 
 posted in Escape the Museum 2 on Nov 21, 09 4:00 PM
Technical: I was able to save my game progress, so that's a good thing, since I have tested a couple of games recently that wouldn't. However, the game could not find my monitor resolution, which is astounding in this day and age, and I was forced to play from a much smaller window. No crashes or glitches for the first ten minutes I played. Technical Score - 7.5

Playability: Fairly intuitive and doesn't waste too much time explaining how to do things. Help is amusing, as the wino throws a bottle at an item you're looking for. Visual cues for special search/action areas and next actions. Playability Score - 8.5

Ascetics: Why do most of these games have a female hero and a bumbling/loutish male sidekick, or a semi-effeminate male hero? Do they really think that only women who read Harlequin Romance novels play these things? I didn't get far enough to deal with the whole weak heart / blood pressure medicine but I have to believe it's more of an aggravation than a game enhancement. Ascetics Score: 4.0

Overall Score: 7
 
 
 posted in Hidden Expedition ® - Devil's Triangle on Nov 1, 09 6:52 AM
tarbarme wrote:well can't save and it keeps deleting my new profle. I think the game and computer hate each other. I wonder if anyone else is having this issue?.


Yes, I'm having the exact same issue. You can leave the game running when you're not playing but it's very annoying not to be able to quit when you want to.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator