Posts created by billiejolear

 
 
 posted in Delicious: Emily's Miracle of Life Collector's Edition on Mar 10, 18 9:56 AM
...and still no game in sight. I went to the new releases. Shockingly? or maybe not at this point, this game is still not available here and further, not a time management game release in two weeks. THIS is why I went to another site and cancelled my membership. BFG does not care about time management gamers who made them what they are today. I know new owners. Ok. Point taken. Stop waiting around. Other sites have two new releases for delicious while BFGs just ignores the players of time management. It is cheap and easy to make hide and seek games. Why would they bother?
 
 
 posted in Delicious: Emily's Miracle of Life Collector's Edition on Nov 20, 17 8:18 AM
Every single Delicious game has had a bonus board you discover. Is there one available and also where is the difficulty tab? What is going on with our games? :'( Since this purchase of BFG's happened the time management group gets no attention. All of the good games have disappeared and those that remain are now being maimed. Come on people... :'( Do you think you could stop making find a dog in a basket games for ten minutes and give some decent attention to these games? I am continually canceling my membership with you. I am really just about done with BFG and that would be a shame because have you like have you seen how many games I have purchased? You seriously need to get your act together. Either make yourself a find a guy game site and be done with it or pay attention to your other paying customers.
 
 
 posted in 12 Labours of Hercules V: Kids of Hellas on Feb 27, 16 1:15 PM
Ok Tech Issue: On level 4.10 if you have a man locked in the gold section when you explode the house, the game is stumped. It can not end and you can not move. It does not 'freeze' the game. The guy sits in the gold area looking at you like you are a fool. The house is exploded and you are done with tasks, so the game should end and the score come up. What happens instead is the game just sits there. The time stops and you can not get the guy out. As I said the game is NOT frozen. It is clear to me that the developer forgot to add (code) in case this happens. It like being limbo. You can't move, you can't finish, the game is over but it will not finish because the guy is in the gold area. Give it a try, please. It is only because this happened to me and I sat there waiting to see if after time it would end but it did not. The times stops like the game is going to end because the tasks are done but fire keeps burning away and the guy keeps giving you the shoulders but um... yea you can't do anything. It is not frozen, just limbo. I have a great computer. This is your game
 
 
 posted in 12 Labours of Hercules V: Kids of Hellas on Feb 27, 16 8:41 AM
After playing Chapter 4.10 for four days trying to beat the developer's score, I am quite upset with the glitch I ran into when I finally beat it. I would LOVE to show you. Yes, you have a glitch. My game froze. It did not even know what to do. Can you see it? Yea, the guy is stuck so even though the chapter is over and finally beat it, I can not release him and the game won't move. Timer is right where it was when he got stuck ten minutes ago. Thanks! I finally beat it and this...just this. Oh I can not even SHOW you the photo on this forum. Well, too bad, it is something to see! When the guy is stuck in the area where he gets gold and can not get be released because you already blew up the house, your game is also stuck. The score will not come up. The timer won't move. I can not release him even though I have enough time left to do so. The game just stops. I have no choice but to start over. Come on, really?
 
 
 posted in Bilbo: The Four Corners of the World on Dec 1, 14 9:44 PM
I notice this is an ongoing complaint. If any of you have found a site that is putting out decent time management could you please PM me. I have my credit here from two months ago and stopped my account from purchasing more until they put out one I want to play. By the looks of it, it wont be any time soon.
 
 
 posted in Bilbo: The Four Corners of the World on Dec 1, 14 9:42 PM
WOW! Remember when Big Fish Games put out so many Time Management that someone actually complained??? Now we can not even get a decent release for Time Management in TWO MONTHS! COME ON, seriously Big Fish! we are the FAITHFUL players who made you great! WHERE ARE OUR GAMES? I am so disappointed to go to the new releases and see you have released just tiny, silly Time Management games and only a few in two months time for PC downloads. What a slap in the face for your long term players! Not EVERYONE likes to play 'find the hidden ball' in the photo like they are in grade school! SOME OF US, like to use our brains and figure out strategies to get to the end of the game. VERY disappointed!
 
 
 posted in My Singing Monsters on Oct 25, 14 7:01 AM
I agree with other posts here. I am not going to play any of the games that really need further purchase to get the full effect. As soon as I realize this is a game of this nature it gets deleted. I am sitting pretty with my game club credit from this month waiting for a new time management game to come out. Would like one of the good ones soon. <3
 
 
 posted in 12 Labours of Hercules II: The Cretan Bull on Sep 14, 14 11:37 AM
I also just clicked on the turtle and got it. This is actually the first puzzle piece I found, did not realize I was looking for them, darn! Oh well, I came here because I am having trouble getting through this in expert time. ug. Some of these I have played almost 50 times before getting the expert time but it is ok, it makes the game last longer, which is awesome! Learning the trick to each one has been fun. With that said, this one, I do not think I am going to get without finding a walk through, so alas, I am here!
 
 
 posted in New Yankee in King Arthur's Court 2 on Feb 6, 13 7:06 AM
OK, to get the achievement at the bottom that says do not use the windmill, this is what I did to get it: I did not go on the windmill island at all, not even remove the rocks, and I did go on the foundry island but I did not build it. this meant I had to cut the trees where the ogre is chopping and fight off constant skeletons until I had enough food to finish but it finally gave me the achievement. So apparently they do not mean: do not use the windmill, they mean: Do not use the windmill or foundry lol.
 
 
 posted in New Yankee in King Arthur's Court 2 on Feb 6, 13 6:57 AM
Geesh I can not believe I am commenting again. Ok, if you try and get the achievement that says: Complete level 9 without using the windmill, it does not give you the achievement. I am going to try it again for the like tenth time while not using the foundry as well and see if that works. This game was seriously given and sold way too early. When I see the spelling errors, (and do not get me wrong, I am NOT a grammar nazi), however it is another sign of just how little time this game was looked over before you released it.

Another horrible and not fun glitch is when you are trying to get the achievement that says to let five men fall in love with the devil lady, if you right click to reset your jobs you have assigned, which I did several times before I realized the problem, it causes an internal error and shuts the game down.

There are more than a few things that cause this to happen. As much as I enjoyed the improvements in version 2 of this game, I am going to tell you, this is appalling. You really should have put some time in checking this game over before you released it... how frustrating.
 
 
 posted in New Yankee in King Arthur's Court 2 on Feb 6, 13 4:56 AM
I have another question about this however: For the achievement: Freeze four workers at the same time in level five. I have frozen them across from the water...four at the same time. Is that what they mean? I am not getting the achievement, therefore it is not right, I am sure. There are only skeletons, so how else would freeze them? I am getting them stranded on the other side where the gold is...how would we freeze them? anyone?
 
 
 posted in New Yankee in King Arthur's Court 2 on Feb 6, 13 3:20 AM
I complained about this earlier...you know what this achievement reminds me of? It reminds me of the one level in cake mania to the max...absolutely impossible..you would have to cheat in some way..and god only knows how...to win it...it stresses me when they make it impossible to get one... It took me all morning just get past the glitch so that the achievements started working..now am finally doing them and I am again disappointed to find that I may not be able to get them all
 
 
 posted in Building the Great Wall of China on Feb 5, 13 11:11 PM
I have a review to add for this game. I have been a member a VERY LONG time. In fact I recieved my felix so long ago, i have no idea where he ended up in life lol. Now, there are many times when you release a game before you should, it is glitchy and needs new work and I get very frustrated that you put your purse before your customers. I am, however, pleased to say, this is not one of them.

THe usual things that irritate me about your games, were absent with this one. IT was challenging, but NOT so challening that I could not do it. It required me to play levels over and over to get the achievement which meant I got almost an entire month of game play from this game, something that is rare. I am usually irritated because the games are so easy I finish them the first day I play or in like six hours. This game challenged me.

I did not experience even ONE glitch...miracle! Yay.

This game, was in fact, a time management home run.

It was not the game I standardly enjoy, but it was at least, a home run for the things that usually irritate me. You could do well to make sure all your games are glitch free or at least mostly glitch free before selling them. You could also do well to make them longer or a bit more challenging as this game was.

Good on you! I highly recommend this one!
 
 
 posted in New Yankee in King Arthur's Court 2 on Feb 5, 13 10:58 PM
oh and one more thing...a little more work on the arrow... it was extremely irritating constantly clicking to find the green arrow spot in each board. Ya know, I understand you want to make maximum money on these games, but honestly, some more time in testing and making them would be nice. I do not appreciate buying a game that does not work properly, on a regular basis. Not at all
 
 
 posted in New Yankee in King Arthur's Court 2 on Feb 5, 13 10:53 PM
Ok, I finished this game all gold in like six hours. It was a fun game and it shut down twice during game play but no biggy. Here IS a biggy. Getting achievements is easy enough..however your game does not give them to me...I like to finish the whole game complete before I move onto the next. These KA Court games were both easy and fun...however I am IRRITATED it wont give me the achievements...how long until you fix it? and will I have to upload something to get it fixed on my side? Further, it is really rude to release games before you have worked out the glitches. Just rude. WE pay for these games, release them when they are ready for game play. If I have to find out that I have to redownload and replay to fix the glitches, I will be a bit upset. Improve your game releases to be ready to play and repaired... BEFORE you release them for sale. Going through these forums..its the same thing for every game? Does it not take some big kahunas to release a game for money when you have not finished working out the bugs? Just a thought.
 
 
 posted in New Yankee in King Arthur's Court on Jun 6, 12 7:29 PM
Would LOVE to buy this game..it claims its on sale and I can use a game credit! However each and every time I try...when I go to the purcahse page for THAT game..it shows my credits as zero. Hm..it shows my credits as the right number on every other page... I just rejoined... I do not want to have issues already... Frustrated with this again already.
 
 
 posted in Potion Bar on Mar 13, 10 7:03 PM
I actually usually buy most games in the time management dept. I liked the idea of this game but it is clearly riddled with problems.

It was not slow on my computer of even causing flickering problems however it does open in a 'too small for fun' window when you start playing.

I hope someone lets me know if they fix that issue, I will probably buy it.

Billy
 
 
 posted in The Cameron Files: Secret at Loch Ness on Nov 1, 09 12:31 PM
same for me...when he looks out the window it freezes while looking at the monster ..it keeps playing the music and wont move...any ideas? I updated my direct x hoping that was it...i uninstalled and reinstalled the game..no luck
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator