Posts created by beckykay

 
 
 posted in Road Trip USA on Apr 2, 18 5:33 PM
Windows 7. Won't play. Get error message and it shuts down.
 
 
 posted in Leaves 2: The Return on Aug 28, 17 6:35 PM
This is a brilliant game. I worked on the first one for weeks, and then this one was released and I couldn't resist. The story is adorable and very challenging. I really strained my brain, and yes, had to use the videos quite a few times. But I was also impressed with how many of the puzzles I could actually solve on my own. I think the developers of these two games are geniuses. I'm just so happy that there are challenging games like this - so thoughtful and magical and charming at the same time. I loved the artwork, the sounds, the odd creatures lurking along the way, & the creativity and imagination that went into making this game. It was so refreshing to see a couple of games released that weren't about a princess in distress, or a kingdom under attack, etc. This game is about solving puzzles/the game and it's a marvelous journey. The only negative thing I have to say about Leaves - The Journey, and Leaves 2 is this - they have totally spoiled me. Only this caliber of game will do from now on, and they are so rare. In spite of that, thank you developers and Big Fish.
 
 
 posted in Leaves 2: The Return on Aug 27, 17 6:47 PM
Same thing happened to me. I got them all on the right columns but didn't get a red bean. I finally took a piece from the bottom of one column and put in on top of the red column and magically got my red bean. ? But it worked and I got my bean.
 
 
 posted in Leaves 2: The Return on Aug 23, 17 5:55 PM
You wouldn't have to play The Journey first, but I would recommend it I think. I just finished it, and it took me a few days because it's so challenging. I just bought the second, and am not finding a walkthrough anywhere. That's the only way I was able to finish the first. I'm not brilliant, but these games are!
 
 
 posted in Leaves 2: The Return on Aug 23, 17 5:48 PM
Both this game, and Leaves - The Journey will only play with my husband's Windows 10 OS. I have Windows 7 and neither game will even open. Just a warning for those with older computers, like mine. And yes, I've tried all the suggestions, etc. Nothing is going to make this game play on Windows 7 64-bit, at least not on my computer.
 
 
 posted in Leaves: The Journey on Aug 16, 17 5:50 PM
I'm using Windows 7 64-bit and the game installed but won't play. I get a black screen with a large white cursor and then an error message and the game quits. I uninstalled and re-installed and same thing. I hope there will be a fix for this because this game looks like my sort of game.
 
 
 posted in Solitaire Chronicles: Wild Guns on Jul 11, 17 5:51 PM
The game downloaded alright, but it won't open.
 
 
 posted in Haunted Hotel: Personal Nightmare Collector's Edition on May 30, 17 6:07 PM
the game crashed after the forest labyrinth. everything froze up and I had to re-boot my computer. after that I tried the game again and disabled special effects. now things are working okay. so far. just finished the demo. can't decide if I want to purchase this game. I like it.
 
 
 posted in Magic Cards Solitaire 2: The Fountain of Life on May 10, 17 3:11 PM
Windows 7 64bit. cards won't flip or move. game just is frozen there. not a buy....but I do love me a new solitaire game. Looking forward to the next one
 
 
Games crashes. Once it did load, it crashed after I set the options. Kept getting the error message. Windows 7.
 
 
 posted in Spellcaster Adventure on Apr 18, 17 5:04 PM
The game won't play. I uninstalled and re-installed but still get the error message, and it stops working. Windows 7.
 
 
 posted in Mystery Case Files: Broken Hour Collector's Edition on Nov 27, 16 12:50 PM
thank you for the tip. i was also stuck on this one!
 
 
 posted in Evil Pumpkin: The Lost Halloween on Nov 20, 16 2:06 PM
I purchased this game when it was released, a few years ago, and decided to re-visit it since there's such a drought of good games. Well... the bad news is - I still find it really difficult to get anywhere. There is no walkthrough, and though the game could be a lot of fun to play, the hint button takes so long to refill that I found myself getting up to do other things while waiting - like laundry, vacuuming, dishes, whatever. Then I decided that it just isn't worth it. The game could be fun, but there is absolutely no sense to it, so you're constantly waiting for 1.5 minutes for the hint button to refill. Nothing makes any logical sense. Graphics are good, I liked the premise of the game, but oh man, come on developers. Surely you can give us senior citizens some help? I don't recommend the game, unless you have an I.Q. of over 140.
 
 
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 21, 16 6:49 PM
I really appreciate your reply, but there is no help for me. I have no bucket of plums, only a barrel of apple sitting not far to the left of the giant with the key. I'm given no instructions as to how to charge the slingshot. I'm supposed to charge it but how? Nothing I do or try charges the slingshot. I do recall using the slingshot once, but missed, and now get no other chance. The game has a glitch. I've resigned to not be able to finish it, though I did really like it until I encountered the glitch. Thank you for your response and suggestions! Unfortunately they are of no help, no fault of yours.
 
 
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 20, 16 6:37 PM
I'm unable to get the key from the giant. I got an apple, shot the slingshot, somehow missed, or I'm not sure what happened, but I'm unable to get another apple for the slingshot in order to distract the giant. Now the hint button keeps lighting up the slingshot, so I click on it and get the message "the slingshot is ready, now all that's needed is to charge it". How do I charge the slingshot? Anyone know? This must be a glitch in the game. I'm unable to advance, there's no where to go and nothing left to do.
 
 
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 20, 16 5:58 PM
If one misses the bucket and fails to get the key, how does one then get another apple to use with the slingshot? I'm not able to get any ammo for another shot with the slingshot. The hint button keeps lighting up the slingshot, and when I click on the slingshot it says "the slingshot is ready, it just needs to be charged". Anyone know how to charge the slingshot? I'm not advancing in the game until this is figured out. Maybe this is a glitch in the game? I'm using Windows 7 64bit.
 
 
Hint button doesn't work. Since the storyline makes no sense at all, I rely on hint button when this happens. No buy for me.
 
 
 posted in Steel LIFE on Feb 29, 16 7:30 PM
I really like this game, but it is so very frustrating! I love the graphics, the cleverness, the gameplay, everything about it except the bugs. At times the cord for the PDA will not let go of the cursor so I have to have the dang thing connected to my cursor no matter what I do. the only thing that fixes this is to leave the game and then come back in. Some of the controls don't work very well during mini puzzles. Operating that laser thing is ridiculous. It's hit or miss. chance, luck. frustrating I tell you. Because of these "glitches" or whatever one would call them, I don't trust the game, it's unreliable, and feel as though I could be stuck or frozen someplace at any given time. I think it was released before it was ready, and people now have to slog their way through it haphazardly hoping and praying they will make it! It's fun, but oh..with the only-sometimes-working hint button this game is a true challenge. Walk-through please!!!
 
 
 posted in Steel LIFE on Feb 29, 16 6:36 PM
I have a red screwdriver, a "strange token", a charged materialization device (it's like blue lightening inside) and a lever. those four items. the hint button keeps showing me the lamp with the green shade. I've already used that to shine the light through the metal plate. The round window is closed. I believe I've done everything there is to do in this house. the materialization device is charged. smh.....
 
 
 posted in Steel LIFE on Feb 29, 16 5:39 PM
Thanks for your reply. I've already opened the window for more light. I've passed that point in the game, the light bulb has been replaced, and I've used the green-shaded lamp to shine through the metal plate with the different-shaped holes in it (the passcode for something). The hint button will only show me the green-shaded lamp. It always takes me back there. So I'm missing something, I just haven't figured out what it is. I have the old battery charged in my inventory. I don't know where that goes either! What a game....I love it but do find myself wishing I had a walkthrough or a strategy guide. It would really help!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator