Posts created by SabineEden

 posted in Surface: Alone in the Mist Collector's Edition on Mar 6, 16 2:58 PM
Is it possible to get the Florist achievement on the iPad version? If so, could someone list all of the other achievements, because I thought I had them all, but I'm clearly missing one or more as Florist won't unlock.

Thank you!
 posted in Wanderland on Mar 19, 15 1:58 AM
Did you lose all of your progress when you trashed it, or is it saved on the server? I just became an addict of the game, too and don't want to lose what I've done already. I'm probably going to try your fix anyway, but figured I'd ask for the next poor player who has a problem.

Thanks for your help in either case.
 posted in Bluebeard's Castle on Apr 8, 14 8:33 PM
lvmykids wrote:I get to the fire place, can't get any further. Can't find the "coat of Arms Card". I have gone back to all areas can't get anywhere.

I know this is an old question, but I came here looking for an answer and didn't find one. I've set the spoiler text below to white which hopefully answers the question for someone else.

The item in question is listed in your inventory as "Note"--and you make it by using the rolling stamp at the ink blotter. My problem with this was that the game was REALLY picky about where you put the note into the skull--I had to move it in front of the skull until it "snapped" to a place above the mouth.
The karmic choices make for a couple of minor differences in the closing movie for the main game. I won't spoiler them here, unless someone asks for it, and then I'll create a separate post with a warning.

Haven't seen so far that the choices in the bonus game affect things at all. And the choices in that part of the game don't make sense to me. For instance, in managing the squirrel, the karmic choice that appears under the "good" comes with language that makes it sound like a bad choice. I'm wondering if the karmic choices in the bonus game are switched around on a couple of them.

I've now played with the all good choices and all bad choices, and that hasn't seemed to change anything in the bonus game.

I do like this game.
Just an FYI: To get the Professor's Cap achievement, it appears that you have to use the hint once, so that the game can "tutor" you about recharging hints. Couldn't figure out why I didn't get the achievement on my first playthrough, but that was because I was trying to get the achievements where you didn't use hints. After using the hint, I got the achievement.

UPDATE: Don't catch the wisp as soon as it comes on screen to get the achievement. You have to wait until a window pops up telling you about wisps. The hint you use does not have to be in an HOP, but it has to actually use up the hint timer, or it won't trigger a wisp to show up. If you ask for a hint and it just points you in a direction, that won't do it. I used one to show me what inventory item to use get past an obstacle.
I've had a weird thing happen in trying to get the achievements. I've managed to get all of them except for the one where you get all of the pumpkins. On my first playthrough, I missed a few of them, but I've now played through on all of the difficulty levels and managed to get all 45 of them on three plays of them, but I'm still at silver level instead of platinum. I haven't tested whether creating a game under a different profile and getting all of them the first time would solve the issue.

Don't know if getting platinum level means that you are supposed to get all of the pumpkins on all of the difficulties, but if I can make myself do the hardcore one once more, I'll give an update to see if it happens. I did replay the casual level (that's the first one I missed getting them all), but that didn't fix it.

UPDATE: I have now replayed the Hardcore mode and gotten all the pumpkins in main game, but still can't get the platinum shield. Also tried playing main game under a new profile and getting all of the pumpkins in main game, and that didn't do it, either.

Hope this gets fixed. I don't always try for all of the achievements in games, but this one was interesting enough that I was willing to replay to get them all. Good work, developers!
 posted in Dark Parables: The Exiled Prince on Mar 28, 11 5:54 AM
mmmm3004 wrote:I found the glass orb. Unable to find tree Disk to enter next room.
Help please.

The tree disk is only available when you play in "Hard Mode." Hard Mode becomes available after the first time you finish the game.
 posted in Hallowed Legends: Samhain Collector's Edition on Mar 25, 11 9:56 PM
Faerie wrote:Does anyone know what to use to get the items out of the pond? I can't find a thing that would be long enough. Driving me crazy.

You use the butterfly net that is stuck in the tree. At least if you are talking about the cemetery pond.

You can find answers to these things by going to the "Strategy Guide" at the Main Menu level. The guide is included with the game.

Happy fishing!
 posted in Wisegal on Dec 21, 09 7:29 AM
I started again from the beginning, and with the walkthrough for this game at [Gamezebo], I was able to figure out that there were a couple of pieces of the note that I hadn't found. What is frustrating is that when I clicked for a hint for these pieces of the note, I was told that I needed to look elsewhere, rather than being shown the location of the note.

If you get similarly stuck (this was in the playground at the park, the second time you go there), look at the screen snapshots at gamezebo to find all the pieces of the note.
 posted in Cassandra's Journey 2: The Fifth Sun of Nostradamus on Dec 19, 09 7:46 AM
Please, please, please port this over for the Mac platform. I have seriously considered taking classes in Mac programming in order to be able to offer that option to other Mac users, because there are so many good PC games that never make it to the Mac side. Don't get me wrong--I love my Mac, and I have to use it for my job in the graphics/design/prepress/publishing world, but I dearly wish that more titles were available on that platform. I know I am not alone, and I dearly hope that developers will take this into consideration and port over this title and the many, many others which are fantastic games.
 posted in Wisegal on Dec 19, 09 7:42 AM
It's been mentioned elsewhere, but there are bugs in this game. First of all, you have to be extremely precise in selecting things, which is an irritating feature of a few of the hidden object games, especially when the items are so small you almost need a magnifying glass to see them. Some games let you zoom in to solve this problem, but not this one.

The major problem for me, however, is that I am stuck in a location because not matter where I move the cursor, there is no arrow to allow me to leave the location. I'm looking at what is clearly part of a note over a child's sand shovel/scoop, but when I click on it, I get nothing. Clicking on the hint button tells me to go to another location, but again, I can't do that for the reasons I've stated.

I unfortunately found out this last bug only after purchasing the game. Very sorry I wasted my time on this one. I only bought it because there is a dearth of good games for Macs since it takes a while for games to be ported over to that operating system, and now I'm sorry I wasted my money.

Here's hoping that the kind people who code for Macs will take pity and get us some of the great titles from the PC side and port them over faster.
 posted in Gotcha: Celebrity Secrets on Dec 16, 09 6:33 AM
penrose47 wrote:
tubergal wrote:Great new twist on HOG. Enjoyed the game til I got to the exercise cards and was unable to click on them to rearrange them. Any suggestions? Is there anyone else out there who is having the same issue and if so, is there a fix to take care of this?


I am having a problem with the Cards that you have to line up. A BOAT< ANCHOR> ETC.... The HINT moves one then it goes bk and WILL NOT MOVE ?

I LOVED the game until I got to this part of the Puzzle. I WISH I could GO ON!
I LIKE the difference of NOT being the USUAL HOG.

HOPE that i can find out how to go on>>>>>>


I don't know if this will help, but you have to click and hold on the mouse button, and drag each picture to one of the squares while keeping the mouse button down.

I'm now in chapter two, and can't get the stage pass pieces to swap no matter what I do. If anyone has any answers on that, I'd love to hear 'em!
 posted in Gotcha: Celebrity Secrets on Dec 16, 09 6:27 AM
I don't know if this will help, but you actually have to click on each picture and hold down the mouse button while dragging it to one of the squares. Only after you have placed all four pictures will the "Submit" button appear on the monitor.
 posted in Steve The Sheriff ™ on Nov 27, 09 4:48 PM
With the help of someone on the support team (thank you Christine W!), I have done some testing on the issue of the hint display problem. I am running an original issue Mac Mini, at 1.4 GHz and 1GB of RAM. And I should mention that the original Mini does not sport an Intel chip (Apple didn't adopt that chip until at least a year, I believe, after the release of the first Mini).

Fortunately, one of my sisters has a newer model with the Intel chip, more RAM, and a faster processor. On her machine, the game ran picture perfect. The cigar smoke floats out, as lovely as you please, to encircle the hidden item. So I now have to conclude that I am going to have to upgrade my machine--something which I probably need to do, anyway.

Just thought I'd let you all know that the problem in this case really is with the user's setup and not with the game itself.

I should also mention that we tried a few things on my machine in the hopes that we could get the game to work, including upgrading some software (including Flash and Quicktime--if anyone wants further details, I am happy to provide them), but none of the things we tried managed to get the hint system to work. I could probably play the game fine without the hints, but I will probably wait until I have purchased a new system before doing that.
 posted in Steve The Sheriff ™ on Nov 4, 09 12:22 AM
I just downloaded this game for Mac, and was frustrated about how the cigar hint is supposed to work. Amazingly, I found a site where you could play the game for a little while in your browser, and discovered that what is supposed to happen is that smoke from the cigar floats out to a hidden object and then encircles it. In the Mac version, as you all know, all that happens is that the cigar burns to the end and no hint is given.

This is also a major glitch that will probably mean that I will wait to buy the game. If this and the continue problems are fixed, I will gladly buy this game, it looks no ends of fun.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator