Posts created by cold_moldy

 
 
 posted in Mythic Wonders: Child of Prophecy Collector's Edition on May 31, 15 11:45 AM
I am unable to even start this game as it won't load.Just a picture of a bird and the message "Loading." I re-installed it but still have the same problem. Any ideas?
 
 
 posted in Chimeras: Tune of Revenge Collector's Edition on Feb 12, 13 2:53 AM
My game D/L for the trial was a little slow but not bad. Enjoyed the game and bought it. Then it took hours. Finally got to play and it is slow motiion now!!?? I uninstalled & reinstalled & it is still the same. Very frustrating..... tried a bunch of the other things recommended but no luck. I wish it had been like this in the trial and I wouldn't have bought it. Too bad I didn't read all these problems before hand too. I hope their is a fix for it. Thought it was a fun game. I tried a couple more recommended fixed and updated just about everthing...it worked finished the game and am playing the bonus chapter tonight. Thanks!
 
 
Did anyone else have the problem of when you exit and then go back to the game later all former play is gone & one must begin at the very start of the game? I had nearly finished the game and this is really frustrating. Is there a fix? I remember another game that did the saame thing and there was a fix.
My charcter name was stll there but that was all.;
 
 
Bow
 posted in Awakening: The Skyward Castle Collector's Edition on Aug 29, 12 2:44 AM
Where do I find the arrows for the bow so as to shoot the red flag thing above the dragon door. I have my bow already.
 
 
I actually went back to page 36 & then went into the right temple wwhere I had placed the buffalo item above the vine covered door. I triggered the puzzle that I had not found before and once I finished that and went back out to frozen Peter the door with the other handle was found. Thanks for all the help and I hope my posting can assist someone too.
 
 
Okay, I looked on pape 32 & when the third compass is applied one recieves the round handle for the safe in the souvenir shop NOT the one in the museum office that now has a key but also needs a handle. I think that maybe it is the below the man turned to stone & I need that triangle item. I appreciate your reply but this is really frustrating.
 
 
I need to find the handle to the safe in the Museum office NOT the one in the gift shop. Have spent hours reading to see if I missed something but can't find it. If I can't open the safe then I can't get the plant poison. I am sure someone must have finished this game by now. Anyone that can help?
 
 
 posted in Delaware St. John: The Town with No Name on Nov 9, 09 12:34 AM
This is exactly the spot in which I am stuck at the time. I assumed it was the door which is across from Epp's office but I cannot knock on the door. I tried various doors down stairs in case I had the wrong door but they don't work either. I cannot read the writing on the doors either. Which door is the correct one?
 
 
 posted in Delaware St. John: The Town with No Name on Nov 9, 09 12:27 AM
I had the same problem in the beginning until I went through the tutorial. At this spot you have to get the umbrella from the dumpster and use it to pull down the ladder in the alley to the left ot the truck. Have fun!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator