Posts created by ZuluDawn13

 posted in Building the Great Wall of China 2 on Jan 2, 16 9:45 PM
I like this game except for one thing - those click-a-holic stupid click yourself lame screens that Pop up Unexpectedly with all these nomads running around Whilst you are actually playing a level.

There are also a couple of impossible levels to finish - have tried everything Including Collecting goods for the Caravan on the previous level - which, if you still don't get the three stars and you have to restart, then you Lose everything you had collected from the caravan full stop.

Lastly, when you get to the so-called last level, it just goes nowhere and I guess that's it. The game is actually Over.

If it hadn't been for those stupid Nomad clicking interruptions whilst playing a level, it could have been a very good game.

 posted in Rescue Team 5 on Nov 5, 15 1:08 AM
Thank you for your encouragement Hespera, I do appreciate your Hints.

Perhaps I could just give it a few more goes.
 posted in Rescue Team 5 on Nov 4, 15 5:04 PM
Love the new game BUT I am so OVER trying to get thru level 12.

WHY is there not a SKIP Feature??

I am Stuck in this level and Cannot move on because I'm a senior, not agile enough with hands and wrists to move as fast as is required - I tried the HINTS already.

What am I to do now?

I have bought all the other Rescue games over the years however, being stuck so soon in the new game is sad - please help.

Patch possible please?
 posted in Divine Academy on Jul 21, 15 3:08 AM
[Removed by Moderator]I mean I thought it was too good to have such a beautiful game for a certain cost - I would have paid good money to OWN this game.

I am so saaaaad to see xxx going this way I LOVE their games.

What now hey? do we sit and HOPE we get another good game some time soon which we can OWN or are people like me who have challenged Vision miss out because I cannot see properly on my iPhone to play games
 posted in Brownies on Jul 16, 15 5:30 AM
Similar problem with other fishies on other levels where the game says to Clear the Road and I Absolutely HAVE Cleared the Road - NO Doubts.

I cannot go forward to the next level No matter How Many Times I Replay Level 10-1 so am Stuck with no where to go. This is a Quality Assurance Matter and perhaps could have done with more testing prior to release...

Have also got an EXE problem with this level where Windows Messaged me with Closed the Game for my PC's Safety on this level.

I reloaded the game and still tried to replay it anyway and then I continued to get this Clear the Road message wrongly each and every time.

Can we get a PATCH for Level 10-1 please?

And, STOP my PC going into the Death Screen of Blue on Level 10-1.

On the PLUS side however, this would have to be the cutiest sweetist challenging game we have had in a LONG time.

Love TM games and they are too few and far between.
I would buy every decent TM game released if I had the opportunity.

 posted in Elven Legend on Feb 4, 15 8:43 PM
I played the Demo and Bought the Game.

The Options screen allows you to adjust, Sound, Music, Voice, Full Screen and Custom Cursor.

Game Modes are Relaxed (No Timer), Normal and Professional.

Gameplay - I needed to use the System Cursor to play in order not to feel like I was wading thru mud with the Game Cursor.

Technical Issues - I noticed that the Background or Wallpaper showing the little Roads would sometimes show the Roads and at other times on the very same levels, would show Flowery Wallpaper so you would not be able to navigate to the various items as there were No Roads shown. If I would Restart and Restart a few times, I could get the Roads back again and continue the game.

Timer - If you run out of Time, there is no going further, you need to Restart the entire level.

Voice Overs - I did not like hearing the Same words Repeated Over and Over and soon turned this Off.

Graphics - Apart from my Technical issues, I really liked the Cute graphics and little Characters.

Length of Game - 40 Levels which one can zoom thru in no time at all.

Challenges - not many really, you just need to plan a bit and restart the level if you miscalculated.

To Summarise, I thought it was a cutsy game, fairly simple and quick to get thru.
I turned Off the Music, Voice Over and Game Cursor in order to play this game.
The Game crashed twice during gameplay but that could be because I used the Vista PC operating system - not sure about that.

A cute game to get with your Credit but not a buy for me.
 posted in Gardens Inc. 3: A Bridal Pursuit Collector's Edition on Jan 23, 15 8:27 PM
I have bought each of the 3 games now and this last edition was much improved on the last game.

Now that we don't have to deal with pesky robbers on every level, I enjoy this editon much more but..

The one thing that annoys me is that there is no Relaxed Mode in the true sense. Ok we can continue playing if we are out of time, but, I would like to get the chance to take my time, enjoy the scenery, think things through and still get the gold like other game developers allow me to do.

I don't like the levels where you have to try and sneak past the cops and turn off alarms and operate switches all over the place - eek. I can do without them and I think a SKIP should be an option for those levels. That way, when we look at the overall map, we haven't got Exclamation marks on them to show they are not at the Gold level.

So please, give us a true Relaxed Mode with gold and let us Skip those silly turn off the alarms and switches level - includes the Maze. I don't think I can buy the next game if these Options are not available to me.

I guess I'm not the only older player out there who hasn't got the good eyesight and hand dexterity that younger fish have to complete each level with Gold.
 posted in Happy Empire on Dec 8, 14 10:04 PM
Played the Trial.

A simple, cutesy, kids game.

I was hoping for a challenging TM game as there haven't been many around lately.

A No Buy for me.
Overall an enjoyable game.

There were some glitches when trying to pick up things - you just had to click a certain spot.

In my case, although no one else seems to have mentioned this, is that the Loading and Saving to Exit time took ever sooo long! This is the first game from all the games I have bought here that has taken sooo long to carry out these functions - I don't understand why?

The story was ok but I did enjoy the graphics so much - thank you to the seven artists.

Regardless of my Comments, I do think it is worth the CE price - there are hours of game play to justify it.
 posted in Risen Dragons on Oct 27, 14 8:49 PM
Apart from other people, I dón't know how to begin the game from start to finish with an actual guide.

I can't kill all the monsters.

I don't know how to get more gold stars without replaying the game on the main island over and over with all three dragons.

I have all the skills that are bought with gold stars and then when I try to upgrade a tower it shows padlocks.

I just do not understand this game and I feel like I'm stupid because other people seem to be able to work it all out.
 posted in Risen Dragons on Oct 27, 14 8:47 PM
Game crashing at lab match 3 with birdie and coming out of an island.

 posted in The Tiny Tale 2 on Jun 4, 14 1:36 AM
I found the trial version so bug ridden it was as though this game was a trial version of a future, fully finished game.

The game was a cartoon and very basic - I would not be able to justify buying it I am sorry to say.

The gameplay was jumpy and at times seemed slow to catch up with clicks.
I played the game on my PC desktop MS Vista so maybe it plays better on other systems?

The Sounds the characters made were ok but could possibly become a bit trying as the game continues.

Now I am a great fan of MKFP and the like - these games are evolving all the time to offer players more and more challenges and fun, addictive gameplay.

In my humble opinion, I feel that Tiny Tale 2 may need a lot more work to come up to the standards of current Time Management games on offer from Big Fish.

 posted in Gardens Inc. 2: The Road to Fame on Mar 31, 14 5:21 AM
Thank you I will do that
 posted in Gardens Inc. 2: The Road to Fame on Mar 31, 14 5:19 AM

Clue is - you can find everything in this Maze - yet I have got it done in Gold time but cannot get the Bonus Clue - is there a secret to this please?
 posted in Gardens Inc. 2: The Road to Fame on Mar 31, 14 5:07 AM
This level is very difficult for me to get Gold..

I built the police stations and animal ranger and other buildings ok but, I feel I am constantly having to check the vandals from wrecking stuff and despite collecting the two clocks, cannot finish this level in Gold time.

Anyone got some tips and the strategy for this level please - I would love a walkthru and a explanation of all the Clues too. Maybe the developer has that available for older fishies..
 posted in Gardens Inc. 2: The Road to Fame on Mar 30, 14 7:55 PM
Anyone worked out what the clue - You can find everything in this Maze - means please?

Tried just using wood, bricks and tools which were in the maze to complete but then still need to get bricks - not sure..
 posted in Gardens Inc. 2: The Road to Fame on Mar 28, 14 3:39 AM

I have tried all different flower colours - please help
 posted in Gardens Inc. 2: The Road to Fame on Mar 25, 14 7:10 AM
Loving this game and absolutely hopeless at trying to get Gold - its fun tho.

The Clues the game gives ( in the lower right of play screen ) are puzzling to me. Sometimes the storyteller gives some clues but not always on how to get Bonus points. Its double dutch to me and I'm dutch!

Any other fishies finding it tricky to get gold and understand the clues or am I just becoming slower with age?

The game is colorful and very busy and addictive too.

The only glitch I find with this game is that it is very slow to load to the next screen after finishing a chapter..

Great game developers - thank you
 posted in Emberwing: Lost Legacy Collector's Edition on Mar 17, 14 6:12 AM
I'm stuck like other fishies with the two Moonflowers in the dry patch - used the little rake on the left and it disappeared.

No water for the 'dry patch' with the last two flowers..

I tried moving ALL the rocks to no avail. The only rock which did move was the one used to break open the hollow log which had 2 flowers in it.

Tried all the ideas other fishies tried and now I'm a sad fish with nowhere to go..

jcsgame wrote:Hi:

After talking to minesita, it looks like the game "requires" you to use the Rake "before" you click on any of the open flowers.

If you use the Rake first, you can get water to both sections of "buds". After watering the buds, you can go ahead and click on all of the open flowers.

I do hope the Developer comes up with a fix for this situation.

I don't feel like starting the game from the beginning.
 posted in Dark Dimensions: Somber Song Collector's Edition on Mar 15, 14 4:40 AM

Game Freezes when accessing the Guide - used Alt, Cntrl, Delete buttons to get out.

Checked the Guide BUT cannot put Glue (U) on the Broken Mirror (indicated in the Guide with the letter O - so to fit the mirror pieces back inside the Mirror Frame - as Guide indicates..

Cannot move on no matter what I've tried so paid Extra for CE and have only played the SE part of the game - not a happy fishy here..

Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator