Posts created by smartsue

 
 
 posted in The Secret Legacy: A Kate Brooks Adventure on Sep 29, 12 11:45 AM
I can't pick up the baseball bat either.



Took the suggestion about clicking on the bat to the left of the bottom part and it worked! Finished the trial with no more problems. Thanks.
 
 
 posted in The World`s Legends: Kashchey the Immortal on Aug 7, 12 11:44 AM
I tried to play demo but couldn't get out of the bedroom. I collected all items, played the hidden object game (twice) and kept sending me back to the beginning! Finally gave up, not worth it.
 
 
 posted in Nightfall Mysteries: Black Heart on May 30, 12 3:33 PM
I am having same problem in the dungeon. Picked up the paper but nothing else. Can't leave either. Tried all suggestions with no help.
 
 
 posted in Sherlock Holmes and the Hound of the Baskervilles on Dec 11, 10 3:43 PM
I hate games with custom cursors. Usually they don't work and if I can, I use a regular cursor which takes away from the game. But with this game I had to change from the custom cursor and the regular cursor stuck. Couldn't get past the sign in page. Had to use CTRL/ESC to get out. No thanks.
 
 
My problem with the tavern key got worse. Now the game is stuck on the strategy guide book and when I close it the screen goes dark with just the words Inventory. Objective. map and journal. The music plays but screen stays dark. Have reinstalled this game more than once but was told that won't help. Would like a refund,too.
 
 
Another game with a custom cursor that I can't use which takes away some of the fun. So slow I can't play. Took me 10 min. to get the chain off of the gate and click on the bag. No thank you.
 
 
Birth date is 1726 not 1728. That should work
 
 
I'm having the same problem. Clicked on the key in the bartenders hand and saw it move down but it's not in my inventory. Yes, I clicked on the blue arrows to check ALL items in my inventory and no key! Can't continue with the game.
 
 
 posted in Twisted: A Haunted Carol on Dec 7, 10 11:35 AM
Can't zoom in on the panel either. Put the lit candle in place, saw the highlight on the panel, clicked and nothing happened. Clicked on hint button and it highlighted the panel. Click and click and nothing.
 
 
 posted in The Dragon Dance on Nov 30, 10 2:23 PM
Took forever to load to play. The cursor was a white square and jumped around so much I couldn't change it to a regular cursor. Terrible!
 
 
 posted in Haunted Halls: Green Hills Sanitarium on Nov 27, 10 8:32 PM
I,too had cursor problems. But also movements were so slow that the objects I clicked on in the hidden objects game took forever to move. Took 30 min and I was still in the trunk of the car. The cursor would "explode" and I had to wait for it to reassemble so I could exit game. Too bad. Looked like a good game. CE wasn't much better.
 
 
 posted in Haunted Hotel: Lonely Dream on Sep 1, 10 8:58 PM
I've had nothing but trouble since I started this game. It sticks and can't move on to next level and have uninstalled and installed this game so many times. Usually I can coax it to move on but now I'm really stuck. I'm at the door where you use the screwdriver to take off a metal plate by a door, push the key out onto the newspaper under the door. Whenever I try to use the screwdriver, it won't let me. It keeps saying to try something else. I used the walk through for help and I'm doing everything I'm supposed to. The only thing: the Tasks says to "perform the ritual" in the last level and I did that but I don't think it registered. Help!
 
 
 posted in Exorcist on Aug 17, 10 12:24 PM
Couldn't get past the intro. Sound stuck , picture stuck, and cursor stuck. So, I gave up and quit.
 
 
Help! I'm stuck in the house on fire and it keeps telling me to go look someplace else but where? Can't go anywhere.
 
 
I've had the same problem,too. Thought it was me but guess not.
 
 
 posted in Hidden Mysteries: Vampire Secrets on Jul 19, 10 8:54 PM
I can't play the game. For some reason right after the Big Fish Game window at the beginning it stops and returns to windows. I've reinstalled twice but same thing. No warning,no error message, just quits. Too bad because it sounds like a fun game.
 
 
 posted in Journalistic Stories on Jul 19, 10 12:02 PM
The floating cursor is enough to turn me off! When you can't play a game without fighting with your mouse, it's no fun! Will pass on this buy.
 
 
 posted in Kate Arrow: Deserted Wood on Jun 30, 10 9:08 PM
I almost finished the game, got all the way to fixing the medicine. I left the game but when I returned, it lost all my information and my login name and sent me to the very beginning! I uninstalled and reinstalled but didn't help. I guess I'll start over but not right away since it has taken me a few days to get this far and there are other games to play.
 
 
 posted in The Inquisitor on May 31, 10 8:04 PM
to britt613: to get to the mill, leave area with two houses and tower back to the bridge. There is a path to the right where arrow will point and that takes you to the mill.
To others who are trying to get back in the tower, I don't think you need to. There is nothing there.
 
 
 posted in The Inquisitor on May 31, 10 7:58 PM
Have same problem as many of you. Played demo,bought game,played for awhile,closed game and now get error message when I try to play. Another problem was after demo and bought game, game was not saved even tho' I signed in and had to start from beginning. Emailed for help with error message.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator