Posts created by Cinders31

 posted in Epistory: Typing Chronicles on Feb 10, 18 11:32 AM
In Creation City I have a bug flying at me with WHITE lettering.
Anytime I type the words, it does not register and I get killed.
I have tried typing in SPARK, FIRE, and ICE.
NONE of them work.
Is this a tech glitch? or am I missing something?
 posted in Flowers Mosaics on Dec 4, 17 11:04 AM
I sure need a list too. Played all of the puzzles three times now and still missing 4 puzzle pieces. I did not take note of where the ones were that I found and wish I had.
 posted in Flowers Mosaics on Dec 4, 17 11:03 AM
yes, I am having trouble getting all the pieces too. I have the obvious ones but if the color is white, yellow or light blue, it is really hard to see them.
 posted in Roads of Rome: New Generation 2 on Nov 2, 17 2:58 PM
i use windows 7 and i have it shutting down too. constantly.
 posted in Leah's Tale on Sep 9, 17 9:06 AM
Hi, I been wandering around the dessert for quite a while now. I can't remember the exact spot where I found the lobster but I do remember finding one near water.
It has a few skulls around it.
Wish I could help more, this is an older game but I just got it myself.
 posted in 3 Stars of Destiny on Aug 2, 17 8:10 PM
I just bought this game and already have a problem I can't seem to find the answer to.
I finished delivering to my parents, now looking for the elf. I do not have a "quests" section in my menu.
I find the elf but nothing happens. There isn't even the acknowledgement of finding her.
this must be a bug and yet this game was out on BF last year or longer.
 posted in Deadly Sin 2: Shining Faith on Jul 29, 17 7:48 AM
Hope someone still comes on this board because I need some help desperately! I have been searching for the harp for days. Just can't find it.
Yes, I jumped off into the waterfall and been running around underwater but still no shipwreck for the harp.
 posted in Echoes of Aetheria on Jul 27, 17 11:41 AM
Absolutely love this game. Some RPG games are too short but this one is longer than any others I have played.
My favorite games are the RPG kind. I have grown tired of the Hidden Object, match 3 and the time management. Back to my first love of gaming now with RPG.
Unfortunately Big Fish does not carry a large selection of these games which means that I either have to wait for a year or more, or spend my money at another site to play them.
 posted in Echoes of Aetheria on Jul 27, 17 11:37 AM
After playing for awhile the game gets very choppy. slow, freezes for a minute, then continues but is very slow.
Hard to play when it is like this.
 posted in Echoes of Aetheria on Jul 27, 17 10:07 AM
Found this on the game developers forum:

Powerful end-game forge recipes
Adamantite Plate Armor: Legendary quality plate armor.
Plate armor pattern

Dragonscale Armor: Legendary quality mail armor.
Mail armor pattern
Dragon Scale

Auraweave Cloth Armor: Legendary quality cloth armor.
Cloth armor pattern
Auraweave Cloth
Silk Thread

Adamantite: Super high-end metal primary material.
5 Aetherium
2 Obsidian
1 Promethion

You can salvage Adamantite to gain:
1 Adamantite Ingot
1 Adamantite Sharpening Stone
1 Adamantite Counterweight

Dragon Scale: Super high-end leather/scale primary material.
5 Aetherium
2 Behemoth Leather
1 Promethion

You can salvage Dragon Scale to gain:
2 Dragonscale Armor Patch

Auraweave Cloth: Super high-end cloth primary material.
5 Aetherium
2 Cashmere Cloth
1 Promethion

You can salvage Auraweave Cloth to gain:
3 Grandmaster's Schematics

Essence of Might/Skill/Power: These are very powerful "gems" that can be used to forge weapons.
1 Garnet Cluster
1 Ruby Cluster
1 Amber Cluster
1 Emerald Cluster
1 Diamond Cluster
1 Sapphire Cluster
1 Peridot Cluster

Adamantite Weapons: These are earned from finishing the individual arena challenges. Clearing Lucian's solo arena will give you the Adamantite Greatsword recipe.
2 Adamantite
2 Promethion (or 2 wood if Kesh's wae)
(Add whatever else you want)

How to find some of these mats:
Obsidian - mined from Aetherial Manifold and Imperial Palace Sewer, purchased from final home base forge vendor (not cheap)
Cashmere Cloth - find in end game chests, purchased from final home base forge vendor (not cheap)
Behemoth Leather - easily found in chests and purchased from several later game vendors
Aetherium - drops only, from final dungeon mobs and level 50+ repeatable dungeon mobs
Promethion - purchase only, expensive reagent from later game forge vendor
Last edited by harmonic42; 27 Jan, 2016 @ 11:21am
 posted in Echoes of Aetheria on Jul 27, 17 10:01 AM
I think electricity and aether works.
 posted in Echoes of Aetheria on Jul 22, 17 8:11 PM
If you are using a mouse, you have to use the arrow keys. I used a mouse and nothing happened except her arms move and head. Once I used the arrow keys I saw lightening and other things, then I could move on.
 posted in Echoes of Aetheria on Jul 22, 17 8:10 PM
I used a mouse and was wondering what the heck is going on... hands up and down but nothing happens. Then I used the arrow keys and there was a lot of lightening etc.
Finally got through it. Just a little tip in case anyone else is using the mouse.
 posted in Echoes of Aetheria on Jul 22, 17 8:07 PM
Please put more of these rpg games on your site. I love these kind.
This game so far is really good and I like that it is not over in 2 hours.
I am close to the end but have difficulty in finding some things. Hope there will be a walk-through soon
 posted in Alpha Kimori ™ on Jul 18, 17 4:42 PM
Just like other players, I would like to see more games like this on Big Fish!

I am bored with Hidden Object Games and Match-3s. some of the time management games are okay but starting to get bored with those too

RPG games like Alpha Kimori are more adventure-like than any others. I know there are many RPG games but BigFish is way behind on these kind.

Just because the art work is beautiful on the games that are released daily doesn't mean they are better. They are all the same, some kind of horror genre thing happens and a mystery to solve by finding objects. I lost interest in those a long time ago.

PLEASE Big Fish, have more RPG games available.
 posted in Adelantado Trilogy: Book Three on Apr 15, 16 12:35 PM
Will you be making more games like these three? I LOVE them!
 posted in Rooms: The Unsolvable Puzzle on Apr 13, 16 7:24 PM
ummm I just tried this and it doesn't work for me... Anyone have directions that are a little more clear?
If I move the room down and right, then go down and use a bomb... then it is a waste of the bomb. It does nothing there.
maybe these directions are not for the basement?
 posted in Rooms: The Unsolvable Puzzle on Apr 13, 16 7:19 PM
Thank YOU
 posted in Rooms: The Unsolvable Puzzle on Apr 12, 16 3:47 PM
stuck at this point for days. stuck on some other levels too but could not find any spoiler for this level.
Anyone? Thanks
 posted in Aveyond 4: Shadow of the Mist on Feb 17, 16 3:37 PM
I thought I sold it too!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator