Posts created by pegod

 
 
 posted in Dawn of Hope: Skyline Adventure Collector's Edition on Nov 7, 16 6:28 PM
Has anyone found the morphing object in the shadow projecting hidden object scene?
Phyllis
 
 
 posted in Christmas Stories: Puss in Boots Collector's Edition on Dec 4, 15 3:15 AM
There were only two things that bothered me in the game.
1. I was never sure in what scenes I had already found the morphing object. Some companies have a little icon that lets you know if there is one in the scene and whether or not you have found it.
2. Apparently there are three puzzles for which you need to find all the pieces. I found all the puzzle pieces for one of the three. The other two I failed to get one piece in one and two in the other. I would have liked to have been able to go back to the specific scenes where the missing puzzle pieces might be found. I know they just want me to play the game again but I do have a life to live.
Anyway, I enjoyed the game.
 
 
 posted in Demon Archive: The Adventure of Derek on May 25, 15 1:08 PM
I am stuck at Mermaid Bay and I cannot get into the cottage or down the cliff or find something to cut the harp down from the tree. It was crappy during the demo but I was bored and used a credit to get it. I certainly regret the purchase. The hints are not helpful, and click and drag inventory items is tedious. And don't they have someone to proof read the text in these things - a "snack" medallion when it should be "snake" medallion. Really?
 
 
 posted in Danse Macabre: Deadly Deception Collector's Edition on Mar 4, 15 9:48 PM
I started the game and after a few minutes I decided to buy it. Closed the program, download the full version and activated it. Now the game won't let me progress past the end of the demo version. Any suggestions?
 
 
 posted in Frankenstein: Master of Death on Jan 27, 15 3:06 PM
Hi Fellow Fishies
I started the game again under a new profile and had no problems. I enjoyed this game once I actually got to play it.
 
 
 posted in Frankenstein: Master of Death on Jan 26, 15 9:07 PM
Hi Tophen
You are in the car, right? On the dash board there are bluish buttons. When you click on them they light up bars on the compartment you are trying to open. when you hit them in the right order it opens the compartment. I hope that helps.
 
 
 posted in Frankenstein: Master of Death on Jan 26, 15 8:53 PM
I was enjoying the game so I bought it. When I started it up again, the hint button no longer worked. Then I got stuck in the passage to the castle. The only way I can get to the castle is to use the map. I have two of the three film reels, so I cannot view them in the projection room; the key is broken off the door in the bedroom; the ladder in the corridor needs its top half; where do I find the eye for the cart in the passage way? How am I suppose to get to the little cave above the rock slide? have I missed something? I think I am regretting my purchase. Not happy.
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 10, 14 5:24 AM
Same problems here - can't get the stone feather; hint button no longer works (with 7 hints) and the bear skin cannot be moved. I was really enjoying this game and now I am stuck.I hope these developers aren't strictly M-F 9-5 because I want to play this game today - Sunday!!
 
 
 posted in Mysteries and Nightmares: Morgiana on Jul 9, 14 4:35 PM
I am stuck, too. What's with the disappearing sparkles on the map? Sometimes they lead me in the right direction, most times they are not there and I am confused. I am sorry that I purchased this game. I feel obliged to persevere since I feel I must be near the end but I find it more stressful than enjoyable. Sooooo, does anyone have any ideas what I am supposed to do next? Thanks for being here. It means a lot to me.
 
 
 posted in Lost Souls: Timeless Fables Collector's Edition on May 10, 14 1:19 AM
I think too much all day and stress has given me high blood pressure. I thoroughly enjoyed the ease of this game.I bought it after the first chapter. Easy - yes but not boring!! I am going to check out the previous game since so many of you have given it a nod.
 
 
 posted in Clutter 3: Who is The Void? on Feb 11, 14 10:51 PM
I LOVE this game!!! It is as challenging as I want it to be and varied enough to keep me occupied for hours. My family won't see me for days!!
 
 
 posted in The Fog on Dec 9, 13 2:22 PM
My code for the phone was 9427 and it did not work either but I tried WolfenRaindancer's code 8562 and it worked! So I am back on track, Thanks , WolfenRaindancer.
 
 
 posted in The Promised Land on Jul 18, 12 12:49 PM
Where do I get the magic axe?
 
 
 posted in Amulet of Time: Shadow of la Rochelle on Feb 14, 12 2:46 PM
I am getting "Panic File:.\LuaMan.cpp line 282"
Then "[]string 'curs=0..."]:109 deleteFromQueuedeletefromClickQueuefailedobject not found

What do I do now?
I paid for this game. It had better work.
 
 
 posted in Bedtime Stories: The Lost Dreams on Feb 6, 12 8:23 AM
I agree. It wasn't even worth the time it took to download the demo. I think that developers should spend a little more time on story lines and making sure their game is ready for play - no glitches. Honestly, in this day and age...
 
 
 posted in Midnight Mysteries: Haunted Houdini Deluxe on Jan 29, 12 1:44 PM
I loved this game!! Intriguing game play. Very helpful strategy guide so there was no frustration when I got stuck. A pleasure to play. Bought it after ten minutes into the trial version. Can't wait for the next one.
 
 
 posted in The Secret Order: New Horizon on Dec 21, 11 9:04 AM
How do I open the garage door in the alley way?
And where do I find the key to open the glove box in the wrecked car?
 
 
 posted in Youda Mystery: The Stanwick Legacy on Nov 17, 11 12:01 PM
Wow!You are all ahead of me! I am stuck looking for the sixth cube to reveal the elevator code.Anyone?
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 20, 11 8:08 PM
Thank you very much.
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 20, 11 2:47 PM
Where do I plant the seeds? I have the magigrow stuff.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator