Posts created by tlhwest

 
 
 posted in Ramses: Rise Of Empire Collector's Edition on Mar 22, 18 5:16 PM
I'm stuck on Level 35; I can't figure out to get to 17000. Any tips?
 
 
 posted in Elven Legend 3: The New Menace on Aug 26, 16 7:09 PM
For some reason, I have a big black space in the middle of my computer screen on level 16. I can't see anything, which means I can't finish the level. Any advice?
 
 
 posted in Incredible Dracula: Chasing Love on Nov 23, 15 8:04 PM
I'm having a lot of difficulty with this level. Either the guards destroy all my buildings before I can build the lab, or I run out of stone after I finally destroy the guard towers. Any suggestions?
 
 
 posted in Yard Sale Hidden Treasures: Sunnyville on Jun 16, 15 9:43 AM
I have the same issue! What's going on, BFG?? Maybe you should contact the game creators to find out what the glitch is??
 
 
I've reached the point where the abbot wants me to copy an ancient scroll. I keep getting directed to the place where it says letters are needed; only problem is, I have no letters in inventory! What do I do?
 
 
 posted in Solitaire Game: Halloween on Oct 16, 14 3:28 PM
I was able to play the game fine at first, but now there's a fatal error that terminates the program whenever I click on "Play." I uninstalled/reinstalled, but I still have the same problem.
 
 
vbeau84 wrote:Hi
I think there might be a glitch in this game as
I've sorted out the games console bit and now
there is no inventory displayed at the bottom
of the screen and nothing happens when you
press the hint button (have tried rebooting both
PC and game but no success)


I'm having the same problem; no inventory, the dialogue doesn't continue, and the hint doesn't indicate what to do next; it just froze up for some reason!
 
 
 posted in Awakening Kingdoms on Jul 28, 14 1:55 PM
Ever since I downloaded the latest upgrade (7/25), I can't get to the game by clicking the desktop icon. When I do that, I get a message that says the game has quit working. I end up having to access the game via the Game Manager.
 
 
 posted in Mysteries and Nightmares: Morgiana on Jul 7, 14 10:00 AM
When I clicked on Play in the Game Manager, the screen went to black for a second or two, then I got bumped back to the desktop. I kept trying, but to no avail. What's going on??
 
 
 posted in Awakening: The Redleaf Forest Collector's Edition on May 31, 14 10:31 AM
I can't even get the demo to work! For some reason, when I hit play, the screen goes to half-screen, then full-screen, then bumps me back to the desktop. The game screen remains black. HELP!
 
 
 posted in Royal Envoy 3 Collector's Edition on May 24, 14 2:51 PM
On this level (glacier) I'm supposed to get 600 Happiness. I have three chalets and three dovecotes, and I'm still 150 short. What do I do?
 
 
 posted in The Beardless Wizard on Apr 27, 14 3:50 PM
I'm having a problem with Level 37. I get close to the end of the level; I've done everything required of me; but the game says I still have to find three crystals, even though I've saved the baby turtles. Then I try to go to the mama turtle, and the game freezes. The cursor still moves, but the game won't continue. What's wrong?
 
 
 posted in Viking Saga: New World on Mar 4, 14 3:23 PM
For the life of me, I can't figure out what to do here! I'm not sure if I should build the druid's hut or not, or where to find enough stone to build the third bridge, or if I should build a house first, or what! AAAARRGH!
 
 
I have a problem. I put the two winged statuettes on the appropriate place in the tower dungeon, but for some reason the game kicked me out of the close view before I could pick up the golden feather. Now I can't go any further in the game.
Any ideas?
 
 
I was playing the demo, and without any warning, my cursor started to flicker and would refuse to move around the screen. It was at the point in the game where I found the postcard with the people who had bought paintings. I couldn't go any further; I couldn't even reach the Menu button to exit. I had to shut the computer down in order to exit the game. Once I turned it on again, everything was fine.
 
 
 posted in The Far Kingdoms on Nov 19, 13 3:01 PM
I downloaded the game, and it won't activate. How did a game with so many technical issues get approved by Big Fish Games??
 
 
 posted in When In Rome on Sep 20, 13 6:17 PM
I've been playing level 35, and I've hit a problem. According to the game, I have to get 3,000 gold. I achieved every other goal, but when I achieved the 3,000 gold goal, the game wouldn't move to the next level. I went up to 6,050 gold, and it still won't go forward. Aaaaugh!
 
 
 posted in Kingdom Tales on Jul 17, 13 12:59 PM
I have no idea how to proceed here. I usually start by building a farm, well, and stonecutter, then building a house. The problem is, after I get rid of the first two sorcerers, I have no magic power left, so I can't clear paths to empty lots where I can build the pavilion. Any suggestions?
 
 
 posted in Moai: Build Your Dream on Jun 24, 13 8:41 PM
Thanks; it worked!!
 
 
 posted in Moai: Build Your Dream on Jun 24, 13 6:32 PM
I've gone as far as I can. I've been able to open all the chests and cut down the three trees, but I'm still missing the last five pieces of wood I need to repair the bridge. HELP!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator