Posts created by kerrikowal

 
 
 posted in Labyrinths of the World: Shattered Soul on May 22, 17 7:44 PM
Thank you for this!!
 
 
 posted in The Secrets of Arcelia Island on Sep 9, 11 3:43 PM
I have obtained the boat hook, the empty canteen and the screwdriver in the first scene and am unable to "move" or "zoom" anywhere. Cannot go upstairs or back into the cabin. Cannot "zoom" to the panel that I am supposed to work on now. Just frozen. I deleted the game and re-downloaded it and still have the same problem.
 
 
 posted in Redemption Cemetery: Curse of the Raven on Sep 5, 10 6:33 PM
Excellent game. Good graphics, challenging but not impossible gameplay, very long length. Definitely feel I got my money's worth on this one. Fun!
 
 
 posted in Haunted Hotel II: Believe the Lies on Sep 2, 10 8:50 PM
I am having similar issues. A couple of days ago I had no problem playing the game. And then tonight I went to play it and when I click "Play" I just get the front page reloading with the Play/Options/Exit etc. selections again. Over and over again. Never goes to the game. Shut everything down and reloaded big fish console and saw that there was a game update, so I loaded that, hoping that it would address the problem. No luck. Still the same issue. Get to the splash screen, click play and the splash screen just reloads. WTF?
 
 
 posted in PuppetShow: Souls of the Innocent on Jul 24, 10 6:57 PM
One of the best games I've played in a while. Graphics are gorgeous, game play is fun. Loved the hidden object where you have to switch the light back and forth... cool! Game play was hard enough to be challenging, but not so hard it was frustrating (like that stupid Cleopatra game). I had to check the walkthrough a couple of times only. Could have improved navigation a bit... had to travel back-and-forth a lot, going step-by-step. Overall, highly recommended.
 
 
 posted in Be a King 2 on Jul 1, 10 3:08 PM
FYI, I played the level again and had no problem attracting citizens.
 
 
 posted in Be a King 2 on Jul 1, 10 11:36 AM
I completely filled Southwood with everything required for a good village, but no citizens ever came. I made the 20K wood requirements, but was stuck at -2 people until I quit the level out of frustration. I had everything needed, e.g., farms (2 royal with a mill and bakeries), houses (5 royal townhouses), protection (4 advanced mage towers and 3 royal barracks), etc., but no citizens ever came.
 
 
 posted in Masquerade Mysteries: The Case of the Copycat Curator on Apr 21, 10 1:11 PM
bribling wrote:I gave up in the museum when I reached the point where I needed a screwdriver to open a panel and all the Hint would do was indicate the panel which is one of the most obvious items in the game up to that point. I could not see the screwdriver. I did a good bit of random clicking and did not find it. Two Hints with the intervening wait both showed me the panel which cannot be opened without the screwdriver. I did see an object that looked like a screwdriver but no amount of clicking would bring it to my inventory. Maybe it is the screwdriver.


This also happened to me... I purchased the game, but am unable to activate the hot spot on the panel to get the screwdriver to open the panel per the walkthrough. I want my money back since I was only able to play the first two chapters.
 
 
 posted in Escape the Museum 2 on Nov 25, 09 11:36 PM
Thanks, Don... that worked. They need to correct the walkthrough!
 
 
 posted in Escape the Museum 2 on Nov 25, 09 11:31 PM
I cannot get the gum/jacket hotspot on the bus, either. And now I am going to hesitate to call to get the fix, because I do not want to go all the way through the game again for a fix that didn't work for you!
 
 
 posted in Escape the Museum 2 on Nov 25, 09 11:30 PM
Is this the city bus where you are looking for the gum? I can't find it either. I am not getting the hotspot like the walkthrough says is there.
 
 
 posted in Escape the Museum 2 on Nov 25, 09 11:26 PM
I am also having difficulty getting the gum on Level 24 - City Bus... walkthrough says the jacket collar is a hot spot... but mine is not a hotspot. I've clicked everywhere... never activates as a hotspot.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator