Posts created by heidid

 
 
 posted in Hidden Clues on Feb 16, 16 9:24 AM
My enjoyment from puzzles like this stems from being able to complete them without guessing and without needing clues. I'm not referring to difficulty level, but to whether it is possible to do so or not.

It's possible I'm missing something, but this would be a much better game if I had the directions/clues for all colors available at any time. I didn't get very far before I encountered a set of clues that made it impossible to even start eliminating boxes, yet if I had access to a different color I could have started a process of elimination.

I only ended up playing for about 10-15 minutes; guessing isn't interesting to me. This type of puzzle has been one of my favorites for years, but it needs to be done correctly - extra hints, guesses, or information that doesn't follow logically ruins the game for me. (For example, I don't mind the "fill in the blanks" feature when I have completed everything in a row, but I hate it when it gives me information I didn't already have. It's done pretty well here in the advanced mode, though it's unnecessary - for me - to have all the push-pin graphics.)

In all, I find it's too many bells & whistles, and not enough solid logic. No buy for me.
 
 
 posted in Youda Sushi Chef 2 on Jun 10, 14 10:40 AM
I just finished playing through the first game, and started up the demo version of this one with a few things I was looking for. So far, however, this seems to be a big step down. The problems I had with the first game seem to still exist, and there are a bunch of extra things thrown in that don't really improve gameplay for me.

Issues with both games:
1) I want to be able to study the recipes without worrying that my time is running down. Either let me examine the book outside of the levels, or pause the timer while the recipe book is open.
2) It drives me nuts when customers "steal" items that were intended for a person farther down the belt. I really wish there was an option to give an item directly to a customer on occasion - not make it the default, that would be awful, but have it available - maybe as a powerup, or something.

Issues with this version -
1) I really don't like the change in graphics. This one is way too bright and cartoon-like. I really enjoyed the soothing atmosphere of the first.
2) Music - also something others have mentioned. The first one had separate sliders for music & sound effects. Why take that away?
3) Gameplay seems pretty much the same - even some of the same recipes, but they have changed the icons, sometimes to something harder to recognize.
4) Not sure I like the new ordering system - it requires more mouse movement, which is less efficient. This might be less of an issue if I hadn't *just* finished the first game, however.
5) No explanation whatsoever on the levels - why is only 1 star filled in when I got at least double the target income?
6) tutorial, what there is of it, completely interferes with gameplay, can't be skipped, and my timer ran out when I was "forced" to go buy more rice, even though there was only 2 seconds left on the timer and I knew I didn't actually need it.

In all, i won't be buying. This is about a 2.5/5 for me.
 
 
 posted in Fantasy Mosaics on May 9, 14 12:44 PM
So, am I the only person who noticed numbers getting crossed off before they should" I love these puzzles, but I am not buying this one - I want to solve them myself, and the extra information felt like cheating.
 
 
 posted in Fantasy Mosaics on May 9, 14 12:42 PM
This is an enjoyable game, but I have issues with it. Perhaps I'm simply more "OCD" about my logic games than other fans of puzzle games, but I found that the game was giving me too much information.

One "feature" fills in blank squares once you finish a row or column. This didn't bother me too much, as it mostly just saves time. However, they also cross off numbers for you before they should.

In a row labeled "2 2 3 3", no number should be crossed off unless there is no doubt it has been taken care of. However, if I were to fill in 2 squares in the middle of the row (and nothing else), this game crosses off the appropriate "2" for me. (or it doesn't, and I know I'm working on a block of 3). I found that this "feature" was ruining the game for me.

I finished 19 puzzles in my demo hour, but I won't be buying it. I don't use clues on this type of game and I certainly don't want extra information just handed to me whether I wanted it or not.
 
 
 posted in Farmers Market on May 4, 14 9:14 PM
I've played through this game at least twice with no problems, but this time I ran into the following:

On the level where you get an "additional" (i.e., not visible at the beginning) goal to have 3 strawberry stands...I think around lvl 41 or 42. I had two strawberry stands already up, but they did not register. I built a third one and only got credit for one of three. I tried taking down the "strawberry" portion of both other stands, then re-building them, and it still only registered that I had 1 of three. I'm sure the easiest solution is to not add any strawberries until the goal shows up, but it's definitely a bug.
 
 
 posted in Farm Craft 2 on Dec 2, 13 10:50 AM
It is badly named, unfortunately. You don't have to "turn it on" - the "Irrigation" system supplies water to a pump. In some levels, you must purchase an irrigation system to be able to plant or dig; it's not the same thing as a sprinkler, unfortunately.

I sort of wish they had come up with a different name for it, since you still have to water everything. In levels where you have to purchase (for $3000!) an irrigation system, I usually don't put in sprinklers, though - I hire watering workers. The cost of adding more workable soil is so high I'm not willing to give up any spaces to place the sprinklers.
 
 
 posted in Trainz Trouble on Nov 3, 13 3:22 PM
This is more of a bug within the game than getting it to run.

On at least two levels so far (I'm on about level 8 in the UK- second set of puzzles) I've had trains stop at a bank but not load. In the first case I played the level over and the problem fixed itself. At the moment, however, I'm in the position of not being able to complete a level.

I can get all trains to their end station, and even go past the correct banks, but only one of the three banks loads correctly onto a train, leaving it impossible to complete the level (this one require 999 gold, and there are 2 green & 1 blue banks each containing 500).

For now I'll just skip it and go on, but if the distributor has a fix for this it would be nice. I've gotten 3 stars on all levels so far an have only had issues with the banks in two of those.
 
 
 posted in Trainz Trouble on Nov 3, 13 3:18 PM
There is definitely a problem with the banks not always loading coins. I'm stuck on one level (UK) because my green train only loads at the first of two green banks, and the blue train doesn't load at all. I'll play with the speed controls & see if that helps. I've gotten three stars on every level up to this point, though. Fun game.
 
 
 posted in Magic Cauldron Chaos on Sep 27, 13 8:11 AM
I have played and enjoyed King's Smith 2...this is nothing like it. Aside from the "beat the imps to the products" problem, you have to first click the place where the ingredient is produced, then you have to click <b>again</b> to select the little gnome and then a third time on his destination with the item. It's absurdly easy to forget one step...in which case the game simply auto-selects one of the gnomes for you. It may not be the one you're planning on sending, and there's no way to intercept them once you click wrongly. Your ingredient is then wasted if it went to the wrong color cauldron.

In addition, you sometimes have to change the target color (of a garden, or the bottle factory, or whatever), and it's not easy to do. The game first assumes you're clicking on the ingredient, making you click multiple times before it gives you what you want, and wasting valuable time when there isn't much to spare in the first place.

I have to agree with those who said this game is a mess. It had potential, i'll say that much - I've been waiting for a TM with an interesting and well-developed concept to appear. Interesting, yes. Too clumsy & frustrating for me, however.

I'll give it a 1.5/5, for effort and the attempt to make something that's not "just another building game copycat". It's really not playable, though.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on Sep 21, 13 1:13 PM
Sorry I didn't see this earlier, but just in case you still need an answer...

The large blue crystals will be destroyed automatically after you finish a puzzle in a nearby room. There are a few places like this in these caves. Hope this helps!
 
 
 posted in Hollywood Tycoon on Sep 21, 13 1:08 PM
I'm trying to figure out what is left to get the final goal for "Tycoon." I have all 50 achievements, I've met the income goal, and I have upgraded everything I could find to its highest level. However, there is a little building icon that still reads 54/56. I have no clue what else I could build, assuming that's what it means. I do wish there was some larger list, as there is for the achievements, so I could find what I'm missing.

I have all the gear purchased. Every lot has all four spots purchased and repaired. What could I be missing?

Thanks to anyone who might have a clue. Fun game, otherwise.
 
 
 posted in Fairy Godmother Tycoon on Sep 15, 13 10:43 PM
Actually, with the first Sneersworth conversation, there is a way around it. If you have already finished all your research by the time this happens, he can't set you back. I set my research rate at 9 days and didn't mess with it (I think it automatically shows up as 12 days for the second potion). I had only 1 day left and Sneersworth showed up during that day-cycle to mess with me. When the day ended, I got my potion, so even when he came back the following day & I got the message about "lost research", it didn't have any real effect. I don't think you can get around the other two, however.
 
 
 posted in Northmark: Hour of the Wolf on Jun 8, 13 11:02 AM
I started a game with the ice mage, and I'm noticing it is pretty difficult to win anything. The first ambush went fine, but the first time I tried an arena battle I got trounced. Same with following the lady paladin.

I'm not unfamiliar with RPGs, tactics, etc - but it's frustrating to see 5 or 6 turns in a row get blocked completely. Against her, the basic attacks (bottom of the screen) are essentially useless.

So my question is: which class/character did you choose, and did you find it easy or hard to win most of the battles? I didn't expect the opponents to be very difficult when I'm only 15-20 minutes into the game...and I've lost 2 out of 3 fights (might be 2 out of 4?). Any input from those who have finished? I usually like RPGs, and I'd really like to figure out what I'm doing wrong before I decide whether or not to buy this one.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 9, 13 10:03 AM
If you mean how do you destroy the barrier, I'm pretty sure you have to have all three orbs. A star/circle icon should appear in the SW corner of the map for Brackenfell. Just stand on it and the barrier will vanish. I've never tried it without having the orbs, so I'm only assuming that is the trigger.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 8, 13 12:22 PM
Treasure vault #5 is accessed by the big double doors upstairs in Wilson Manor.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 7, 13 8:15 PM
If you are following the storyline quest you should have a quest to follow the "Monk's Trail". If you look at the in-game map it should be labeled on the Willow Woods area. (Or whatever it's called, the area between Riverdale & Python village)

You have to thoroughly explore the caves & rooms once you go into the Monk's trail...there are a few places where you need to destroy a blue crystal on the floor; once you do that, bigger crystals that are blocking an exit or hallway will also be destroyed, letting you through. There are either 2 or 3 of these places, I think.

Hope this helps. If not, please give more specifics and I'll do my best to answer.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 7, 13 8:11 PM
You won't be able to get a dog until you're almost to Quenera. There's a "dog" racing track by the city entrance; go in and talk to everyone. It will cost 420G.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 7, 13 8:10 PM
Can you be more specific? by "First treasure" do you mean the first vault? I can't remember what type of puzzle they are..sliding blocks turning the floor green, or something else? I'll do what I can but I can't go back to do each puzzle after they are done. I think that may be why these are so hard to give directions for.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 7, 13 8:08 PM
If you mean you are trying to go *back* to Riverdale after getting to the other side, just use the teleporter. The only hitch with that is, you can only return to a place you have been, and I think you have to walk right up to the teleporter in a town in order to use it later. Hopefully, you examined either the one in Riverdale or the one in Python village before you went through the Monk's trail. There is one on the path to Wilson manor that you can use to go back.
 
 
 posted in Adelantado Trilogy: Book Two on Apr 19, 13 11:32 AM
What level are you talking about? Either I sailed through it without hitting this problem, or I haven't gotten there yet.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator