Posts created by Linda1210

 
 
you have to take a chisel and finish carving out the flying monkey that is on the box lid. The spikes just seemed to appear the second time I tried to click on the shoes.
 
 
 posted in Clutter VI: Leigh's Story on Dec 5, 16 6:04 AM
As I drag them out, I put everything that starts with A-L on the left and M-Z on the right. Then it is easy
 
 
 posted in Northern Tale 4 on Aug 29, 14 7:55 PM
Well, so much for my powers of observation. I finally figured out that a new area opens up if you pay the Forester and the branch is in there. I hope this helps someone else who might be stuck.
 
 
 posted in Northern Tale 4 on Aug 29, 14 7:44 PM
Does anyone remember where the Tree of Life Branch is in level 47? I thought it would be in bonus level 2 but I have clicked every inch of that board many times and I still do not have that piece. Any help would be appreciated.
 
 
 posted in Northern Tale 4 on Aug 3, 14 11:28 PM
Thank you Fihill!
 
 
 posted in Northern Tale 4 on Aug 3, 14 7:34 PM
Can anyone tell me what level is ringing the bell?
 
 
 posted in Royal Envoy 3 Collector's Edition on Jun 19, 14 1:02 PM
I have noticed the pirates say this everytime they are paid and have said it in every installment. Is Mr Riskit one of the developers? I'm am just curious if it has some meaning to someone.
 
 
I see him making a gesture like he is operating an old movie camera. Maybe he is there to remind us to take a picture?
 
 
I never write reviews, but this game sent me here because I almost did not purchase it. It seemed to have more bad reviews than good. I am so glad I gave it a try anyway. I think it is wonderful. I do not understand why some didn't like it, but to each his own, I guess. I recommend you give it a try.
 
 
 posted in Kingdom Tales on Jul 20, 13 3:24 PM
I finally got it! Thanks for your help Csustar
 
 
 posted in Kingdom Tales on Jul 16, 13 6:39 AM
Any advice on how to get "Kingdom Time" on level 15? I miss it by about 10 seconds every time.
 
 
 posted in Phantasmat: Crucible Peak Collector's Edition on Jan 8, 13 6:36 AM
Same problem here. My game has no downed power lines and no rodent running around. Therefore no lock pick. Off to try reloading the game and starting over. At least it's not very far in.
 
 
I am having trouble with the seltzer bubbles puzzles. I click and click and only occasionally get a bubble of random size to squirt. Most of the time nothing happens. The puzzles seem like they should be very easy, but each one has taken me at least a half hour to complete because the bottle doesn't squirt like I think it is supposed to. Am I doing something wrong? Any advice?
 
 
 posted in Campgrounds on May 26, 12 7:05 AM
I finally got this level after many, many tries. The way I did it was, to not upgrade any houses. Start making wood immediately and build a greenhouse in the empty spot as soon as possible. Get both cars ASAP. Buy a few more workers as you can. As soon as you have enough wood for the pool, destroy the sawmill and build another greenhouse there. Build 2 ponds and a shrub as soon as you can. Put gardens on all 4 houses when you get a chance. Destroy the house in the upper right and build a pool. Try to time it so you can start an event at the pool while the guys are still right there from building it otherwise it takes too long to run someone back there. Really, the only difference I used than the other suggestions was not to upgrade any houses. Then you can destroy the sawmill that much sooner and build your 2nd greenhouse. I finished with a couple seconds to spare.
 
 
 posted in Roads of Rome III on Oct 9, 11 7:07 AM
Anyone else think your little guys look like the Beatles?
 
 
 posted in Roads of Rome III on Sep 30, 11 5:00 AM
Thanks for the advice! I am off to try it. I am afraid my problem is more lag than anything since it is much worse in episode 2 than the other episodes. But hopefully this works.
 
 
 posted in Roads of Rome III on Sep 28, 11 6:50 AM
I am also having trouble with slow, jerky movements even with custom cursor and weather effects turned off. I am stuck around level 2.5 since my guys won't move fast anough, I am so sad :-(
 
 
 posted in Roads of Rome III on Sep 28, 11 1:37 AM
I cannot seem to get expert on this one. Have tried 10 times or more. I always miss by at least a minute. Any suggestions?
 
 
 posted in Grim Tales: The Bride on Sep 16, 11 7:59 AM
Me too. I never skip any puzzles no matter how long it takes me. When a game bug forces me to do that I get so mad!!
 
 
In the Mayor's house (I think), in the room where you had to put the wheel on the chair, theres a spot on the wall at the entrance where you get a soul jar. There's a piece of coal right next to the jar
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator