Posts created by JerryInWales

 
 
 posted in Imperial Island 2: The Search for New Land on Nov 8, 14 5:51 AM
I liked Imperial Island 1, so bought this game on the strength of that.
Like most other reviewers, I felt it's not so good: slightly less crisp and generally not so rewarding to play.
I get the impression that someone sketched out the mechanics on the back of an envelope, for both games, and I.I.1 is the result from the 'A' team and this is from the 'B' team (sorry, chaps, if you're reading this!).
I think overall I recommend this game but would suggest that you try I.I.1 first...
 
 
 posted in Manor Memoirs Collector's Edition on Sep 22, 14 9:53 AM
To save a bit of someone's time: in a bathroom scene, you're asked for 3 combs, of which one is a brush!

Pleasant game so far (bought with game club credits) but basically bought untested because I like the others from Playrix. Runs fine on my Windows 7 Dell.
 
 
 posted in Dream Chronicles: The Chosen Child on Aug 19, 14 3:20 AM
It looks as though they have stopped stocking this game: none of the DC games show up if I do a search. Might be quite recent: a few weeks ago I upgraded from XP to W7, and had to reload all the BFG games. The DC games were OK.

Maybe I'll mail them: they may have dropped it by accident.
 
 
 posted in Patchworkz™ on Jan 28, 14 10:03 AM
Belanaparis wrote:there should be a way to remove/disable all timers!!! I'm sick of doing the fever games...I bought it, I should be able to play alll games in my own timeline. Its a great game if we ever get to finish playing it....


Fever mode is just the timed version of the untimed games, I think. So just ignore the fever button! Specifically, I think you can do just what you want, play all games in your own timeline, it's just that for the speed fanatics there's a small bonus of a few more (simple) games. That's true of the Android version, anyway: note that for that version there's a set of levels that you unlock by subscribing to a newsletter (which you probably get anyway!).
 
 
 posted in Patchworkz™ on Jan 28, 14 9:55 AM
By doing lots of the Challenge levels, I have unlocked several of these, despite only getting 1 star on most of them! You're told that a new screen has been unlocked by a little banner dropping down from the top saying which one it is ("Fairway 2" and so on.

So far all the ones I've unlocked have been very simple (6-8 pieces).
 
 
 posted in Aquascapes on Dec 12, 13 10:32 AM
pinkfish23 wrote:I agree...I thought I was the only one who had problems with the helicopter scene. I too exited to tank to get another scene. I tried it for nearly 30 min & decided life is too short.


Try exiting to main screen, choose a different tank, then PLAY again. I got a different (easier!) screen (at Level 85, for me).
I had fed the fish first, in case that matters.
 
 
 posted in Aquascapes on Dec 12, 13 10:26 AM
Try exiting to main screen, choose a different tank, then PLAY again. I got a different (easier!) screen (at Level 85, for me).
I had fed the fish first, in case that matters.
 
 
 posted in Aquascapes on Dec 12, 13 10:21 AM
I found a way of doing one of these without having to leave the game (I was at level 85): exit back to main screen, choose a different tank, and do PLAY again. I got a different scene to find the gold, no problem this time.
It might be significant that I fed the fish first.
 
 
 posted in Aquascapes on Dec 12, 13 10:15 AM
Looks like Level 85. Agreed it's not accessible in the usual way. Well done to solve it!

I got past Level 85 by a different trick: I went back to the main screen, chose a different tank, and having fed the fish, did PLAY and got a different scene to find the gold. No trouble this time, thank goodness.
 
 
 posted in Nearwood on Dec 1, 13 12:50 AM
To save the furry animal you need a net, found in one of the FROG scenes.
 
 
 posted in Holiday Bonus on Dec 1, 13 12:39 AM
Jadakiss2000 wrote:I bought this last year and enjoyed playing it. I too wish that you could save all the beautiful pictures to a folder to have as wallpapers.


The backgrounds do exist as separate files that you can choose as wallpaper: look in the folder where the game is installed (on a PC: right-click the game icon, select properties, then "Open File Location". Then click on "Data" then "Graphics". The pictures are bg1 to bg10.jpg.

So you can either replace with your own pictures, or copy these (as kdubs did) and use them as pictures for other BigFish puzzle games.
 
 
 posted in Finders on Aug 27, 13 11:15 AM
toomuchsht wrote:I meant to mention that I finished the game on level 29. I guess the game goes on until you rescue the guy.


I got to the "end of the game" - as you say, level 29 - and the screen said "The End", but being the pig-headed type, I went back to the main screen and said "Start" - and was able to carry on. I've been getting tasks (but see comments above). One interesting point: the achievement screen on getting to level 30 was in Russian! Not knowing the language I have no idea what it said, and I could not cut-and-paste the text. Maybe one of our Russian speakers can tell us!
 
 
 posted in Finders on Aug 22, 13 7:51 AM
You say "Jeep" - by now you should have bought the GPV, which is what I used to get the safe.
 
 
 posted in Finders on Aug 22, 13 5:40 AM
Valdy wrote:The tutorial should tell you when you should click on that icon at the bottom left, which is for the different buildings. Click on it, and select the "Storehouse". Then put it anywhere on your island.

Hope this helps.


The icon at bottom left opens into a window saying what you can buy for the camp - tents etc - and for each thing it will either give you a "buy" option, or will tell you why. You'll sometimes see "not available", or "not enough resources". Against each icon there's a counter, so you can see how many tents you are going to be able to buy, for example.

The same thing applies for the other tab in the window - vehicles. These become available as the game tells you to buy them.

(added) I forgot to say: when you are finding a place to put a tent/grill/whatever, look carefully at the little blue squares underneath the icon. If one or more is pink, you can't build it there. Don't forget it needs a person to build it - if they are all collecting stuff in the woods, you can't do it!

However, it's possible to move the item after it's built, the second icon from the left, at the bottom, allows this. Click there, then click the thing you want to move, when in the right place click ONCE, then go to the tick-thing just to the left, and click again.
 
 
 posted in Finders on Aug 22, 13 5:31 AM
While you are clicking on the mouse to keep the bar in the green (about 2-3 times per second, I find) you'll see a little white spot (tiny fish, I thik) moving from left to right just above the bar. When this spot reaches the right-hand bar, you've caught the fish. Sometimes you get the fish earlier
 
 
 posted in Finders on Aug 22, 13 5:23 AM
Improving the tents just gives you a bit more money each time.
 
 
 posted in Finders on Aug 20, 13 5:46 AM
Yes, the instructions are a bit vague! One of the more obscure things: you are told "Serve Tea" (etc.): you have to go to the Storehouse screen and "USE" it.

I was baffled for a bit when on the second island: it wanted Fish, but there was no fishing point. Back to the first island: fish but I needed bread. Everything had been packed into crates for me: no flour or kitchen!

In the end it seems that bread made on the second island is somehow available on the first island.

Someone was asking about fishing: if you have bread, click on the fish and you get a "fishing screen", with 6 "bait" to start with. Click on "cast", this goes grey (or gray!) and says "wait". After a few seconds (variable) it goes green and says "strike". Then you have to click the left mouse button many times, fairly quickly (say 3 times a second) and you'll see a bar along the bottom of the screen, with red markers at left and right. As you click, a green bar flickers along between these: you have to pace your clicks to keep the bar in the green. There's a tiny white marker just above this, which moves to the right as you click. When the marker reaches the right-hand red marker, you land the fish.
 
 
 posted in Finders on Aug 20, 13 5:34 AM
lazy_furball wrote:you can find the container on storehouse page. It's located on the bottom right.. Click 'use' then place it on the ground.

I have filled the container twice $300, how many times should I do it until it's enough? Thank you.


I think it's about 10 times. There was a little thermometer-thing just below and to the right of the picture of the container, and it slowly fills up as you pay for the "aid" crates.
 
 
 posted in Enchanted Cavern 2 on Jul 25, 13 8:35 AM
EimearMcA wrote:Really enjoy Enchanted Cavern 2 and would love a similar game, any suggestions?


After playing the demo of EC2, I prefer the style of the Season Match games - these are also click-on-a-group style. There have been reported problems with SM1 on the "trophy" section (after you've played everything else) but I've had no problems here.

EC2 somehow doesn't please me as much. The cutscenes are rather slow, and the gems are a bit 2-D. The locked gems are a bit harder than in the SM games: I think maybe the writers are not quite so generous in giving you the arrangements you need. Also, in the 30 mins I played, there were no player-selectable power-ups: the SM games do give some choice in this.
 
 
 posted in Night In The Opera on Jul 10, 13 8:52 AM
sewbizzy wrote:
But, what do the scissors do? I can't seem to use them in the M3 part of the game, so maybe they are for the other part?
.

Have just played the hour demo: like everyone else I find the whole thing rather odd.

Just got the scissors, but did not have time to use them. At a guess, they can cut the M3 roped-up bits. The spray bottle seems to remove 3*3 tiles, but I don't think it does anything with "special" tiles. Typical "bomb" thing but weaker.

Possible spoiler (but I think they should explain these things in tutorial!)

When you get as far as multicolour masks, you build up a single powerup at lower left (takes several sets of multicolours). Then if you click on the powerup, it clears the board and repopulates with new tiles - sort of "help I'm getting nowhere".

For M3 games, so much depends on whether the programmer tries to help by providing you with potential matches. They _have_ tried here, I think.

One other thing: the coffee beans don't fall off the bottom like the waterdrops or keys, but you can swap them. I got a bean at the bottom, a droplet just above, swapped them and won both. Also the splatty-things are just frozen tiles, match next to them and they slowly thaw and reveal what's inside (can be a key/drop etc).
Oh yes, you have to clear _all_ the special tiles to "win" the round. Getting the required tokens is not enough.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator