Posts created by orchidna

 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 12:33 PM
You're welcome.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 12:05 PM
All you have to do is walk out of town into Bluleaf Forest, or leave via MME or Red Warp Egg. You can immediately return and the contest will be on.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 11:55 AM
The Quill Shop is just to the east of the Post Office, which in turn is east of the library. The quills are on tables. If you look at them, the shopkeeper will respond.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 11:52 AM
FIrst of all, enter the opening just northeast of the Thief Lord's office, and see if you can afford any of the black market items being sold there. If you can only afford one thing, get the weapon. To get everything Mel can use, you will probably need to do some fighting in Bristle Woods to get enough gold. Once you've bought all the equipemnt Mel can use, equip it and venture on into the sewer. You'll find the cockroaches are a breeze then.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 11:49 AM
The Fauna Caves are in the southeast of Acropolis, the Mana Caves are in the northwest.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 11:47 AM
The data on your stat screen is correct, so go by it rather than the HUD bars at the bottom of the game screen.

This is a bug that is being looked into, and will hopefully be corrected in the update coming soon.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 11:42 AM
Frog:
Can only be done if you helped Rat get out of jail during the baby trade sidequest .. it is in Fahd's house in Tyobi. If you freed Rat, he will be on the east side of Tyobi east of the vendor stalls. Talk to him and help him to get the frog.

Circus Act:
Can only be done if you helped Hercules trap all five pixies, including blowing up the bridge. The pixies will then be in the Fauna Caves of Acropolis.

Bottles:
- Blueleaf Forest
- Circus
- Crystal Caverns
- Ashera’s Tomb
- Mana Caves
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 9:22 AM
You're welcome. Glad i could help.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 9:19 AM
Peliad is east of there, on the far side of the map. You won't need to get past the guard until you've done some other things.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 8:22 AM
Truth Serum
Just an FYI:
The recipe for Truth Serum was changed in one of the later builds, but isn't in the build BFG has for you right now. When BFG updates the game (soon), you will be able to make the serum, and won't need to restart to do so.

We apologize for this bug.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 8:08 AM
I will post them on the amaranthia forum in about 1-1/2 weeks.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 6:18 AM
Shoal Leiu is east of the Granite Mountains. Make your way all the way across the mountains from Wyrmbone Desert to the east exit, which takes you into Shoal Leiu. It's the only place you can go before learning Rock Climbing.
 
 
 posted in Aveyond: The Lost Orb on Feb 18, 10 6:13 AM
The recipe was changed in one of the later builds and sent to BFG. However, the one posted for you to download was an earlier build. When BFG updates the game, you will be able to make the recipe with the new ingredients. We apologize for any inconvenience.
 
 
 posted in Aveyond: The Lost Orb on Feb 17, 10 5:46 PM
I accidentally left the Worm Tunnels map out of the strategy guide, and I deeply apologize.

Since the Worm Tunnels seem to be the only place multiple players are getting lost, I have posted the map at the game maker's website. I don't think I am allowed to give the link here, but you can do a web search for amaranthia.

Again, to those who purchased the guide, I am deeply sorry I left this map out.
 
 
 posted in The Sultan's Labyrinth: A Royal Sacrifice on Jan 29, 10 8:47 AM
Thank you, Eldaphil.
 
 
 posted in The Sultan's Labyrinth: A Royal Sacrifice on Jan 27, 10 1:44 PM
I have the code (from the gathered pieces of paper) in my inventory. However, when i enter that code into the Jar's lock, it doesn't open. I have tried repeatedly, with no resolution.

I was planning on buying the game until i ran into that in the last 5 minutes of my trial. Now I'm scared to do so, since, if the code doesn't work, I can never progress any further.

Has anyone else run into this problem or does anyone have any solutions? My trial is now over, but I really liked the game up to that point.
 
 
 posted in Gobs of Fobs on Dec 28, 09 6:37 AM
Pepper010,

Thanks. I had tried to get them to go from anywhere other than the right side and been unsuccessful. I'll try again. although it's too late to get it for $2.99.

Thanks, again.
 
 
 posted in Fashion Assistant on Dec 27, 09 3:47 PM
I, too, found the game unplayable due to the totally uncontrollable cursor. It seemingly has a mind of its own.

Being able to turn the custom cursor off would have been a godsend. I don't know why gamemakers don't make it an option. Why a few games have mind-of-its-own cursors, while most other custom ones are completely fine, really puzzles me.
 
 
 posted in Gobs of Fobs on Dec 27, 09 3:34 PM
The game is very cute, but I have a question.

Some of the boards are impossible to complete as far as I can tell, because the colored squares are behind rocks. I can't find any way to make the fobs go to any squares behind rocks, and I've read the instructions twice. IS there any way to accomplish this?
 
 
 posted in The Magician's Handbook II: BlackLore on Jul 10, 09 3:02 PM
RoverD wrote:... the Crypt of Heroes Puzzle. I have found all of the pieces of the 6 statutes and the bases go down and "ding." But the scrool does not appear. I have referred to two differnet walkthroughs and seem to have found all of the items they have circled...



Please disregard my message below. I realized only one slab was locked down, so I started switching statuettes, and one combo took both all the way down. I thought the clunk indicated both were down all the way, but I was mistaken. I'm so happy to be able to continue now.

So, for others who run into this ... your correct combination may not be the same as in the walkthroughs. It wasn't for me.



I have the same problem. The stone slabs both locked down with a resounding 'thunk', but no scroll appeared and nothing else happened. I used a reveal, and it highlighted the two stone slabs. I resorted to checking walkthroughs, also (only found two). Both showed exactly the same statues I have on the slabs.

Please help .. what can I do to make the scroll appear?

Addendum:
I haven't been able to find the gold key it says is still there, but that wouldn't cause the scroll to not appear, correct?


I've tried lots of HOGs, this one I bought as soon as my trial ran out because I .like it so much. Shortly after, I hit this problem. I want to continue, it's such a wonderful game.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator