Posts created by melonrind

 
 
 posted in Awakening: The Redleaf Forest Collector's Edition on Jun 2, 14 11:57 AM
Never mind. I found it, too.
 
 
 posted in Awakening: The Redleaf Forest Collector's Edition on Jun 2, 14 10:56 AM
Where? I can't find it, either. I even turned to the strategy guide and it's no help.
 
 
Thanks for trying to help. I tried that and, unfortunately, it didn't work. I've given up and started over from the beginning, which is a bit annoying to have to do, but oh well.
 
 
I had crane tokens 1 and 3, and I used them both. After that, I realized I was missing token 2. I got it and went to use it, and the game tells me, "The right token will start the game." It won't take token 2, maybe because I used the tokens in the wrong order? As far as I know, there are no more tokens. I'm stuck. Any tips?
 
 
 posted in Farm Fables on Mar 16, 13 9:48 PM
How do you get enough money to upgrade the storage? I am not understanding this at all. The upgrades for the buildings are really expensive. Also, the hint in the game said that upgrading a plant is cheaper than buying two plants, but it isn't. This makes no sense to me.
 
 
 posted in Summer Resort Mogul on Mar 15, 13 5:27 PM
Following the instructions people have given here, I should have had everything done with time to spare, but I still can't get the income up to $20k. I had three houses, a bar, and the bungalow all upgraded to three stars, and my income was something like $19,400, not $20,000. The pool and the club don't provide income, just luxury, so I didn't upgrade the pool, and I only upgraded the club to the required 2 stars. What am I doing wrong, here?
 
 
etselec wrote:I'm enjoying the game, but while working on the torn canvas mini-game I'm having trouble getting a right-click to work. I try control-click which usually works in most games but is not working in this one. How does the game recognize a right-click on a Mac?


I'm having the same problem. I can't get the puzzle pieces to rotate using control-click on my Mac. Is there a solution to this besides skipping the puzzle?
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 26, 12 5:30 PM
I guess I'm the only one who didn't love it. I enjoyed it enough in the beginning to purchase the CE, especially with the Christmas sale going on, but in the end, I wished I'd skipped it. The puzzles were fun, if a bit easy, up until about 2/3 of the way through, and then, they suddenly seemed to lose all logic. Maybe I'm just overly tired, but I could not for the life of me figure out the strategy behind that flag puzzle, or the "swap the china" thing, or that annoying part where it kept telling me to add rivets to the armor but the rivets wouldn't stick. I was trying to get all the achievements, so I'll admit I lost some steam and interest in the game when I was forced to skip that flag puzzle (which I hope never to see in a game again) so after that, I didn't have much patience for any fussy minigames.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 26, 12 5:21 PM
Apparently, you're supposed to be able to swap items that are the same color or the same style, but there must be more to it than that, because I couldn't reliably swap, say, a red cup with a red plate, or a blue mug with a blue bowl. It seemed like the game was choosing at random which objects could be swapped with which. Sometimes, I'd click a bowl and it would show me that I could swap it with one other bowl or with a mug. Other times, a clicked bowl could be swapped with two other bowls or two plates. It made no sense.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 26, 12 5:19 PM
I never figured it out. I got the original parts off, then tried to get the new parts on, and it kept telling me I needed to put on the rivets first. And I tried and tried to get the rivets on, and they wouldn't go on. Finally, I just skipped the puzzle. I have to say, I ended this game on a really sour note. I liked it in the beginning, but once I hit that awful flag puzzle (which I am still convinced has no rhyme or reason to it) I was just over it. Not fun. I ended up skipping most of the puzzles after that just to get the whole thing over with, so I'll admit I didn't have much patience for this "rivets" nonsense.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 25, 12 8:59 PM
Update: I'm so frustrated that I enlisted my husband to help. He can't figure out what's going on with this, either. We are two intelligent, logical people, and neither one of us sees any rhyme or reason to this puzzle. How do you surround a flag? It seems like when the red flags get mine, they always make sort of an elongated pentagram shape. Is that the only shape that counts? If so, how do you make that shape without the red flags blocking you? I'm baffled.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 25, 12 8:45 PM
I feel so stupid, but no matter what I do, I can't get a single red flag surrounded. I've tried like fifteen times, and the red flags just always go exactly where I don't want them to. I've gone from loving this game to hating it in a span of ten minutes. Does anybody have a strategy for this puzzle? I've tried going around the edges, I've tried building up a blue zone, I've tried spacing my flags out all over the board, I've tried putting flags down on every other space, which is what the red flags seem to do, but nothing works.
 
 
 posted in A Gnome's Home: The Great Crystal Crusade on Nov 27, 12 2:46 PM
I'm glad I'm not the only one who finds this game unreasonably hard. I like a challenge as much as the next person, but not when the challenge is just to click really fast. Strategy challenges: good. Fast-clicking challenges: boring and frustrating. I'm regretting using a credit on this one.
 
 
 posted in A Gnome's Home: The Great Crystal Crusade on Nov 26, 12 6:54 PM
Despite the tips, I'm still stuck. I enjoy these types of games, and I like a challenge, but this is just unreasonably difficult, and the challenge is less about strategy and more about fast clicking. It doesn't help that the game freezes up a lot, so suddenly I can't click on anything for a few seconds at a time. I was looking forward to something like Roads of Rome, but this is just too hard to be fun.
 
 
I haven't seen anybody else with this problem yet, but I am having an issue with a part where you're supposed to iron a crinkled piece of paper. No matter where I click with the iron, it doesn't do anything. There's nothing else I can do in the game until this darn paper gets ironed out, and I can't do it. I finally gave in and consulted the strategy guide, which helpfully advises me to "use the iron twice on the crumpled part of the paper". Gee, thanks. I've tried that about a dozen times. Any ideas?
 
 
 posted in Royal Envoy 2 Collector's Edition on Oct 1, 12 10:09 AM
Am I missing something? The menu screen shows a clown in front of a circus tent, and there are green-haired clowns on the intro screens to some of the levels. I am baffled by this. There are no circus tents to build, and as far as I can tell, there are no clowns in the game. Or am I wrong?
 
 
 posted in Awakening: The Skyward Castle Collector's Edition on Aug 27, 12 9:12 PM
I'm having trouble with the HO scene with the dress to cut out, too. The scissors don't disappear for me, but when I try to outline the dress pattern with chalk, the game simply will not recognize it. I've done it perfectly, right on the dotted line, but still, nothing. I've done it dozens of times now, and I don't want to do it anymore; I just want to move on with the game. I started a separate thread about this to see if I was doing something wrong and if others had had this problem, but I didn't get any response. I'm thinking this must be a technical problem, because I don't see what I could possibly be doing wrong, here. It's very frustrating.
 
 
 posted in Awakening: The Skyward Castle Collector's Edition on Aug 27, 12 1:24 PM
In chapter 3, there's a minigame in a HO scene where you have to trace the outline of a dress pattern with chalk. There have been a few minigames like this so far, and none of them have been too finicky about the lines being perfect, but this one just will not work for me. I must have tried tracing that thing twelve times, and I've been staying on the dotted line pretty well, and still, no dice. Did anybody else have this problem?
 
 
 posted in Surface: The Noise She Couldn't Make Collectors Edition on Aug 16, 12 11:10 AM
I feel really stupid, but I'm totally stuck on this minigame with the bubbles and the little paper boat. I hate this kind of minigame, and the strategy guide is no help. The only walkthrough I could find was a video of someone doing it, and it wasn't particularly helpful, either. I was enjoying this game quite a bit until I got to this stupid thing. Any tips?
 
 
 posted in Campgrounds on Jun 5, 12 7:26 PM
Does anybody have an alternate strategy for this one? It's driving me nuts.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator