Posts created by indian49

 
 
 posted in The Promised Land on Jul 12, 12 11:46 PM
I am having the same problem. First hungry man was dropped at table over and over and won't eat. It shows he wants ham which there is plenty of in the warehouse where ever that is but it won't give me one and he won't eat. I can't go any further.
 
 
 posted in All My Gods on Mar 2, 12 7:55 PM
That worked, thank you so much!
 
 
 posted in All My Gods on Mar 1, 12 9:51 PM
I have already studied all that and cleared the swamps, built on them. I keep clicking on the lava cracks and it says they can be fixed but how? And how far into the game do you have to get before you can do something with them? I still have 1 soldier to rescue in it and can]t get to him. Already have a road from the stairs to the main building but still can't do anything to get him out and cover the lava.
 
 
 posted in All My Gods on Feb 29, 12 9:41 PM
How do you clear the lava so you can rescue the last soldier and build the temple?
 
 
 posted in All My Gods on Feb 29, 12 9:30 PM
You can take the hand of the god and grab more stones from the quarry until your manna is used up then when it refills, if you need more do it again.
 
 
 posted in Royal Envoy 2 on Feb 19, 12 9:36 AM
it worked like a charm, thank you so much! I didn't notice the dove cote has been added to the building section and now when huge happiness is required, i know what to do.
 
 
 posted in Royal Envoy 2 on Feb 18, 12 7:01 PM
I didn't see anything for a dove coat in that level but will try again and see, will let you know. Had dove coats in an earlier level though. Thanks
 
 
 posted in Royal Envoy 2 on Feb 16, 12 11:41 AM
This is the level that requires you to free the little green tax collectors, build 3 upgraded homes and get 300 happiness. The happiness is the problem. There are only 4 lots to build on with maximum 50 happiness each, you repair lamp posts, have an everlasting berry bush but I still have fog in the background behind and to the side of the 4 building lots and the stream. My mouse does not detect any more lamp posts to fix and expose more lots. Am I missing something or is the game messed up on that level?
 
 
I tried playing the trial version last night and the mouse has no control. Has anyone else had that problem? I played another game as soon as i got out of it which took a few minutes as the mouse wandered all over the screen, hard to click on anything but my mouse works fine for other BFG games.
 
 
I believe if I remember corectly the handle is given to you once you wake the Puppet master and color his tatoos. I have already gotten the last leg but don't remember where Sorry.
 
 
 posted in Murder Island: Secret of Tantalus on Feb 1, 11 5:30 PM
I am stuck and need some help here. I can't find the pass card to get into the door in the mansion and I can't find the code to access the little unlocked safe door on the yaht. I have been to every location over and over and there are no new hidden object scenes to aquire these 2 items. I did find the third ring I was hunting for finally and gained access to the island owner'[s house but can't get the locked door open inside without that pass code card. Help Please.
 
 
 posted in Murder Island: Secret of Tantalus on Feb 1, 11 1:20 PM
Re: the 5 apples, did you find the eye and shield in that same scene? They have to be placed on the wall to your right . There is a carved person on the wall missing those 2 parts, the apples will then all stay in place and certain ones go on each side.
 
 
 posted in Murder Island: Secret of Tantalus on Jan 31, 11 11:18 PM
The steak scene has only 1 steak but 2 actions you have to take before you can clear it off your list. Put it on the grill and find matches to light the grill. As for some of the technical issues some of you are having, i did too for awhile with other games that I have played many times and suddenly none would either load or i'd get an error message. it turned out to be my spyware and antivirus program that updated to a new version. Everything game wise stopped working and once i uninstalled the prgram i was using all worked fine and of course i tried uninstalling games and game manager first and re installing and nothing did any good. De activating the program didn't work either. i also find Firefox does not always support these games. I have no problem with IE. Sometimes you have to do other things first before it will let you do what the screen says is next. There are 2 places you need to find oars, one is to get to the cave, the other is to get to the yaght.
I am stuck too and can't find the 3 rd ring to open the tower door. You just have to keep jumping from place to place to see if there is anything to find before you complete the task at hand. I got a couple suprise Hidden object scenes in places i had already been and found tools i needed like with the ladder. One board is to the right of the tower. Another I think is near the gardener. Then one of the places has a hidden object scene where you get the nails and hammer. Sorry i can't remember where. Wish they had a walkthrough!!!!
 
 
 posted in Gardenscapes on Jan 31, 11 11:55 AM
I am in the same place, all the rooms are open except the one in the right side tower, I have played this multiple times and that one never opens. Also you do get money for finding the 20 items from the letters you receive and it is tallied at the bottom just like the sales. I have never gotten Austin's list and have earned over $150,000 after winning the contest and buying everything there is to upgrade. Bigfish couldn't tell me if there is any more to the game as they haven't played it.
 
 
 posted in Murder Island: Secret of Tantalus on Jan 31, 11 11:46 AM
I love the game too but I can't find the third ring to get in the door to the island owner's door. I found one in the tree near the door and one in a wardrobe in one of the guy's rooms. where is the third. been jumping from site to site with no luck.
 
 
 posted in Gardenscapes on Jan 15, 11 10:57 PM
Once you have bought at least one of each category of item , you should get the winning notice of the contest in the newspaper Austin shows you. I haven't gotten the dog show notice and I have played this game many times, have bought all items and no new lists come up as said in the hints. When I finished the game once and bought everything else through design mode after winning the contest Austin says we need some furniture in the gazebo yet no options come up to buy new stuff.
 
 
 posted in Gardenscapes on Jan 12, 11 12:21 PM
I have played it to the end several times, bought all the choices several different ways. Fun game love it but am confused as occassional in the hints it says once all available items have been purchased, start another sale and new items will be availabel. Well I have yet to get any new items no matter which way I buy all the choices.
 
 
 posted in Gardenscapes on Jan 12, 11 12:11 PM
I love the game too and have played it over and over all different ways. The hints tell you once you have purchased all items, you start a new sale and new choices will be available and in one place when I had done all that, the gardener says it would be nice to have some furniture in the gazebo but yet no new items come up to buy. Anyone have a clue on that?
 
 
 posted in Bigfoot: Chasing Shadows on Aug 23, 10 10:39 PM
I started the game over under a new player and have the same problem. I tried clicking on the left side of the chair but I did turn them all upright before i tried to clean them. Still same glitch.Nothing works to get that foot print cleaned. I am fed up and I hope bigfish does something to fix this

After writing tech support, I tried a 3rd time from the beginning and that is the trick. Don't turn up the chairs before you try to clean them. Worked perfectly this time.
 
 
 posted in Bigfoot: Chasing Shadows on Aug 22, 10 7:15 PM
I don't know if this is a glitch or not but I am at the part where her house has been broken into after she finds the barrel in the water. it says to use the sponge to clean up the foot prints. I got them all gone except the one on the chair.lt won't go away no matter what i do. Is this a problem or am i doing something wrong? There is still that 1 boot print left on tasks and hints just circle the print on the chair.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator