Posts created by gmmace

 
 
 posted in 9 Elefants on Sep 16, 14 1:04 AM
I only played a few minutes, but there's way too much reading and hardly any actual gameplay. I have to pass on this one.
 
 
 posted in Statue of Liberty: The Lost Symbol on Aug 25, 14 4:42 AM
DragonLadyOz - custom cursors almost alway drag on my pc. It makes trying to click on anything really frustrating. Most games give you the option to turn them off.
 
 
 posted in Statue of Liberty: The Lost Symbol on Aug 25, 14 12:59 AM
Would like to have tried it, but there's no way to turn off the custom cursor, so it's unplayable for me.
 
 
 posted in Weather Lord: In Pursuit of the Shaman on Aug 18, 14 2:51 AM
I love the graphics and like the gameplay, but I hate the timer. Not the fact that there is a timer, but once the gold level gets to a certain point, instead of continuing to tick down, it jumps down to the silver level. Hope that makes sense. You really have to keep an eye on the timer.
 
 
 posted in Northern Tale 4 on Jul 31, 14 1:14 AM
I've purchased the previous Northern Tale games, and I only played a few levels, but I really don't see anything new here. It was probably the same in the previous games, but I really hate when these time management games don't allow you to chain tasks. I think I'll have to pass on this one.
 
 
VJSS wrote:Game was running great until I went into the shipyard in Scotland. The picture went to black and white streaks, I had sound and a cursor but could not see anything. I uninstalled and installed again, but same thing. I own all the other games and they run fine.


I ran into the same issue in the shipyard, in the castle courtyard and again in the grand chamber. You can move past it using the hint buttons to figure out where to click and you'll have to skip any puzzles, but you aren't able to see what you're doing. And there's probably hidden crowns in these areas that you won't be able to collect. I don't know how close I was to the end, but three times is enough. I give up on this game and will be asking for a refund.
 
 
VJSS wrote:Game was running great until I went into the shipyard in Scotland. The picture went to black and white streaks, I had sound and a cursor but could not see anything. I uninstalled and installed again, but same thing. I own all the other games and they run fine.


I am having the same issue. I don't know if I'll be able to get past it, but I took a video recording of the issue and I'm sending it off to Tech Support.
 
 
 posted in Fright Collector's Edition on Jun 29, 14 9:22 AM
I'm on the fence on this one. I'm getting pretty sick of princesses and fairies and all the cutesy themed games, so this is a nice change of pace. I tend to skip most cutscenes anyway, so the non-syncing voiceovers don't bother me too much, but the gameplay is clunky at times. I like the game, but I will probably wait for the SE.
 
 
 posted in Haunted Manor: Painted Beauties on Jun 26, 14 12:42 AM
I played about 20 minutes of the demo. I enjoyed the game, and would have purchased it, but the map was a deal breaker. I don't like having to use the hint button if I can avoid it, so I like maps that show you where tasks can be accomplished. The map for this game is virtually useless. A no-buy for me. In reading some other reviews of the Collector's Edition, it seems like quite a few people mentioned this when beta-testing the game. It's a shame the devs didn't change it before they released it.
 
 
 posted in Lost Souls: Timeless Fables on Jun 6, 14 3:12 AM
I had the same issue. I exited the game and went back in and the inventory items I had already collected from the wharf had disappeared and I had to collect them again. Still ran into the same problem at the beach.
 
 
 posted in Witch's Pranks: Frog's Fortune on May 7, 14 5:19 AM
I also had an issue with the cursor. I always turn the custom cursor off and once in a great while there will be a game that still has a dragging cursor, but never to this degree. I've already got the most recent drivers for my graphics card, so I don't think there's anything else I can do. I could barely get the cursor to respond enough to exit the game. It's a shame, because it looks like a fun game.
 
 
 posted in Through Andrea's Eyes on Feb 25, 14 5:56 PM
ladykokopuff wrote:
NicoleKathryn3 wrote:when you drink the drink press skip


THANK YOU! I was finally able to get past the turtle but I am now stuck in the attic.


Was anyone else able to get this to work? I've tried several times but it still freezes up
 
 
 posted in Through Andrea's Eyes on Feb 13, 14 11:46 AM
NHLMR wrote:i am stuck at the turtle to- did every thing you said i should do- still does not work do we get credit for this game


@NHLMR - you shouldn't have any problem getting a replacement game if you report your issue to Tech Support. Just run a Dr. Felix report and attach it to your message. That's what I did and I received a coupon code for a replacement game.
 
 
 posted in Bluebeard's Castle: Son of the Heartless on Feb 12, 14 7:13 PM
It took me a while to figure out to click and hold to drag the wheels around. Drag the wheel to the starting direction/number, the follow the arrow direction to get to the next direction/number.
 
 
 posted in Through Andrea's Eyes on Feb 10, 14 9:34 PM
I wrote to to Tech Support about the game freezing issue at the turtle. They suggested I try running the game in administrator, but it made no difference. They gave me a coupon code to replace the game, so it appears that there is no definite resolution. I guess all we can hope for is that the developer cares enough to try to correct the issues.
 
 
 posted in Through Andrea's Eyes on Feb 9, 14 10:13 AM
I'm also getting stuck at the turtle. I didn't even install the game until after the updates had been posted. I soon as I place the seat on the turtle and drink the potion, I get a black screen with a little red circle with a slash through it. Has anyone managed to get this resolved? I'm really not willing to start again with a new profile, just to get stuck again.
 
 
 posted in Mythic Wonders: The Philospher's Stone on Feb 3, 14 4:43 PM
Beautiful and fun game. I only have one complaint - the cursor. I always turn off the custom cursor because it's always sluggish on my computer. When you turn off the custom cursor in this game, it just turns into a smaller version and it's just as sluggish as the regular custom cursor. It didn't seem bad in the demo, but I bought the game and I'm certainly noticing it now and it's a pain.
 
 
 posted in Excursions of Evil on Jan 15, 14 12:24 AM
ajwiggin wrote:How Is this the new game release for tomorrow when there are reviews of this game dating back to Oct?


I was wondering that as well. It looks like this game may have been released last year as Mac only? Is this really the TGT?
 
 
 posted in Secret Trails: Frozen Heart on Jan 3, 14 5:10 PM
I got it worked out. I ended up having to uninstall FlashPlayer completely, then uninstalled the game. Then I reinstalled the demo and followed the prompts to install FlashPlayer and the demo ran fine after that. I ended up with the same version of FlashPlayer that I had in the first place, but whatever works.
 
 
 posted in Secret Trails: Frozen Heart on Jan 3, 14 1:44 AM
The demo seems to install just fine, but when I try to play it I get the error message "Please install the latest version of FlashPlayer using Inernet (sic) Explorer to play this game." I'm using Chrome and and already have the latest version of FlashPlayer. Tried uninstalling and reinstalling and still have the same issue.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator