Posts created by rxpcgal

 
 
 posted in 12 Labours of Hercules IV: Mother Nature on Sep 3, 16 2:31 PM
Sorry, it's a late response, but if you haven't found it, it's right dead center under the trees on the stone platform. Took me a while to find it and then I saw your post. Hope this helped!
 
 
 posted in Cathy's Crafts Collector's Edition on Aug 23, 16 4:53 PM
Any button I press minimizes the game. Created profile. Clicked PLAY, minimizes.
Opened back up, clicked another profile, clicked, PLAY, minimizes. Opened back up, Clicked CREDITS, minimized game. OPened back up, couldn't get out of the credits, so I hard closed it.
PC - Windows 10
 
 
 posted in The Tiny Tale on Oct 14, 13 4:34 PM
I know where the mushroom village is (to the right of the ogre path, there's a bridge to the right of that to build, the village needs 1000 coins), but I'm stick and can't finish with expert time, I finish halfway through the regular time.

So basically I need help in finding a more efficient way to complete this. This is the last level that I need expert time on!!
 
 
 posted in Monument Builders: Notre Dame on Aug 11, 13 11:05 AM
Yeah, I was stuck on this one, and I saw this post and a lot of people viewed it but no one responded.

So I was able to try many things, but I finally figured out how I could get started:

Grab the stone
chop the 2 woods
smash the stone above that (the donkey won't move because of the road)
but get the gold behind him
to the left, build a quarry (will have 10 gold leftover)
once you get enough stone, you can repair the road to cross over then build the bank

you can take it from there.

Good luck if you haven't figured it out yet, but if you have, good luck to others who are in this spot.
 
 
 posted in The Jolly Gang's Misadventures in Africa on Nov 12, 11 3:26 PM
Click somewhere outside the area to close the plane/wheel popup. Go underneath the floor to the tunnel and use barbie2477's advice to unlock the hatch.
 
 
 posted in The Jolly Gang's Misadventures in Africa on Nov 12, 11 3:08 PM
I did gather all the planks of wood (#7), the hammer and the nails. Went outside and tried to place the wood/nails/hammer on the tree, and it keeps saying not a good idea. The closest I came was placing the wood on the tree and she said, "Nah, Boar is a hammerhead himself."
Is this a glitch? The hint, isn't working as well. I even tried to place the hammer/nails/wood over each other to "build" a ladder.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator