Posts created by AeronAoife

 
 
 posted in Dark Dimensions: Blade Master Collector's Edition on Jun 26, 16 4:26 PM
Same here. Was just trying to figure out if I could go back to find the missing pieces and it wouldn't let me.
 
 
 posted in In Search Of Treasure: Pirate Stories on Dec 16, 13 5:44 PM
I only played two minutes and had to shut it down. The **** sound literally made my brain hurt and I couldn't stand it any longer. I like playing with sound and not having it detracts from the game, IMHO that is.
 
 
 posted in Kingdom's Heyday on Dec 4, 13 6:28 PM
It was only level 4 or 5.
 
 
 posted in Kingdom's Heyday on Dec 4, 13 5:12 PM
I'm positive I didn't sell the buildings. You have to physically click on them and select to sell them and the only thing I did was upgrade them then gather gold. It happened to all five houses in one level and I'd remember if I sold all of them. I was actually upgrading one house when I saw a house several lots away go black. When it happened to one house on the previous level, I thought maybe I'd accidentally sold it but five in one level, not likely.
 
 
 posted in Kingdom's Heyday on Dec 4, 13 3:57 PM
I don't understand why buildings that are generating income all of a sudden go black and say "Not your building." What is happening with this?
 
 
 posted in The Far Kingdoms on Nov 19, 13 10:22 PM
I like Match 3 games and HOGs but not in the same game. I actually groaned after the fourth or fifth match 3 came up. They made no sense in this game and made it progress extremely slowly.

The music was good but annoying as it continued to build in volume and then stayed there for far too long.

The storyline was okay but a bit disjointed and having the text "type" out instead of putting it up all at once helped to make the game seem far too slow.

The HOGs weren't too hard but did have some spelling issues. I liked the graphics, they were lovely and nicely done.

If you don't mind match 3's in your HOGs or HOGs with your match 3's, then this game is not bad, just not for me.
 
 
 posted in Island of Death: Demons and Despair on Oct 23, 13 6:37 PM
Not a bad game, but sorely needed a tech editor to go over it before it was released. There are multiple items misnamed, such as a gear called an "asterisk," an oil can listed as a butter dish (item needed for inventory so considered this a huge error), and gems called a "stone amulet" then called "pebbles" in the mini game - just to name a few. There's even a place where you find part of a trunk and it says, "I need something heavy to break open this trunk" and this is long before you ever even know there's a trunk somewhere to be opened. There are also improbable situations such as having to use a key card to even leave your hotel room and a simple road barrier you could step around or over, but no, you have to find a key card. The hint system is also error ridden, sometimes taking you back to a place where you already completed an action and when you click where the help system says to do something, nothing is there to do or you don't have the right inventory item to do the step it wants you to do.
 
 
 posted in The Torment of Mont Triste Collector's Edition on Oct 14, 13 7:21 PM
Two examples of getting code when using an incorrect item:

1. Placing empty bucket on fish out of water
2. In Boy's Dream, trying to place half wolf face on cage box before removing face panel

Exception raised: Not_String.XML_univeral_wrong_item
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Sep 16, 13 9:58 PM
I haven't had any problems with it not staying in place since it opens at exactly the spot I'm at in the game.

I do have issues with it not being available within the game and that when you close it, the guide contents comes up and you have to close it as well. I'd much prefer a contents button within the guide and if I want it, I can click on it. Basically, it takes four clicks to get back into the game when it should only take one.

There is also a lot of missing text. It tells you to get something but doesn't necessarily tell you where it is or that you have to click on something to bring up a window.
 
 
I've gotten all the spots where the schematics are as shown in the first post of this thread and it still says I only have 7 of 8 of them. I've checked, rechecked, and triple checked and I should have all of them but no go.
 
 
 posted in Mystery Murders: The Sleeping Palace on May 8, 13 6:36 PM
I have a scarab and Redmond Crest as well as the razor, manhole key, and a cog. I cannot go any further. I can't get into the library as I need the square item to activate the device in the right hand hall.
 
 
 posted in The Heritage on Jan 31, 13 10:14 PM
I'm at the end of chapter 19, I placed the wing on the angel and the ceremonial candle piece showed up on its shoulder (I'm assuming it's was piece 4 since the hint says the fragments are all completed and that's the only piece I have left in the scene). I clicked on it but it's not registering as being picked up so it's not completing the item which means I can't continue.
 
 
 posted in Botanica: Into the Unknown Collector's Edition on Oct 21, 12 5:26 PM
Does it still cost two game credits though?
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Oct 12, 12 8:18 AM
I got about halfway through the demo and decided to visit the shop and got a black screen with the inventory panel at the bottom. I couldn't get out of the screen and had to manually close the game. When I went back into the game, it started me off back at the beginning.

Until this, I had no issues with the game itself. Really not up to replaying what I already played only to use up the rest of the demo period and not get any further than I was before this happened.
 
 
 posted in Adelantado Trilogy: Book One on Sep 17, 12 4:45 PM
I like this game but there are two things keeping me from getting it (besides being unemployed and not having the cash so I'd have to use precious game credits): (1) You can't repair or demolish abandoned buildings and (2) you can't save your progress.

I lost all progress on the second level because I had to take care of one of the dogs and if I'd paused it, I would have lost 20 minutes of the demo period. In addition, the gameplay was just a bit too slow for my taste but I did like that I could place buildings where I wanted them. Not being able to repair or demolish buildings is a big shortcoming in this game as it means when you need to replace it, you can't re-use the space and then you start running out of space right where you need it. I'd prefer to be able to repair it and continue.
 
 
 posted in Kingdom Chronicles Collector's Edition on Jun 14, 12 5:01 PM
Since it's been confirmed that there are only six bonus levels, I'll wait until the SE is released to get this. For a CE price, I'd expect to have at least as many extra levels as in the base game, like Royal Envoy has. Just adding the integrated guide doesn't cut it for double the price - I'd only pay an extra dollar for that.
 
 
 posted in Kingdom Chronicles Collector's Edition on Jun 13, 12 9:04 PM
Love this game and as others have said, it's a mix of Roads of Rome, Royal Envoy, and My Kingdom for the Princess, but has it's own charm.

I would really like to get this but not at the CE price if there are only six extra levels as someone else posted. For the CE price, I expect a similar number of levels as in the main game, like Royal Envoy did.
 
 
 posted in Haunted Hotel: Charles Dexter Ward Collector's Edition on Jun 13, 12 7:53 PM
I did not like the previous games in this series so wasn't prepared to like this one, especially since I'm not a big fan of games with occult overtones, but this one I liked, at least from the demo.

The graphics were clear on my screen, very little that I'd call grainy, the music didn't bother me and I eventually tuned it out for the most part, the stretch screen worked for me, and the mini-games weren't too hard (at least in the demo). I had no delays between scenes loading and the game cursors worked without any issues. I did notice in the guide that one of the thumbnails was wrong, for the wire game on the electric pole. The image that displayed was correct but the thumbnail was not the same as the actual image. Oh, and a few grammar/spelling issues but nothing major (not enough to really bother a tech writer, which I am).

The basic story line is one we've played before but hey, there are only so many stories that can be turned into games that people will play or that even make a decent game.

I recently lost my job so getting the CE version isn't in my budget but I just might get it when the SE version is released.
 
 
 posted in Snark Busters: High Society on May 24, 12 10:22 PM
The thing I found was that despite the image shown in the walk through, you cannot get the photo to get outside the frame. You get it as close as possible and then after you click the red button, parts of the photo show outside the frame. I spent a long time trying to get it to look like the image in the walk through and it just never worked.
 
 
 posted in Whispered Stories: Sandman on May 21, 12 5:29 PM
Not sure about this game, it just didn't grab me so probably won't be buying it unless I decide to get it when it's a daily deal.

I didn't like how the characters responded to questions I apparently asked but never heard or actually asked. I got stuck at the mouse thing because I couldn't find what I needed for the safety glass and despite wandering around and trying to find what I needed, got nowhere fast.

I also couldn't get past the thought that the game is from the viewpoint of a young boy yet the tasks are for things you probably wouldn't expect a child that age to be able to think through or accomplish. Yes, some kids might be able to but I wouldn't allow a child to handle acid either no matter how smart they are.

The graphics were well done but most look as if they came directly out of a 3D modeling program, so a little too "3D" for me. The text for the menus and dialog was pixelated as well.

The story is a nice change from the usual fare lately but still has ghostly figures that try to help in some way. Game is a maybe for me in the future but only if I've nothing else to get.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator