Posts created by Loupep

 
 
 posted in Harrowed Halls: Hell's Thistle Collector's Edition on Oct 27, 17 2:13 PM
stuck in living room, chapter 4, can't complete doorknob puzzle, can't reset or skip either, has anyone else had this problem?"
 
 
 posted in Grim Tales: Graywitch Collector's Edition on Feb 7, 17 10:43 AM
also stuck in bonus game in doctor's ofc. third day I've tried to solve problem with no results.
 
 
 posted in Vermillion Watch: Fleshbound Collector's Edition on Jan 30, 17 8:26 AM
thanks for the help
 
 
stuck in library in bonus chapter cannot pick up lion head medallion to combine it with broken paw and golden claw. has anyone else had this happen? guide does not show any steps for letters "Q" & "R" jumps from "P" to "S".
 
 
has anyone else had trouble collecting the enchanted tree bark????????????
cannot collect this . thanks
 
 
found key to barts room. key disappeared when I clicked in inventory to use it. can not advance in game. has anyone had this problem? thx for your help
 
 
 posted in Christmas Eve: Midnight's Call Collector's Edition on Dec 11, 14 1:17 PM
have downloaded game twice. game will not let me turn dial on safe. I have the combination and have tried multiple times to open it . if this fixable , or I can skip and still open the safe in Robert's house. please help
 
 
 posted in Haunted Legends: The Stone Guest Collector's Edition on Nov 18, 14 6:50 AM
stuck in chapter 3 trying to collect 3rd beer mug chained to outside of caged tree. have adjusted/ moved chain 4 times to free mug, several times. any help is appreciated.
 
 
 posted in Haunted Legends: The Stone Guest Collector's Edition on Nov 16, 14 7:33 AM
stuck trying to free 3rd beer mug chained to bottom right outside of caged petrified tree. have tried to adjust/move chain 4 times without success. did anyone else have the same trouble?
 
 
tried to give carrot to rabbit even after following suggestions from forum and from tech support still a 'no go' . very disappointed i was not able to skip this task and continue on to complete game. I will use my game credit on something that is not as frustrating or feels like a waste of time.
 
 
 posted in Ominous Objects: Family Portrait Collector's Edition on Jul 19, 14 3:32 PM
i followed the instructions for crossbow and also had the same problem. . very frustrating to happen near the end of the game.
 
 
 posted in Chronicles of the Witches and Warlocks on Jun 26, 14 11:09 AM
I am also stuck in the cave. I deleted the game and did a new download and also shutdown & rebooted my laptop. all i could access was the map, only had access to several areas on the map around or near the cave. once i accessed these areas I had access to cave. Could not do any tasks.
 
 
I didn't read entire credits at end of game. Can't find/and or access Bonus Chapter. Do I need to play game a second time to access it? Thank you for your help.

Loupep
 
 
 posted in Shadow Shelter on Feb 1, 14 5:06 AM
ennasor, thanks for info.
 
 
 posted in Shadow Shelter on Jan 31, 14 9:18 AM
trying to pick up glowing runes. I have physical disability and cannot pick runes fast enough. has anyone else had the same problem? is skip button available?
thanks for your help.
 
 
 posted in Haunted Train: Spirits of Charon Collector's Edition on Jan 12, 14 6:59 AM
Thanks, penny1942.
 
 
 posted in Haunted Train: Spirits of Charon Collector's Edition on Jan 11, 14 12:08 PM
can't break dome after pressing gems in required shape. I have pressed gems illustrated in strategy guide without success.
This occurred after two separate shut downs of game, and after finding there was a discount offered for purchase of any CE game.
Very disappointed, that I am unable to correct or skip this part of the game.

 
 
 posted in Fairy Tale Mysteries: The Beanstalk Collector's Edition on Oct 20, 13 12:29 AM
Help, I'm stuck in courtyard and can't find the sling. Has anyone else had the same problem?
 
 
 posted in Timeless: The Lost Castle on Aug 12, 13 4:11 PM
I am stuck in castle dungeon, i have collected 4 of 5 chalk pieces. but i cannot find the right tool/ way to remove previously removed brick from left side of cell door. can anyone help?
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on May 24, 13 7:18 AM
having trouble with red candle placement, have physical disability. could someone clarify this for me?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator